Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: BAT mod installation help, Please.  (Read 1677 times)

0 Members and 1 Guest are viewing this topic.

Joes44

  • member
  • Offline Offline
  • Posts: 8
BAT mod installation help, Please.
« on: February 21, 2024, 04:35:22 PM »

I HAVE IL-2 46 4.04M DISK VERSION INSTALLED IN IT'S OWN FOLDER LOCAL DISK C/GAMES/ IL-2 46 GAME DISK.
I HAVE YET TO SUCCESSFULLY INSTALL THE MODS.
I AM INTERESTED IN ONLY WWII MODS.

I HAVE THE FOLLOWING MOD FILES DOWNLOADED IN A SEPARATE FOLDER IN THE SAME DRIVE ;LOCAL DISK C / GAMES /BATMOD.

1) SAS IL-2 4.12.2M MEGA PATCH . TORRENT
2) SAS IL-2 4.12.2M MEGA PATCH
3) BAT V4.1 BLUE EDGE INSTALLER
4) BAT V4.2 FLASH POINT INSTALLER
5) BAT ZIPPED FILES; 4.1_01 THRU TO 4.1_07
6) BAT 4.0 RED CORE TORRENT
7) BAT 4.1 BLUE EDGE TORRENT
8) BAT_4.2.1_ UPDATE.PART1
9) IL2 4.12.2M MEGA PATCH.PART01 THRU TO PART 12

I"M NOT SURE OF WHICH OF THE ABOVE FILES ARE TO BE UNZIPPED FIRST, AND IN WHAT ORDER?
THE TORRENTS?
MEGA PATCH?
BLUE EDGE INSTALLER?
FLASH POINT INSTALLER?
RED CORE TORRENT?
SHOULD I FIRST MOVE THE BAT_4.2.1 UPDATE  TO THE IL-2 GAME DISK, THEN UNZIP?
UNZIP FIRST THEN MOVE?


 
Logged

Frankiek

  • SAS Team
  • member
  • Online Online
  • Posts: 2368
Re: BAT mod installation help, Please.
« Reply #1 on: February 21, 2024, 05:20:12 PM »

If you have a 4.04 version this is not IL-2 1946 but most likely Forgotten Battles+Ace Expansion Pack+Pacific Fighters normally called 4.04m

The Megapatch will just upgrade from 4.07 to 4.12.2. You will miss essential content if you try to install it over 4.04 and Il-2 won't launch.

So as a first step you need to patch your game to 4.07 otherwise nothing will work. If you don't have the IL-2 1946 CD  the only solution would be buy a GOG or Steam version on line or a copy of the CD from e-bay or other similar site.

Once this is done then you can launch the mega patch and once verified that your 4.12.2 stock version works well then proceed to install BAT
Logged

Joes44

  • member
  • Offline Offline
  • Posts: 8
Re: BAT mod installation help, Please.
« Reply #2 on: February 22, 2024, 07:12:18 AM »

When I click on the icon on my desktop the game starts and it clearly states 4.07m
Logged

Frankiek

  • SAS Team
  • member
  • Online Online
  • Posts: 2368
Re: BAT mod installation help, Please.
« Reply #3 on: February 22, 2024, 08:25:13 AM »

ok so you definitely have a 4.07.

I mentioned that just because you stated that "I HAVE IL-2 46 4.04M DISK VERSION"

So you can just proceed as mentioned

First the megapatch then BAT. Here my advice would be to go all the way to 4.2 even if you are only interested in WWII. Much better to have the latest version with all the feature and then you can just delete the modules that you won't use. 
Logged

Joes44

  • member
  • Offline Offline
  • Posts: 8
Re: BAT mod installation help, Please.
« Reply #4 on: February 22, 2024, 08:35:31 AM »


I"M NOT SURE OF WHICH OF THE ABOVE FILES ARE TO BE UNZIPPED FIRST, AND IN WHAT ORDER?
THE TORRENTS?
MEGA PATCH?
BLUE EDGE INSTALLER?
FLASH POINT INSTALLER?
RED CORE TORRENT?



WHICH IS THE CORRECT PROCEDURE?
SHOULD I FIRST MOVE THE BAT_4.2.1 UPDATE  TO THE IL-2 GAME DISK, THEN UNZIP?
OR UNZIP FIRST THEN MOVE?
Logged

Satanas

  • member
  • Offline Offline
  • Posts: 26
Re: BAT mod installation help, Please.
« Reply #5 on: February 22, 2024, 11:08:08 AM »

Above a 4.07, 4.08, 4.09, 4.10 or 4.11 version, the correct install sequence is:
4.12.2m megapatch
BAT 4.0 Red Core
BAT 4.1 Blue Edge
BAT 4.2 Flashpoint
BAT 4.2.1 update
BAT 4.2.2 update + hotfix
Logged

Flying H

  • member
  • Offline Offline
  • Posts: 1328
  • "And you can fly, high as a kite if you want to..
Re: BAT mod installation help, Please.
« Reply #6 on: February 22, 2024, 02:46:42 PM »

And do start the game after every installment to check that it is running as it should. If you get problems check out this link https://www.sas1946.com/main/index.php/topic,66170.0.html and theese https://www.sas1946.com/main/index.php/topic,13457.0.html, https://www.sas1946.com/main/index.php/topic,19308.0.html and this https://www.sas1946.com/main/index.php/topic,39780.msg627220.html#msg627220. Follow the instructions and if you getstuck return here and you´ll get all the help you need. This is a good bunch of people who´ll sort you out!
Logged
And you can fly, high as a kite, if you want to.........

Joes44

  • member
  • Offline Offline
  • Posts: 8
Re: BAT mod installation help, Please.
« Reply #7 on: February 22, 2024, 03:07:39 PM »

i am getting a message after unzipping 4.12.2m mega patch part 1.
"next volume is required"
I have the game disk 2 in my dvd burner and is playing still nothing is happening, now what?
Logged

Frankiek

  • SAS Team
  • member
  • Online Online
  • Posts: 2368
Re: BAT mod installation help, Please.
« Reply #8 on: February 22, 2024, 03:59:36 PM »

The megapatch is composed by 13 files one exe and 12 rar archives so you need just to keep them in the same folder then launch the exe and follow instructions
Logged

Mr_Wafflehead

  • member
  • Offline Offline
  • Posts: 1
Re: BAT mod installation help, Please.
« Reply #9 on: March 26, 2024, 02:32:00 AM »

Y’all, I have installed all the BAT files(flashpoint, the original red core, blue core, the patches) and when I try to run the Jet Age setting, the game does not open. I tried to turn off windows data execution prevention and put an exception from my anti virus but it still fails to open when I try to open the jet age setting. Do you guys know how to fix this? Thanks!
Logged
Pages: [1]   Go Up
 

Page created in 0.089 seconds with 26 queries.