Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2   Go Down

Author Topic: Game launching issues.  (Read 620 times)

0 Members and 1 Guest are viewing this topic.

sercrets

  • Missioneer
  • member
  • Offline Offline
  • Posts: 83
    • Discord:
Game launching issues.
« on: September 25, 2023, 09:35:52 AM »

Hello! I suppose this is as good a place as any, though it also pertains to the stock game. (Storebror if your seeing this I figured I'd let you have a vacation and make a public post so others can help out ;p). I had messaged Storebror the other day asking after this error. It seems a few of our members in our discord as well as others; https://discord.gg/quWygTW6wU

Have struggled to launch the game for unforeseen reasons. First we tried stock 4.12.2, it launched with a weird resolution, however we proceeded to install Ultrapack and the resolution seemed to fix itself. Then about half an hour after installation, the person in mention closed the game and went for supper. When they came back, it refused to launch. We tried adjusting the resolution in the config, adjusting the actual windows resolution, disabled DEP (Data Execution Prevention), and it refused to run. We then went back to stock 4.12.2, and finally the latest steam install, following the previous troubleshooting methods used for each, with no avail. We also tried fiddling with the SAS selector and ram inputs.

Another user seemed to have the same issue. This user was able to run the startup debugger, which returned blank, however when they ran the windows event log, and It says that the failed module is jvm.dll, version: 0.0.0.0 And the failed app is il2fb.exe, version: 0.0.0.0. Storebror had mentioned something about other windows codes:

“If even the Startup Debugger doesn't show anything, then it's most likely DEP indeed.
The final check for DEP would be a look at the Windows Event Log.
DEP issues are indicated with Event ID 1000 and the executable name (il2fb.exe) in details, plus usually an access violation (exception ID 0xc0000005 (STATUS_ACCESS)”

However these do not match up. Any and all help is appreciated!

Cheers.
Sercrets
Logged
You get what you give.

sgt.wingspan

  • member
  • Offline Offline
  • Posts: 204
  • /][\[l//\
Re: Game launching issues.
« Reply #1 on: September 25, 2023, 04:52:53 PM »

Hi;
    Try something or have you tried fixing based on Access Violation error 0xC0000005
https://ugetfix.com/ask/how-to-fix-access-violation-error-0xc0000005-on-windows/

Logged
Not far

sercrets

  • Missioneer
  • member
  • Offline Offline
  • Posts: 83
    • Discord:
Re: Game launching issues.
« Reply #2 on: September 25, 2023, 08:36:08 PM »

Hi;
    Try something or have you tried fixing based on Access Violation error 0xC0000005
https://ugetfix.com/ask/how-to-fix-access-violation-error-0xc0000005-on-windows/





Nope I have not! Will check back!
Logged
You get what you give.

sercrets

  • Missioneer
  • member
  • Offline Offline
  • Posts: 83
    • Discord:
Re: Game launching issues.
« Reply #3 on: September 25, 2023, 08:38:23 PM »

However these did not come up in the log, just to be clear, that was what storebror was suggesting might comeup. Will report back.
Logged
You get what you give.

rockdoon

  • Modder
  • member
  • Offline Offline
  • Posts: 396
  • Flying Ass Clown #42
    • sandbar mitchell
Re: Game launching issues.
« Reply #4 on: September 29, 2023, 01:13:26 PM »

I was running into a similar issue and I think it had to do with the selector, updating to the latest selector seemed to fix my issue, if you try the latest selector make sure you do this after installing it


I can’t garentee this will work for you but it seemed to help me. Hopefully it gets results
Logged

sercrets

  • Missioneer
  • member
  • Offline Offline
  • Posts: 83
    • Discord:
Re: Game launching issues.
« Reply #5 on: September 30, 2023, 05:09:27 PM »

Roger will try it out thanks.
Logged
You get what you give.

sercrets

  • Missioneer
  • member
  • Offline Offline
  • Posts: 83
    • Discord:
Re: Game launching issues.
« Reply #6 on: October 05, 2023, 01:16:46 PM »

This is the stock game now, and windows event log gives:

Failed application name il2fb.exe, version: 0.0.0.0, timestamp: 0x44fd7bbb
Failed module name: jvm.dll, version: 0.0.0.0, timestamp: 0x3af53001
Exception Code: 0xc0000005
Error Offset: 0x000b08b0
Failed process ID: 0x1b80
Failed application start time: 0x01d9f7bcc6a5aff2
Failed application path: D:SteamLibrarysteamappscommonIL 2 Sturmovik 1946il2fb.exe
Failed module path: D:SteamLibrarysteamappscommonIL 2 Sturmovik 1946binhotspotjvm.dll
Report ID: 6b6aff84-44fd-41bd-a7a3-6ea79459c9a3
Full name of the failed package:
Application ID related to the failed package:


Any ideas guys?
Logged
You get what you give.

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 23596
  • Taking a timeout
    • STFU
Re: Game launching issues.
« Reply #7 on: October 06, 2023, 02:34:27 AM »

Error Offset: 0x000b08b0 is absolutely, definitely the DEP issue.

Please let your buddy re-read and triple-check this:
https://www.sas1946.com/main/index.php/topic,71235.0.html

]cheers[
Mike
Logged
Don't split your mentality without thinking twice.

sercrets

  • Missioneer
  • member
  • Offline Offline
  • Posts: 83
    • Discord:
Re: Game launching issues.
« Reply #8 on: October 06, 2023, 10:14:36 AM »

Good to see your back my friend. I have 2 or 3 people with the same issue now so hopefully this fixes it. Will report back.
Logged
You get what you give.

sercrets

  • Missioneer
  • member
  • Offline Offline
  • Posts: 83
    • Discord:
Re: Game launching issues.
« Reply #9 on: October 06, 2023, 11:25:08 AM »

Error Offset: 0x000b08b0 is absolutely, definitely the DEP issue.

Please let your buddy re-read and triple-check this:
https://www.sas1946.com/main/index.php/topic,71235.0.html

]cheers[
Mike

Mike, He has rechecked and redone DEP completely, and still comes up with that error as well as failure to launch. Any other ideas? Any other thing that could be causing the error to be thrown? They are pretty competent in computers and I am confident they did it correctly
Logged
You get what you give.

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 23596
  • Taking a timeout
    • STFU
Re: Game launching issues.
« Reply #10 on: October 07, 2023, 12:58:38 AM »

Not trying to question the computer skills of the poor sod having this issue, but the Error Offset really gives it away and that's a reproducible thing.
It's exactly that error being reported by others too, you can even search the Internet for it.
I can turn on DEP and get just the same.
XML view (I usually prefer the XML Event Log view cause it's language independent and looks the same across all Windows Versions):
Code: [Select]
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" Guid="{a0e9b465-b939-57d7-b27d-95d8e925ff57}" />
  <EventID>1000</EventID>
  <Version>0</Version>
  <Level>2</Level>
  <Task>100</Task>
  <Opcode>0</Opcode>
  <Keywords>0x8000000000000000</Keywords>
  <TimeCreated SystemTime="2023-10-07T06:25:09.3582858Z" />
  <EventRecordID>169201</EventRecordID>
  <Correlation />
  <Execution ProcessID="18408" ThreadID="16708" />
  <Channel>Application</Channel>
  <Computer>EDDIE10</Computer>
  <Security UserID="S-1-5-21-4185781700-4238074747-1687624439-1001" />
  </System>
- <EventData>
  <Data Name="AppName">il2fb.exe</Data>
  <Data Name="AppVersion">5.0.0.3</Data>
  <Data Name="AppTimeStamp">44fe754b</Data>
  <Data Name="ModuleName">jvm.dll</Data>
  <Data Name="ModuleVersion">0.0.0.0</Data>
  <Data Name="ModuleTimeStamp">3af53001</Data>
  <Data Name="ExceptionCode">c0000005</Data>
  <Data Name="FaultingOffset">000b08b0</Data>
  <Data Name="ProcessId">0x330</Data>
  <Data Name="ProcessCreationTime">0x1d9f8e7042de534</Data>
  <Data Name="AppPath">U:\IL2\CLIENT\IL-2 Ultrapack 3.4\il2fb.exe</Data>
  <Data Name="ModulePath">U:\IL2\CLIENT\IL-2 Ultrapack 3.4\bin\hotspot\jvm.dll</Data>
  <Data Name="IntegratorReportId">5836b1ad-2fd3-4c5e-9a73-f8baeb1a08da</Data>
  <Data Name="PackageFullName" />
  <Data Name="PackageRelativeAppId" />
  </EventData>
  </Event>

What could have happened?
Your friend may have forgotten to reboot the PC to apply the DEP changes?
He might have some fancy tool (Antivirus?) installed which re-enabled DEP on reboot?

If the DEP hint doesn't yield any good results despite all efforts, the only viable next step would be to completely wipe IL-2 off the disk and start with a fresh install.
On that opportunity, your friend may also follow some best practices for Steam Users:

]cheers[
Mike
Logged
Don't split your mentality without thinking twice.

sercrets

  • Missioneer
  • member
  • Offline Offline
  • Posts: 83
    • Discord:
Re: Game launching issues.
« Reply #11 on: October 08, 2023, 10:15:03 AM »

Hello storebror, just wanted to update you. He re-tried the DEP once again and it seemed to work! My guess he just accidentally forgot to restart the pc as you said. I shall report back when the other two have tried this issue.
Logged
You get what you give.
Pages: [1] 2   Go Up
 

Page created in 0.074 seconds with 28 queries.