Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Widescreen Woes  (Read 263 times)

0 Members and 1 Guest are viewing this topic.

Rakkis

  • member
  • Offline Offline
  • Posts: 3
Widescreen Woes
« on: August 06, 2023, 01:24:13 PM »

I have a 5120x1440 Super Ultrawide Monitor, I an unable to get 1946 to run in any sort of widescreen format Windowed (preferably) or otherwise. Attempting to change to DirectX from OpenGL or selecting any 1080 / 1440 resolution crashes the game to desktop and editing the INI to any resolution or changing Fullscreen = 1 to Fullscreen = 0 yields no results. Very frustrating.
Logged

Frankiek

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2098
Re: Widescreen Woes
« Reply #1 on: August 06, 2023, 05:59:04 PM »

To receive some decent support it would be better to tell us the version of Ultrapack you are running and insert your conf.ini
Logged

Rakkis

  • member
  • Offline Offline
  • Posts: 3
Re: Widescreen Woes
« Reply #2 on: August 06, 2023, 06:11:36 PM »

Ultrapack 3.4 "Cassie", Patch 2, Hotfix 19.

Don't seem to be able to attach a file but here's a screenshot if what (I think) the relevant information should be.


Logged

WxTech

  • Modder
  • member
  • Offline Offline
  • Posts: 5434
Re: Widescreen Woes
« Reply #3 on: August 06, 2023, 06:20:49 PM »

Try EnableResize=1
Logged
Great minds discuss ideas. Average minds discuss events. Small minds discuss people. - Hyman Rickover (but probably predating his use.)

Rakkis

  • member
  • Offline Offline
  • Posts: 3
Re: Widescreen Woes
« Reply #4 on: August 06, 2023, 06:34:41 PM »

So, EnableResize=1 did put into an appropriately scaled window for a brief moment, it then reverted to fullscreen and when I went to Video Options to change resolution it again crashed to desktop.
Logged

Frankiek

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2098
Re: Widescreen Woes
« Reply #5 on: August 06, 2023, 07:49:02 PM »

Don't use in game options to change screen resolution or Fullscreen options always do it through conf.ini yields better results and reduce ctd.
IL-2 is optimized for Fullscreen mode not windowed so better to run fullscreen=1 however if for any reason you prefer to run it in a window then Fullscreen=0
Then width and height need to match exactly  your screen resolution otherwise game won't even start. If you have enableresize=1 it will start but it won't fill your screen. You also need to be careful with DPI settings and scaling. The easiest way is to set conf.ini
Width=5120
Height=1440
Fullscreen=1
Changescreenres=1

Scaling of display 100%

These are initial setting to verify that everything works
Logged

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 23504
  • Taking a timeout
    • STFU
Re: Widescreen Woes
« Reply #6 on: August 06, 2023, 11:18:52 PM »

ChangeScreenRes=0

Just saying.

]cheers[
Mike
Logged
Don't split your mentality without thinking twice.
Pages: [1]   Go Up
 

Page created in 0.036 seconds with 24 queries.