Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 [3] 4 5 6 ... 8   Go Down

Author Topic: B.A.T. v4.2.1 Update + hotfix 03  (Read 30081 times)

0 Members and 1 Guest are viewing this topic.

barber

  • member
  • Offline Offline
  • Posts: 340
Re: B.A.T. v4.2.1 Update
« Reply #24 on: December 22, 2021, 01:07:39 AM »


Works fine as usual. Thank you very much and Merry Christmas to all.

Cheers
Barber
Logged

Vampire_pilot

  • member
  • Offline Offline
  • Posts: 7669
  • a million fixes
Re: B.A.T. v4.2.1 Update
« Reply #25 on: December 22, 2021, 01:15:10 AM »

Quote
You have to rebuilt all your modded ini files based on the new inis.

Not quite sure on how to rebuilt my ini folders as I forgot to save my pervious ini's from 4.2. Maybe a new ini folder would work and fix my ships, but I would certainly need a new one..

A bit OCD, but that is why I have my .ini files for each era in a jgsme switchable folder. I then add things one at a time, test the switched version, and if something is wrong deactivate and  adjust until it works. Takes a while (I currently have 19 mods which require .ini adjustments), but at least the base game remains unaffected.

^^^ THIS!

if you mess with ini files, you need a backup, and this is the the way to do it.

I also strongly suggest using the original STD/com/.... folder path in your JSGME package as well, so you always only have one (1!) set of ini files active in your era folder. Never have several ini of the same kind in one era folder. You are bound to mess up because you forget what's what. Trust me on this.

For good measures, get a file comparison tool, like WinMerge.

pisolithe

  • member
  • Offline Offline
  • Posts: 2
Re: B.A.T. v4.2.1 Update
« Reply #26 on: December 22, 2021, 02:10:01 AM »

Merci pour ce beau cadeau de noel :P
Logged

PO_MAK_249RIP

  • CMON U SPURS!
  • member
  • Offline Offline
  • Posts: 1953
Re: B.A.T. v4.2.1 Update
« Reply #27 on: December 22, 2021, 02:24:16 AM »

Wonderful xmas present thanks to all involved!! Will we get more ships for WAW in 2022??
Logged
Corsair Carbide case, Intel core i5 4690 3.5ghz with Arctic Cooler, Asus Rock H97 performance, Gainward windforce OC GTX 960 2GB, 8GB Corsair Vengeance 1600mhz, 256GB/500GB Crucial SSDs, Windows 10 64bit.

Griffon_301

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2199
Re: B.A.T. v4.2.1 Update
« Reply #28 on: December 22, 2021, 04:50:45 AM »

thanks to all involved! great stuff here and a wonderful electronic christmas present! this after version 1.2 of the Tie Fighter Total Conversion Mod came out yesterday - now its a tough choice what to play with during the holidays :D
guess my time will be evenly spent between flying in the HTA section in the USS Macon and the piloting Tie Fighters for Lord Vader :D :D :D
Logged

Mission_bug

  • Modder
  • member
  • Offline Offline
  • Posts: 5586
Re: B.A.T. v4.2.1 Update
« Reply #29 on: December 22, 2021, 06:43:44 AM »

Downloaded and installed without drama, all okay as far as I can tell. 8)

Thank you very much to all involved, really appreciated. ;)

Take care and be safe.

Wishing you all the very best, Pete. ;D
Logged

Tore

  • Crazy Mission Maker!!!!!!!!!!!!!!!!
  • member
  • Offline Offline
  • Posts: 667
Re: B.A.T. v4.2.1 Update
« Reply #30 on: December 22, 2021, 11:27:14 AM »

I've just recently found out by checking some of my folders that I have those backup ini folders but some are months old. For my older ship ini that is from August 22nd 2021.

I've tried on replacing the ship.ini with the older version and it was 60% for more than 10 seconds until it crashed, and I thought I just had it oh well..   :-[

Is there like any other way such as a working ship.ini or do I have to do those other following steps which I feel confused about? But I may eventually get the hand of it maybe..

The log again:
https://pastebin.com/ndVZ5a8s

What I used for JSGME if they are useful or not:
Code: [Select]
[DEPENDANCIES]
[MODS]
!!!_New_BigShip_Smoke&Fire v1.0=1
!!!_New_Damage_Smoke&Fire v4.1=2
!#NG-HUD_v3.6=3
!#NG-CAM_v1.6=4
#BAT_old_style_backdrops=5
Logged

Griffon_301

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2199
Re: B.A.T. v4.2.1 Update
« Reply #31 on: December 22, 2021, 12:44:03 PM »

well, to answer your question in a short way: if you have modded an older version of BAT, adding stuff to ini files, as soon as you copy over a new version of BAT with those additional thingies in the BAT module folders, all hell will break loose and your game will crash, either at 60% (air.ini) or at 70% (ship, objects, stationary.ini)
so if you want to have a current version of BAT - AND - additional stuff, you need to apply all those ini changes for the stuff you want to add to BAT again!!!
a crash at 60% points towards missing entries (or missing classfiles) for aircraft though; it can be of course that your game loaded up to 60%, even finishing loading aircraft  and as soon as it tried to initialize other stuff like ships, objects etc where there are classfiles but no ini entries, it crashes (at 70%), the crash happening so fast that you do not even see the 70% load indicator...

so in a nutshell, if you want to add aircraft, ships, objects to BAT , you have to add the respective ini entries....
if you have more specific questions, please open a thread in the tech help section though, this is the release thread and it should not be filled with tech questions and problems that do not come from the installer itself, as this works as advertised....
Logged

Alfie Noakes

  • Art Director
  • member
  • Offline Offline
  • Posts: 2574
Re: B.A.T. v4.2.1 Update
« Reply #32 on: December 22, 2021, 01:13:15 PM »

Greetings to all at BAT HQ
Many thanks for the new update.... just in time for Christmas  8)
I seem to have a problem with the download process... ( and the only one by the look of it  ::( )
Download from MediaFire is no problem but for the life of me I cannot extract the folder  BAT00
The rest of the folders are absolutely fine but not BAT00
I attempt to extract but  1. data error :BAT00\XUPMOD23.SFS  is being flagged up
I've opened BAT00 and have found I can extract XUPMOD25.SFS individually
It appears to be XUPMOD23.SFS that is generating the resultant 1. data error :BAT00\XUPMOD23.SFS warning box
I can't remember having such a problem before
I've downloaded the update now five times and am still stuck at this point........ hmmm

Any ideas ?

Cheers

Alfie
Logged
Everything is for the best in the best of all possible worlds

Vampire_pilot

  • member
  • Offline Offline
  • Posts: 7669
  • a million fixes
Re: B.A.T. v4.2.1 Update
« Reply #33 on: December 22, 2021, 01:55:24 PM »

Do
No
Extract
It
Yourself.

Use the exe

Tore

  • Crazy Mission Maker!!!!!!!!!!!!!!!!
  • member
  • Offline Offline
  • Posts: 667
Re: B.A.T. v4.2.1 Update
« Reply #34 on: December 22, 2021, 02:23:00 PM »

Thanks! I now got it work again so I could work on my next mission later on. But I'll need add some of the newer aircraft one by one.  ;)

Tore
Logged

Alfie Noakes

  • Art Director
  • member
  • Offline Offline
  • Posts: 2574
Re: B.A.T. v4.2.1 Update
« Reply #35 on: December 22, 2021, 02:26:30 PM »

Many
Thanks,
Worked
A
Treat !

Cheers

Alfie   ;)

PS   He-70  :-*
Logged
Everything is for the best in the best of all possible worlds
Pages: 1 2 [3] 4 5 6 ... 8   Go Up
 

Page created in 0.136 seconds with 26 queries.