Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: VP Modpack on Linux  (Read 105 times)

0 Members and 1 Guest are viewing this topic.

tomhighway

  • member
  • Offline Offline
  • Posts: 30
VP Modpack on Linux
« on: November 24, 2021, 12:38:39 PM »


Howdy,

After all the time and trouble I went through, and at the urging of another Sim pilot who posts great game videos on youtube, I decided to write about my experience in case there may be others out there who would like to run VP Modpack on Linux. I'm not calling this a tutorial because I can't say it will work for everyone. I only know it worked for me.


So first, here are some general specs about my system:

Dell Precision 490 workstation.
2 dual core Intel Xeon 5160 CPU's @ 3.00 GHz.
8 gigabytes of RAM.
Silent Cell GV-N98TSL-1GI  video card.
500 gigabyte SSD hard drive.
Linux Mint 19.2 Xfce 64 bit operating system.
Wine version 4.0 bionic.


There are other threads on this forum that talk about BAT on Linux, and there is some good info in there about configuring Wine, although the versions of wine they suggest are outdated. You will want to make sure you have Wine's 32 bit architecture installed along with the 64 bit stuff if you are running a 64 bit system. It's crucial. I already had 32 bit Wine architecture installed on my rig, so that wasn't part of my problem. But there was another aspect of Wine configuration that I didn't have which caused me to experience a CTD at 70% load when I would try to run VP Modpack. I found that information in the BAT on Linux thread, as well. Once you have Wine configured with 32 bit, open up the "Wine configuration" feature, switch to the "libraries" tab, and "add" the following DLL overrides from the list provided when you click the "add" button:

dinput (native, builtin)
msvcp71 (native)
msvcr71 (native)

Once I did this, VP Modpack would load and run. It just wouldn't run properly. (as a side note, before I added those DLL overrides, I would get a CTD at 20% trying to load my "YPack" install, too. After I added them, YPack loaded and ran perfectly). So that was how I solved my first VP Modpack on Linux issue. Much thanks to the folks who posted the information in the BAT on Linux thread.


The second issue was in the "patch" that you have to install after you install the VP Modpack. Folder names are case sensitive in Linux. There are two folders in the "patch" that are not spelled using the proper "case", as named in the stock game. So if you follow the instructions provided for installing the patch, instead of those 2 folders merging with the original folders, Linux just adds them as a second folder in each place. The fix is fairly simple, once figured out. Do NOT extract the patch directly into the game's root folder as instructed, if you are running Linux. Extract the patch into a separate folder. Once extracted, you need to change the spelling of the patch's "Dgen" folder to "DGen". (Note the capital G). Next, open the SAS folder, then open the MAPMODS folder, and rename the patch's "maps" folder to "MAPS". (Note the all caps spelling). Once you have renamed those two folders, drop and drag all of the main patch folders into the game's root folder, and when prompted to "overwrite" the existing files, say yes to all. After I did this, VP Modpack now loads and runs well on my Linux box.


I hope this is helpful to anyone else who may be interested in running VP Modpack on a Linux operating system.

Have a good one.

Logged
Pages: [1]   Go Up
 

Page created in 0.046 seconds with 24 queries.