Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Mods not loading anymore: 60% CTD  (Read 391 times)

0 Members and 1 Guest are viewing this topic.

Divebrake

  • member
  • Offline Offline
  • Posts: 50
Mods not loading anymore: 60% CTD
« on: February 21, 2021, 01:48:41 AM »

The V12.2 Modact 5.3 took a turn for the worst months ago, and I've been trying to get to the bottom of the problem. The game won't load mods as it did before, and many other planes I never installed. Since there are so many to choose from that do load, the game is fully functional once all the problem planes (about 10% of the total) get the // before them in air.ini. As an example that shows what happens with a mod, here is the log with the B7A1

Code: [Select]
[8:26:24 AM] sFMDir = b7a_fm
[8:26:24 AM] s1 = flightmodels/b7a1.fmd
[8:26:24 AM] s = FlightModels/B7A1.fmd:B7A_FM
[8:26:24 AM] m_lastFMFile = gui/game/buttons
[8:26:24 AM] getting fm file b7a_fm
[8:26:24 AM] Main begin: null
[8:26:24 AM] java.lang.NullPointerException
[8:26:24 AM] at com.maddox.il2.gui.GUIQuick$ItemAir.<init>(GUIQuick.java:872)
[8:26:24 AM] at com.maddox.il2.gui.GUIQuick.fillArrayPlanes(GUIQuick.java:2809)
[8:26:24 AM] at com.maddox.il2.gui.GUIQuick.<init>(GUIQuick.java:3954)
[8:26:24 AM] at com.maddox.il2.gui.GUI.create(GUI.java:160)
[8:26:24 AM] at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1742)
[8:26:24 AM] at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1436)
[8:26:24 AM] at com.maddox.il2.game.MainWin3D.beginApp(MainWin3D.java:212)
[8:26:24 AM] at com.maddox.il2.game.Main.exec(Main.java:432)
[8:26:24 AM] at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)
[Feb 21, 2021 8:26:24 AM] -------------- END log session -------------
Logged

Epervier

  • 4.09 Guardian Angel !
  • SAS Team
  • member
  • Offline Offline
  • Posts: 8044
  • I'm French and Rebel_409! Nobody is perfect!
    • Some tinkering here
Re: Mods not loading anymore: 60% CTD
« Reply #1 on: February 21, 2021, 04:28:23 AM »

Your B7A1 appears to be using an external FM: FlightModels/B7A1.fmd:B7A_FM
And obviously this external FM is not compatible with the buttons_412 of your game.
Have you checked that the Mod B7A1 is 412 compatible?
Logged
If your results are not up to your expectations, tell yourself that as large oak was once an acorn ...

Divebrake

  • member
  • Offline Offline
  • Posts: 50
Re: Mods not loading anymore: 60% CTD
« Reply #2 on: February 23, 2021, 11:22:09 PM »

Thanks for the reply and pointing in the direction of buttons because I think that is the problem. When I downloaded the B7A1, and all the other mods that are not working now, they all started with no problem. Is there a site where I can download the Modact 5.3 button? I fear I have messed up by replacing the original with a loaner button that isn't correct.
Logged

Epervier

  • 4.09 Guardian Angel !
  • SAS Team
  • member
  • Offline Offline
  • Posts: 8044
  • I'm French and Rebel_409! Nobody is perfect!
    • Some tinkering here
Re: Mods not loading anymore: 60% CTD
« Reply #3 on: February 24, 2021, 06:31:35 AM »

Is there a site where I can download the Modact 5.3 button?
The ModAct buttons are contained in the ModAct archive!
With 7z, right click on the file "SAS_Modact_5.30_for_IL-2_4.12.2m.exe",
- Open archive
- in the folder #SAS\STD\gui\game\... you will find the buttons
- extract the button

Logged
If your results are not up to your expectations, tell yourself that as large oak was once an acorn ...

Divebrake

  • member
  • Offline Offline
  • Posts: 50
Re: Mods not loading anymore: 60% CTD
« Reply #4 on: March 05, 2021, 12:28:46 AM »

Merci, Epervier, this will help!
Logged
Pages: [1]   Go Up
 

Page created in 0.05 seconds with 25 queries.