Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Crash w/WeaponsPack 1.3 & Gen2016_III  (Read 480 times)

0 Members and 1 Guest are viewing this topic.

Dummics

  • member
  • Offline Offline
  • Posts: 2
Crash w/WeaponsPack 1.3 & Gen2016_III
« on: January 24, 2021, 11:28:09 AM »

Hi, I've been playing IL-2 for few days now, and decided to mod the game. I wanted to get some planes installed, but after installing WeaponsPack v1.3 the game just won't load any mission (tried most of the default planes, doesn't seem to work). In the log file I'm getting the following error before the crash:

java.lang.NoSuchMethodError
   at com.maddox.il2.fm.Mass.computeParasiteMass(Mass.java:146)
   at com.maddox.il2.fm.RealFlightModel.update(RealFlightModel.java:519)
   at com.maddox.il2.fm.FlightModelMain.tick(FlightModelMain.java:1206)
   at com.maddox.il2.engine.Interpolators.tick(Interpolators.java:222)
   at com.maddox.il2.engine.Actor.interpolateTick(Actor.java:371)
   at com.maddox.il2.engine.InterpolateAdapter.msgTimeOut(InterpolateAdapter.java:174)
   at com.maddox.rts.MsgTimeOut.invokeListener(MsgTimeOut.java:73)
   at com.maddox.rts.Message._send(Message.java:1217)
   at com.maddox.rts.Message.sendToObject(Message.java:1191)
   at com.maddox.rts.Message.sendTo(Message.java:1134)
   at com.maddox.rts.Message.trySend(Message.java:1115)
   at com.maddox.rts.Time.loopMessages(Time.java:252)
   at com.maddox.rts.RTSConf.loopMsgs(RTSConf.java:101)
   at com.maddox.il2.game.MainWin3D.loopApp(MainWin3D.java:131)
   at com.maddox.il2.game.Main.exec(Main.java:422)
   at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)

When removing the Packs, the game works properly (without the weapon packs, some planes will eventually crash the game aswell).


Logged

FL2070

  • Modder
  • member
  • Offline Offline
  • Posts: 703
  • Mod Dispenser Operator In-Training
Re: Crash w/WeaponsPack 1.3 & Gen2016_III
« Reply #1 on: January 24, 2021, 05:33:09 PM »

"NoSuchMethodError"

The error could be:
- You are missing some other mod which you need to use WeaponsPack
- WeaponsPack Gen2016 overwrites something that it shouldn't
- WeaponsPack Gen2016 uses some other mod which is being overwritten

I'm assuming you're using the game setup listed below. If you aren't, then you will have problems.
- v4.12.2m
- SAS ModAct 5.3
- SAS Engine Mod 2.8.20 (double check to make sure you have the right version)
- AMT JetWar 1.33 or later
- 4S_Vega Weapons Pack v1.3

If you have the right game version and modact, and all of these mods, then the problem is the ordering of the mods: something is being given too high or low of a loading priority.

Loading priority is changed by modifying mods' folder names, such that whatever is shown earlier when the contents of your mods folder (#SAS) are sorted by name will load with higher priority.  For instance, if you have this, then Mod1 will load with higher priority:
Code: [Select]
#SAS/
    0_Mod1/
    Mod2/

Whereas if you have this, Mod2 will load with higher priority:

Code: [Select]
#SAS/
    0_Mod2/
    Mod1/

The highest loading priority character, second only to the space, is the exclamation mark, because it has the lowest unicode number (U+0021). Thus, the best way to increase a mod's loading priority is to make the name something like "!              Mod"

Whenever there is a conflict between two or more mods (they change the same file), the file from the mod with the highest priority is chosen. Because the error occurs at a function to compute the mass of something within flight model code, you can assume the mod that's causing the problem is something that will modify integral game code—something like EngineMod.

I don't know the specifics of what EngineMod and WeaponsPack Gen2016 edit, but I would recommend checking your #SAS folder to see what the loading priority of your EngineMod is relative to your WeaponsPack Gen2016. Whatever it is, reverse it, then do whatever it was that made the game crash to see if that fixed your problem. If it didn't fix the problem, I'll be happy to help further.

You seem like the competent sort, having figured out how to mod the game in only a
few days
so I wish you further progress in the future. Modding is a long road, but well worth it. Cheers  :)
Logged
On average, the average average averages, averagely, the average average of all averages.

Dummics

  • member
  • Offline Offline
  • Posts: 2
Re: Crash w/WeaponsPack 1.3 & Gen2016_III
« Reply #2 on: January 25, 2021, 01:32:00 AM »

Changing the mods priority worked. It was such an easy fix, but being new, I didn't know what the "!" and the "0" meant in the mod folder name.
Thanks for the help and for your time!
Logged
Pages: [1]   Go Up
 

Page created in 0.059 seconds with 25 queries.