Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 16 17 18 [19] 20 21 22 23   Go Down

Author Topic: Royal Navy Pack - HMS Nelson - HMS Rodney - HMS Devonshire - HMS Leander - HMS Ajax - HMS Vampire - HMS Hermes - N48 Medway Queen - HMS Valiant - HMS Repulse - HMS Black Swan - HMS Dido  (Read 26242 times)

0 Members and 2 Guests are viewing this topic.

Evgen

  • member
  • Offline Offline
  • Posts: 2

 Good afternoon. I'm trying to install "Repulse" in BAT mod 4.0. I don't know where to look for the file "ship.properties". Tell me please.  "Repulse" is not shown in the "ship.ini" file either.

Logged

asheshouse

  • SAS Team
  • member
  • Offline Offline
  • Posts: 3204

You will find them in the STD/i18n folder.
However, ship.ini and ship.properties text entries are not required.

Their only purpose is to enable the ships to appear in the Object Viewer accessed from the main menu.
You can instead use the viewer in Full Mission Builder. This works just as well.
Logged

Evgen

  • member
  • Offline Offline
  • Posts: 2

 Thank you for the answer, I haven't installed ship mods for 10 years, I forgot everything. BATH has almost all the ships from your mod, except for the "Repulse", "Rodney" and "Valiant". Thank you for the mod!
Logged

WWIIBuff65

  • member
  • Offline Offline
  • Posts: 23

I have extracted and installed this ship mod to my mods folder (#SAS) but do not see any of the ships added or listed when I try to view them as "objects" in the game menu.  Also tried installing to my jsgmemods folder and then activated it from there -- still nothing.  Can someone please tell me what I'm doing wrong?

Currently using the VP Modpack for v4.12.2
Logged

asheshouse

  • SAS Team
  • member
  • Offline Offline
  • Posts: 3204

Do they appear in the menu in Full Mission Builder FMB.
If not then check you have correctly added the text entries in chief.ini and ships.ini.
Logged

WWIIBuff65

  • member
  • Offline Offline
  • Posts: 23

They do not appear in the FMB, no.  I added text entries to ship.ini and both chief.ini files within the mod folder (#SAS)....even watched video tutorial on YouTube -- game now CTDs at 70%.  Tried updating Selector to 4.0.2.  Same thing happens.  Am I supposed to add text entries for ships.ini, stationary.ini, technics, properties, etc. as well?  Very confused.  Please help.  Here's the end of my start up log file after running debugger:

PlMisChief: property 'speed' NOT found in class 'com.maddox.il2.objects.ships.ShipAsheRN$Nelson
java.lang.RuntimeException: PlMisChief: property 'speed' NOT found in class 'com.maddox.il2.objects.ships.ShipAsheRN$Nelson
   at com.maddox.il2.builder.PlMisChief$Item.<init>(PlMisChief.java:107)
   at com.maddox.il2.builder.PlMisChief.configure(PlMisChief.java:636)
   at com.maddox.il2.builder.Plugin.loadAll(Plugin.java:152)
   at com.maddox.il2.builder.Builder.<init>(Builder.java:3214)
   at com.maddox.il2.gui.GUIBuilder.<init>(GUIBuilder.java:90)
   at com.maddox.il2.gui.GUI.create(GUI.java:166)
   at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1742)
   at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1436)
   at com.maddox.il2.game.MainWin3D.beginApp(MainWin3D.java:212)
   at com.maddox.il2.game.Main.exec(Main.java:432)
   at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)
Main begin: java.lang.RuntimeException: PlMisChief: property 'speed' NOT found in class 'com.maddox.il2.objects.ships.ShipAsheRN$Nelson
java.lang.RuntimeException: java.lang.RuntimeException: PlMisChief: property 'speed' NOT found in class 'com.maddox.il2.objects.ships.ShipAsheRN$Nelson
   at com.maddox.il2.builder.PlMisChief$Item.<init>(PlMisChief.java:119)
   at com.maddox.il2.builder.PlMisChief.configure(PlMisChief.java:636)
   at com.maddox.il2.builder.Plugin.loadAll(Plugin.java:152)
   at com.maddox.il2.builder.Builder.<init>(Builder.java:3214)
   at com.maddox.il2.gui.GUIBuilder.<init>(GUIBuilder.java:90)
   at com.maddox.il2.gui.GUI.create(GUI.java:166)
   at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1742)
   at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1436)
   at com.maddox.il2.game.MainWin3D.beginApp(MainWin3D.java:212)
   at com.maddox.il2.game.Main.exec(Main.java:432)
   at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)



Logged

cbradbury

  • member
  • Offline Offline
  • Posts: 650

In my experience, a 70% ctd is usually down to classfiles. My recommended procedure:

1. Use jgsme - don't start randomly changing stuff in il2 unless you fancy reinstalling the lot.

2. Download the original package, the four patches, and the updated classfiles.

3. Extract and overwrite everything in strict order i.e base package, add each patch in turn, then finish with the latest classfiles - they are very important.

4. Add all the .ini entries (again use jgsme to do this).

5. Activate your jgsme package and see what happens then.

P.S. Of course you need to add the ships.ini entries! The ship.ini changes are not important - the ships will still run without that.
Logged

Griffon_301

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2158

what cbradbury has posted!

plus: make sure to have the new ships load BEFORE the classfiles folders in your module! this is important as BAT currently does not have the latest RN ships in it IIRC and it is important to have the classfiles for a ship package up to date and load first before any older classfiles of an older ships package...

i do not use jsgme, in fact i hate it as it makes things more complicated if you want to add one mod while leaving out another; fiddling with multiple ini files and not loosing overview is quite difficult if you tend to mod your install heavily...
what I do is to make a copy of the complete STD folder before I add ships or aircraft or static and stationary objects and put it into a safe directory somewhere else;
if anything goes awry, I just delete the offending mod and copy back the saved std folder and all is fine again....
works like a charme and that way, you only have one set of ini files in use - a working one with all the mods you have added for your own liking....
if
Logged

WWIIBuff65

  • member
  • Offline Offline
  • Posts: 23

SUCCESS -- thanks, all!  Game loaded without a hitch and I could see all the ships listed in the FMB :)   I'm not able to view them all, however -- any idea if there's a workaround for viewing objects?
Logged

asheshouse

  • SAS Team
  • member
  • Offline Offline
  • Posts: 3204

Check the ships.ini entries again. Probably text missing from user defined gun section if you cant see a ship. Which ones are not visible?
Logged

asheshouse

  • SAS Team
  • member
  • Offline Offline
  • Posts: 3204
Logged

Epervier

  • 4.09 Guardian Angel !
  • SAS Team
  • member
  • Offline Offline
  • Posts: 8325
  • I'm French and Rebel_409! Nobody is perfect!
    • Some tinkering here
Logged
If your results are not up to your expectations, tell yourself that as large oak was once an acorn ...
Pages: 1 ... 16 17 18 [19] 20 21 22 23   Go Up
 

Page created in 0.063 seconds with 25 queries.