Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Level stabiliser doesn't work in Swordfish  (Read 195 times)

0 Members and 1 Guest are viewing this topic.

FAA

  • member
  • Offline Offline
  • Posts: 8
Level stabiliser doesn't work in Swordfish
« on: November 26, 2019, 05:23:03 AM »

I've been trying to use the level stabiliser in Swordfish for a while now, at maximum throttle, but it fails to maintain the altitude. I tried to engage it at 1,000 ft and it almost worked after dropping 200 ft and then continued dropping up until around 500 ft. It would possibly drop more, but at that point I tried to get back to 1,000. Overall, Swordfish seems seriously underpowered, more so than the real one. Is this WAD?
Logged

Koty

  • Mr. MiG
  • Modder
  • member
  • Offline Offline
  • Posts: 2107
  • It's a MiG!
Re: Level stabiliser doesn't work in Swordfish
« Reply #1 on: November 26, 2019, 05:30:51 AM »

Swordfish is fine. Level stabilizer on the other hand is not perfect. If you want to climb using the stabilizer, use trim. It's that simple, really. But with some aircraft that is not enough, it has nothing to do with power though, it's just how it is.
Logged
If I don't have to do it, I won't. If I have to do it, I'll make it quick.
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 26 queries.