Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2]   Go Down

Author Topic: Waterstart  (Read 4409 times)

0 Members and 1 Guest are viewing this topic.

Mission_bug

  • Modder
  • member
  • Offline Offline
  • Posts: 5292
Re: Waterstart
« Reply #12 on: September 08, 2019, 03:03:41 PM »

Hello again Dimlee, the aircraft in my install 4.12.2 with SAS ModAct 5.30 is definately 4.10, . ;)

Code: [Select]
public class Walrus extends Scheme1
    implements TypeTransport, TypeBomber, TypeSailPlane
{

    public Walrus()
    {

I will have a go at converting it tomorrow, been drinking tonight so anything could happen. :D


Wishing you all the very best, Pete. ;D
Logged

<Gunny>

  • member
  • Offline Offline
  • Posts: 1332
Re: Waterstart
« Reply #13 on: September 08, 2019, 06:31:56 PM »

Here is  a little trick I use and it works 90% of the time....
Use a TEST RUNWAY 4 or 5 they seem to work the best.. set them on your water way and use the SET key to the icon for landing ...
The plane will in fact land... They dont taxi but they land.. Same thing for starting.....






Logged

Mission_bug

  • Modder
  • member
  • Offline Offline
  • Posts: 5292
Re: Waterstart
« Reply #14 on: September 09, 2019, 05:50:04 AM »

Hello guys, not had a chance yet to meddle with the Walrus class, however, I did a test in BAT and it is still using the
4.10 'TypeSailPlane' as you can see form this image of it on approach at a land airfield:







Wishing you all the very best, Pete. ;D

Logged

Mission_bug

  • Modder
  • member
  • Offline Offline
  • Posts: 5292
Re: Waterstart
« Reply #15 on: September 09, 2019, 11:05:16 AM »

Hello again, as promised I made a class to change the Walrus compatible for 4.12 and in my 4.12.2 with SAS ModAct 5.30 all is good. ;)




Unfortunately, when I tested the change in BAT WAW the problem persisted of the aircraft trying to put down at a land airfield. o_O


Maybe what Andy says here has something to do with that, Mike must have made some alterations:

mind you, in BAT this should all be rectified.


The class I made for the FW-58 worked so changes must have come in the last BAT update.


Nothing else I can do to help Dimlee, code work for BAT is beyond my ability apart from the change I made to the class file, sorry. :(



Wishing you all the very best, Pete. ;D
Logged

Dimlee

  • member
  • Offline Offline
  • Posts: 659
Re: Waterstart
« Reply #16 on: September 09, 2019, 02:20:06 PM »

Thank you Pete for your work and explanations.
Since there is no easy solution, we can use what Gunny suggested or find another workaround. So far I'll send the Walrus to dead zone to vanish or - even better - I'll just sit in the cockpit myself to accomplish the mission.
Thanks again !
Logged

Mission_bug

  • Modder
  • member
  • Offline Offline
  • Posts: 5292
Re: Waterstart
« Reply #17 on: September 09, 2019, 02:34:33 PM »

Hello Dimlee, the only thing I can do for you is zip the class up and provide a link, however, to use it you would need a separate 4.12 install as I have to be able to confirm my findings, if you only use BAT then then I think the best thing is to report this as a bug in the BAT area and hopefully Mike will be able to help. ;)


Wishing you all the very best, Pete. ;D
Logged
Pages: 1 [2]   Go Up
 

Page created in 0.053 seconds with 25 queries.