Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 10 11 12 [13] 14 15   Go Down

Author Topic: graphics extender - bugs  (Read 13346 times)

0 Members and 1 Guest are viewing this topic.

slibenli

  • member
  • Online Online
  • Posts: 430
    • IL-2 Graphics Extender
Re: graphics extender - bugs
« Reply #144 on: January 18, 2020, 03:11:17 AM »

Looks like problems with effect shadows - do those artifacts disappear when setting "Effecs=0" in conf.ini?

Rostic

  • member
  • Offline Offline
  • Posts: 28
Re: graphics extender - bugs
« Reply #145 on: January 18, 2020, 09:45:02 AM »

Looks like problems with effect shadows - do those artifacts disappear when setting "Effecs=0" in conf.ini?

Yes, you are right. Those articacts disappear when I set "Effecs=0" in conf.ini
Logged

FL2070 / dirtbloxxMC

  • Modder
  • member
  • Offline Offline
  • Posts: 300
  • i make sounds
Re: graphics extender - bugs
« Reply #146 on: January 31, 2020, 03:30:19 PM »

Attempting to change the reticle brightness to lower values through the "Toggle Reticle Brighness" key produces a blue reticle instead of a very transparent one. Reticle at high brightness with il2ge:


Reticle at low brightness with il2ge:

Logged
I'm FL2070, previously known as dirtbloxxMC. I make sounds. My current main project, UJS (Ultimate Jet Sound) v1.2, can be found here: https://www.sas1946.com/main/index.php/topic,61360.0.html

slibenli

  • member
  • Online Online
  • Posts: 430
    • IL-2 Graphics Extender
Re: graphics extender - bugs
« Reply #147 on: February 01, 2020, 09:10:47 AM »

Hmm, I can't find that key binding. In which section is it and does it require an extra mod?
Do you mean "Tinted Reticle Dimmer" ? - Edit - Nah that doesn't seem to be it.

FL2070 / dirtbloxxMC

  • Modder
  • member
  • Offline Offline
  • Posts: 300
  • i make sounds
Re: graphics extender - bugs
« Reply #148 on: February 01, 2020, 09:17:12 AM »

No, it's stock 4.12, found near the bottom of the misc section.

(screenshot taken from my stock 4.12.2m install)
Logged
I'm FL2070, previously known as dirtbloxxMC. I make sounds. My current main project, UJS (Ultimate Jet Sound) v1.2, can be found here: https://www.sas1946.com/main/index.php/topic,61360.0.html

slibenli

  • member
  • Online Online
  • Posts: 430
    • IL-2 Graphics Extender
Re: graphics extender - bugs
« Reply #149 on: February 01, 2020, 09:20:47 AM »

Arrgh - there it is  :D
Thanks :)

Kelso

  • member
  • Offline Offline
  • Posts: 141
Re: graphics extender - bugs
« Reply #150 on: February 01, 2020, 10:47:36 AM »

This is my next approach to this mod. It's the same every time - the game doesn't start. I met all the requirements from the readme file. My computer is: GeForce GTX 660 Ti - driver for it 344.75 (I know - very old, but works well with IL-2), Intel E8400 processor, Windows 7 64 bit, il2ge-installer downloaded today. I'm good with mods, but here I have no idea what the problem is. I paste the contents of il2ge_full.log and I will be grateful for your help.
https://pastebin.com/zFu2tZGn
Logged

slibenli

  • member
  • Online Online
  • Posts: 430
    • IL-2 Graphics Extender
Re: graphics extender - bugs
« Reply #151 on: February 01, 2020, 11:55:52 AM »

This is my next approach to this mod. It's the same every time - the game doesn't start. I met all the requirements from the readme file. My computer is: GeForce GTX 660 Ti - driver for it 344.75 (I know - very old, but works well with IL-2), Intel E8400 processor, Windows 7 64 bit, il2ge-installer downloaded today. I'm good with mods, but here I have no idea what the problem is. I paste the contents of il2ge_full.log and I will be grateful for your help.
https://pastebin.com/zFu2tZGn

OK, the problem is that your driver doesn't support the method glReadnPixels, which is part of OpenGL 4.5.
Installing a newer driver might fix that.
I should probably mention in the requirements that il2ge requires OpenGL 4+.

Kelso

  • member
  • Offline Offline
  • Posts: 141
Re: graphics extender - bugs
« Reply #152 on: February 01, 2020, 12:03:28 PM »

Thank you so much for help. How do I install the new driver - will I know if it helped.
I don't like changing something that works well. As you can see - it stopped.
Logged

slibenli

  • member
  • Online Online
  • Posts: 430
    • IL-2 Graphics Extender
Re: graphics extender - bugs
« Reply #153 on: February 01, 2020, 12:05:11 PM »

Attempting to change the reticle brightness to lower values through the "Toggle Reticle Brighness" key produces a blue reticle instead of a very transparent one.

Fixed in https://gitlab.com/vrresto/il2ge/-/jobs/422904786/artifacts/raw/il2ge-installer.exe?inline=false.

There is a side effect though, which is wrongly lit objects in some cockpits, for example of the La-7:



Only noticable with the setting Atmosphere=Precomputed.

I'm using the alpha blending mode as a hint to determine whether a rendered object is self illuminating, which fails in the above case.
More precisely: If the opengl blending mode is set to GL_SRC_ALPHA,GL_ONE - I think this corresponds to the option blendAdd in the material definition files.

slibenli

  • member
  • Online Online
  • Posts: 430
    • IL-2 Graphics Extender
Re: graphics extender - bugs
« Reply #154 on: February 01, 2020, 12:25:59 PM »

Thank you so much for help. How do I install the new driver - will I know if it helped.
I don't like changing something that works well. As you can see - it stopped.

https://www.geforce.com/drivers ;)

Kelso

  • member
  • Offline Offline
  • Posts: 141
Re: graphics extender - bugs
« Reply #155 on: February 01, 2020, 01:15:08 PM »

OK, the problem is that your driver doesn't support the method glReadnPixels, which is part of OpenGL 4.5.
Installing a newer driver might fix that.
I should probably mention in the requirements that il2ge requires OpenGL 4+.
My graphics card supports OpenGL 4.2. Enough for your mod?
Logged
Pages: 1 ... 10 11 12 [13] 14 15   Go Up
 

Page created in 0.015 seconds with 26 queries.