Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Cloud shadow bug on ground textures  (Read 1383 times)

0 Members and 1 Guest are viewing this topic.

tbauchot

  • Modder
  • member
  • Offline Offline
  • Posts: 275
Cloud shadow bug on ground textures
« on: June 03, 2019, 05:20:05 AM »

"I don't know if it's the right place for this topic ?!..."
Hi,
Sometimes it happen in my game to see the clouds shadows that appear like big squares :

Did you have ever seen that in your game ?
Do you have any idea what caused this ?
Here, my OpenGL config.ini :
Code: [Select]

[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=0
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=1
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=0

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3


Sky=2
Forest=3
LandShading=3
LandDetails=2

TypeClouds=1

LandGeom=3
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=4
Effects=1
ForceShaders1x=0

PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0




Thank you very much in advance.  ;) :)

Logged

Lagarto

  • Modder
  • member
  • Offline Offline
  • Posts: 325
Re: Cloud shadow bug on ground textures
« Reply #1 on: June 03, 2019, 10:20:08 AM »

Yes, I see it quite often in my game and I'd love to know the fix for it.
Logged

Mick

  • Modder
  • member
  • Offline Offline
  • Posts: 4168
Re: Cloud shadow bug on ground textures
« Reply #2 on: June 03, 2019, 11:20:25 AM »

... never seen that before, must be some setting in your conf.ini, but which one ...?  :-X

You should try Mike's one ...  ;)

Code: [Select]
[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=0
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=0
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=0
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=0

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=4
Effects=2
ForceShaders1x=0
PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-1.0
Logged

macgiver

  • member
  • Offline Offline
  • Posts: 132
Re: Cloud shadow bug on ground textures
« Reply #3 on: June 03, 2019, 12:05:04 PM »

Yes, I see it quite often in my game and I'd love to know the fix for it.
+1
Sometimes I see it in the same clouds...
Logged

marcost

  • Modder
  • member
  • Offline Offline
  • Posts: 947
  • Keep calm and run away
Re: Cloud shadow bug on ground textures
« Reply #4 on: October 29, 2019, 03:27:22 AM »

Hi did anyone manage to fix this? I have it, but i don't see it on other people's youtube videos.

Thanks

M
Logged

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 19088
  • Failure is not an option.
    • What goes around comes around, you'll see
Re: Cloud shadow bug on ground textures
« Reply #5 on: October 29, 2019, 04:40:27 AM »

It only happens when your conf.ini is wrong.
Either you have a dedicated graphics card and use wrong settings, in which case Mick's reply nailed it.
Or you are playing with CPU-integrated Intel HD graphics, in which case there's a few thousand times when on this very forum we adviced you not to use OpenGL but DirectX instead. Intel HD doesn't work with IL-2 in OpenGL mode, that's a known fact for more than a decade now.

]cheers[
Mike
Logged
While love lives, while suns set, while snowmoons rise in november skies, while ties bind, while souls cry, while oceans ride in an endless tide, while love grows, while blood flows, while truth is real you need never feel alone.
In loving memory of times when I cared.

marcost

  • Modder
  • member
  • Offline Offline
  • Posts: 947
  • Keep calm and run away
Re: Cloud shadow bug on ground textures
« Reply #6 on: October 29, 2019, 05:21:13 AM »

Thanks Mike,

It's a dedicated card (1080ti) and I thought I had always used your conf.ini settings. I will have to check again!

Cheers
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 26 queries.