Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: FPS Issues  (Read 1632 times)

0 Members and 1 Guest are viewing this topic.

GeorgeCostanza

  • Always in an Awkward Situation
  • member
  • Offline Offline
  • Posts: 50
  • George Costanza's the name dropin bombs is my game
FPS Issues
« on: August 30, 2017, 11:24:18 PM »

I have browsed similar threads for quite a while now and must admit I'm feeling hopeless with this issue. I recently got myself a new computer, however I'm still having FPS issues with Monty's BAT. On almost all missions I play I'm only able to average between 20-30fps on perfect settings. This will usually drop to 5-10fps when looking at urban areas and speeding up the game is sort of horrific. And those frames are on solo flight with no other assets around aside from 3 other planes alongside me. Larger dogfights are essentially a slideshow with pretty pictures. I have a feeling I am missing something however, because after searching the threads of similar people's problems, as well as enacting many of the fixes monty suggested, such as the removal of several .SFS files, my issue persists.

I'm unsure whether I need to post a logfile as my game isn't crashing, but here are my specs of my fresh computer:

Intel i9 7900x
2x GTX1080ti SLI
32GB of RAM
And the game is installed on an SSD

Here is my conf.ini:
Code: [Select]

[window]
width=1920
height=1080
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=1
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0
WideScreenFoV=1
UIColor=0
UIDetail=0
UIBackground=rnd

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

[MaxLag]
farMaxLagTime=10.0
nearMaxLagTime=2.0
cheaterWarningDelay=5.0
cheaterWarningNum=-1

[HotKey game]
PrintScreen=ScreenShot
P=pause
Pause=pause

[HotKey gui]
Escape=activate

[HookViewFly Config]
timeFirstStep=2.0
deltaZ=10.0

[HookView]
MouseLeft=Len

[HookView Config]
AzimutSpeed=0.1
TangageSpeed=0.1
LenSpeed=1.0
MinLen=1.0
DefaultLen=20.0
MaxLen=3000.0
Speed=6
LeanF=0.07
LeanS=0.059999995
Raise=0.04
RubberBand=0.04

[HotKey builder]
MouseLeft=objectMove
MouseRight=popupmenu
Enter=freeView
Shift MouseLeft=worldZoom
Alt MouseLeft=select+
Alt MouseRight=select-
Alt Ctrl=unselect
PageDown=change+
PageUp=change-
End=change++
Home=change--
Ctrl MouseLeft=insert+
Insert=insert+
NumPad-0=insert+
F=fill
Ctrl MouseRight=delete+
NumPad.=delete+
Delete=delete+
Backspace=cursor
Tab=cursor
F10=land
F11=onLand
NumPad-=normalLand
NumPad+=toLand
NumPad-5=resetAngles
NumPad-8=resetTangage90
NumPad-7=stepAzimut-5
NumPad-4=stepAzimut-15
NumPad-1=stepAzimut-30
NumPad-9=stepAzimut5
NumPad-6=stepAzimut15
NumPad-3=stepAzimut30

[MouseXYZ]
F1=SpeedSlow
F2=SpeedNormal
F3=SpeedFast
MouseRight=XYmove
F4 MouseRight=Zmove
MouseMiddle=Amove
F5 MouseRight=Amove
F6 MouseRight=Tmove
F7 MouseRight=Kmove

[MouseXYZ Config]
RealTime=1

[HotKey Console]
Shift Tab=Activate
[Console]
HISTORY=1024
HISTORYCMD=1024
LOAD=console.cmd
SAVE=console.cmd
LOG=0
LOGTIME=0
LOGFILE=log.lst
LOGKEEP=0

[sound]
SoundUse=1
SoundEngine=1
Speakers=4
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=4
ObjectVolume=14
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=1
MasterVolume=4
Attenuation=7
SoundMode=3
SamplingRate=2
NumChannels=2
SoundExt.occlusions=1
SoundFlags.hardware=1
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=1
SoundExt.volumefx=1
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=14
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=0
ActLevel=0
MicLevel=0
SoundFlags.forceEAX1=0

[rts]
ProcessAffinityMask=1048575
mouseUse=2
joyUse=1
trackIRUse=1
DisableIME=0
locale=
UseSmartAxis=0
JoyProfile=0

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
Invert=0
SensitivityZ=1.0

[rts_joystick]
X=0 1 4 9 16 25 36 49 64 81 100 0
Y=0 1 4 9 16 25 36 49 64 81 100 0
Z=0 10 20 30 40 50 60 70 80 90 100
RZ=0 10 20 30 40 50 60 70 80 90 100 0
FF=0
U=0 10 20 30 40 50 60 70 80 90 100 0
V=0 10 20 30 40 50 60 70 80 90 100 0
1X=0 10 20 30 40 50 60 70 80 90 100 0 0
1Y=0 10 20 30 40 50 60 70 80 90 100 0 0
1Z=0 100 100 100 100 100 100 100 100 100 100 0 0
1RZ=0 100 100 100 100 100 100 100 100 100 100 0 0
1U=0 100 100 100 100 100 100 100 100 100 100 0 0
1V=0 100 100 100 100 100 100 100 100 100 100 0 0

[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=2
TexFlags.UseDither=0
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=1
TexFlags.DrawLandByTriangles=0
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=1
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=3
Effects=1
ForceShaders1x=0
PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-1.0

I understand many people have had FPS Issues in the past, but the sort of solutions that brought them to a steady 60-70 seem to be not helping as much for me, doesn't seem to make much sense on this new system, especially considering that I may or may not have bought it mainly for just IL2 with BAT Flight Sims  :-X

Any word on this? If I've left out critical information like a fool please tell me and I'll provide.
Logged
GFX: 2 x ASUS ROG Strix GeForce GTX 1080 Ti ~~~~ CPU: Intel i9-7900X 20 Core 3.3GHz  ~~~~ RAM: 32GB DDR ~~~~ STX: Thrustmaster HOTAS-X

SAS~Storebror

  • retired
  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 19789
  • Taking a timeout
    • STFU
Re: FPS Issues
« Reply #1 on: August 30, 2017, 11:57:40 PM »

On almost all missions I play I'm only able to average between 20-30fps on perfect settings.
Which module? WAW?
All others have not been reported to have FPS issues so far.
If it's WAW, you will want to take a look here: http://www.sas1946.com/main/index.php/topic,54580.0.html

This will usually drop to 5-10fps when looking at urban areas
It does so for all of us, on all game versions.
If you look at a well populated urban area, the CPU becomes your bottleneck.
IL-2 1946 is strictly single core and even a 7900x is not able to get above 10fps if you put enough houses in a city.
Attention: I know it's tempting guys, but please refrain from posting screenshots of small cities stating that this doesn't happen to you. It does. You simply didn't fly above a large one.

Larger dogfights are essentially a slideshow with pretty pictures.
That's odd and has nothing to do with BAT.
If I were you, I'd check the CPU temperature.
Maybe the heat spreader wasn't attached correctly and your CPU simply runs into throttling.
HWInfo is a tool that can tell you any details about this.

Code: [Select]
[rts]
ProcessAffinityMask=1048575

[Render_OpenGL]
TexCompress=2
TexFlags.UseClampedSprites=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexCompressARBExt=1

Sky=1

LandGeom=2

Water=3
Any reason for these settings?
They don't follow the recommended perfect settings: http://www.sas1946.com/main/index.php/topic,9756.msg185327.html#msg185327

Best regards - Mike
Logged
What goes around comes around, you'll see

GeorgeCostanza

  • Always in an Awkward Situation
  • member
  • Offline Offline
  • Posts: 50
  • George Costanza's the name dropin bombs is my game
Re: FPS Issues
« Reply #2 on: August 31, 2017, 12:40:05 AM »

Thanks for your help, much appreciated.

You did say something I haven't read before or have only considered a little bit, that's everyone? Everyone gets crappy frames? It would make sense I guess considering the game being single core. I'll download HWinfo and check on my hardware, and tweak the ini more in line with the perfect settings. But this may have been a problem with my expectations, I can be slightly more at ease knowing that it is simply the case that this game isn't going to run like a modern game.
Logged
GFX: 2 x ASUS ROG Strix GeForce GTX 1080 Ti ~~~~ CPU: Intel i9-7900X 20 Core 3.3GHz  ~~~~ RAM: 32GB DDR ~~~~ STX: Thrustmaster HOTAS-X

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 6652
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: FPS Issues
« Reply #3 on: August 31, 2017, 01:42:34 AM »

This will usually drop to 5-10fps when looking at urban areas
It does so for all of us, on all game versions.

Not all game version. I took this image over Berlin with 8x time compression on. Only one plane in the air. The city is populated with around 600 extra objects. My config is quite outdated, i3, gtx550 and 8 RAM, 1440*900 screen res, 4xAA, 4xAF, vsync adaptive.

SAS~Storebror

  • retired
  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 19789
  • Taking a timeout
    • STFU
Re: FPS Issues
« Reply #4 on: August 31, 2017, 01:58:29 AM »

I've told it already.
Intentionally.
Clear enough I thought...

I know it's tempting guys, but please refrain from posting screenshots of small cities stating that this doesn't happen to you. It does. You simply didn't fly above a large one.

Your Berlin Screenshot is not showing a critically "over" populated city causing such FPS drops.
Your comment is misleading.

Believe it or not: If the map holds a really crowded city, all system's FPS drops to single digit when you look right at it.
All.
Regardless what people want to make you believe.

Best regards - Mike
Logged
What goes around comes around, you'll see

PA_Willy

  • member
  • Offline Offline
  • Posts: 756
Re: FPS Issues
« Reply #5 on: August 31, 2017, 02:29:02 AM »

Believe it or not: If the map holds a really crowded city, all system's FPS drops to single digit when you look right at it.
All.
Regardless what people want to make you believe.

True. It's more critical when you use the zoom view (external or internal) over big cities.
Logged

sniperton

  • member
  • Offline Offline
  • Posts: 1183
Re: FPS Issues
« Reply #6 on: August 31, 2017, 03:24:30 AM »

@George, silly question, but just to make it sure: is your monitor actually plugged into the GPU (and not the motherboard)?

Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 26 queries.