Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 7 8 9 [10] 11 12   Go Down

Author Topic: SAS Modact 6.4 for IL-2 4.13.4m  (Read 68164 times)

0 Members and 1 Guest are viewing this topic.

SAS~Storebror

  • retired
  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 19872
  • Taking a timeout
    • STFU
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #108 on: August 30, 2018, 02:25:11 AM »

I sense a certain confusion here ;)
First of all, SFS files (except for files.sfs) don't contain any class files.
Seconds, the selector has a pretty simple meaning of disabling mods.
You disable a mod by putting a "-" (minus) sign up front of the mod's folder name in the "#SAS" folder.
That. And only that.
What you do with files or subfolders inside a mod's folder, the selector doesn't care.
But disabling a mod folder by adding a "-" prefix definitely keeps it from even being considered for use by the selector at all.
You can try it yourself. Rename "XTD" inside the "#SAS" folder to "-XTD" and see how your game doesn't even start anymore.

]cheers[
Mike
Logged
What goes around comes around, you'll see

Kelso

  • member
  • Offline Offline
  • Posts: 193
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #109 on: August 30, 2018, 02:52:15 AM »

First of all, SFS files (except for files.sfs) don't contain any class files.
I pack complete aircraft mods to SFS, together with classes - works ok.
The exception is the default airplane models, whose classes must be placed in the #sas catalogs.

The "mistake" described by me may be a problem in, for example, searching for conflicts - shifting classes instead of turning them off (within subdirectories of a given mod) gives nothing. Sometimes the moder also add alternative class files to different versions of the game in subdirectories marked with (-). The class files from such excluded locations are also loaded. I would like to add that in SAS Modact 5.3 such action does not occur.
Logged

SAS~Storebror

  • retired
  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 19872
  • Taking a timeout
    • STFU
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #110 on: August 30, 2018, 02:57:40 AM »

Absolute bullshit, sorry to say.
Every word of it: Bullshit.

]cheers[
Mike
Logged
What goes around comes around, you'll see

Kelso

  • member
  • Offline Offline
  • Posts: 193
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #111 on: August 30, 2018, 03:17:56 AM »

Hmmm ... Maybe I have misunderstood.
The correct location of the class file:
X: \ IL-2 Sturmovik Forgotten Battles \ #sas \ PLANE Yak-11 \ FB1FB810757A71AA
Incorrect location:
X: \ IL-2 Sturmovik Forgotten Battles \ #sas \ PLANE Yak-11 \ -123 \ FB1FB810757A71AA - the class is load.
It is only "disabling" the class file (-FB1FB810757A71AA) that causes it to not be loaded.
Logged

SAS~Storebror

  • retired
  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 19872
  • Taking a timeout
    • STFU
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #112 on: August 30, 2018, 03:24:41 AM »

Yes of course.
And that's even intentional.
The latest Selector Version introduced a feature that enables loading classes from subfolders, including hashed, "cod"ded and clear name classfiles:
https://www.sas1946.com/main/index.php/topic,16403.msg626272.html#msg626272

It's not a bug, it's a feature.

]cheers[
Mike
Logged
What goes around comes around, you'll see

Kelso

  • member
  • Offline Offline
  • Posts: 193
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #113 on: August 30, 2018, 03:31:36 AM »

It's not a bug, it's a feature.

If so - there is no topic. I did not know about it.
 ]cheers[

Edit: What are the benefits of this feature?
Logged

Marat

  • member
  • Offline Offline
  • Posts: 261
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #114 on: September 22, 2018, 02:37:03 PM »

I have a question. Can any mod of aircraft somehow affect/overlap the forgotten countries mod, which comes with SAS Modact 6.4 in JSGME being activated? Suddenly it stopped working and shows only stock countries, after installation of several aircraft mods ((
Logged

SAS~Storebror

  • retired
  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 19872
  • Taking a timeout
    • STFU
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #115 on: September 23, 2018, 01:01:45 AM »

What are the benefits of this feature?
Modders can use unhashed classfiles.
No need for wild guessing what is what anymore, you can just have plain text classfile names and plain text package named folder structures.
The idea was to make life easier for both modders and users.

Can any mod of aircraft somehow affect/overlap the forgotten countries mod
Sure.

]cheers[
Mike
Logged
What goes around comes around, you'll see

Marat

  • member
  • Offline Offline
  • Posts: 261
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #116 on: September 23, 2018, 03:45:15 AM »

I found the problem. That was a F7F-3 Tigercat mod with own custom markings, paintscheme and jsgme to activate them. Deliting of them solved the problem and now forgotten countries mod works well.
Logged

Werner Mölders JG 51

  • member
  • Offline Offline
  • Posts: 32
    • Where Gamers Dare Facebook Group
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #117 on: October 01, 2018, 07:24:47 AM »

Here everything works as planned fortunately! ( Just one minor problem with JSGME, see below )

I have just a question: what are\is the difference between the SAS_HD DLLs Alternative version 1 and 2?

In addition it seems I have a problem with JSGME...

I activate the mods as per normal ( JSGME run as admin before starting the game, mods of interests activated and then game started with the selector on " SAS ModAct " ) but they seems to not apply.

Am I'm doing something wrong?
Logged

SAS~Storebror

  • retired
  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 19872
  • Taking a timeout
    • STFU
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #118 on: October 01, 2018, 07:42:22 AM »

HD DLLs 1 and 2 are different versions for the same thing, because each version works on specific graphics cards only.
If one version works for you, simply stick to that.

JSGME mods not applying... have you checked your #SAS folder contents whether the specific mod has been copied to it's destination after activating it?
Maybe you've got some other mod installed that comes first in load order and overrides the JSGME mod you're trying to activate.
Just guessing, as I have no idea which JSGME mod we're talking about nor which mods you have installed already and how.

]cheers[
Mike
Logged
What goes around comes around, you'll see

Werner Mölders JG 51

  • member
  • Offline Offline
  • Posts: 32
    • Where Gamers Dare Facebook Group
Re: SAS Modact 6.4 for IL-2 4.13.4m
« Reply #119 on: October 01, 2018, 08:13:22 AM »

HD DLLs 1 and 2 are different versions for the same thing, because each version works on specific graphics cards only.
If one version works for you, simply stick to that.

JSGME mods not applying... have you checked your #SAS folder contents whether the specific mod has been copied to it's destination after activating it?
Maybe you've got some other mod installed that comes first in load order and overrides the JSGME mod you're trying to activate.
Just guessing, as I have no idea which JSGME mod we're talking about nor which mods you have installed already and how.

]cheers[
Mike

Thanks for the reply. The JSGME folder is untouched ( the standard one that comes with 6.40 ).
So far I've manually added just some ships and objects to the SAS folder ( added only the required lines to the various .ini files present in the STD folder ) all the rest is stock 6.40.
Somehow not a big deal because in the worst case I can manually add them where needed if the JSGME will continue not working.

Returning to the HD DLLs 1 and 2 thing...Which one of them do you suggest to use with an NVidia video card? ( GTX 1080 ti )
Logged
Pages: 1 ... 7 8 9 [10] 11 12   Go Up
 

Page created in 0.015 seconds with 26 queries.