Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Missing ship USS Shamrock Bay in CUP  (Read 1706 times)

0 Members and 1 Guest are viewing this topic.

bergkamp

  • If you can't find it here, it doesn't exist
  • Modder
  • member
  • Offline Offline
  • Posts: 363
Missing ship USS Shamrock Bay in CUP
« on: December 18, 2015, 05:00:23 PM »

I noticed that in CUP #WAW module, the CEV USS Shamrock Bay is not showing. This is a stock 4.12 object, together with USS Kitkun Bay and USS Casablanca. All three are present in CUP #JTW module. Looking at the #WAW STD folder, I see that there are no chief .ini entries for Shamrock Bay but the relevant entries are in there for ships, stationary and i8n technics .ini's

Having corrected the chief entries, Shamrock Bay showed up in the ships placeholder in FMB but clicking on the viewer window, FMB crashed to a blank screen. Unless I have a corrupted file, I'm guessing there may be a 3do file missing in one of the SFS files.

Monty may be able to look at this straightaway, otherwise, if somebody can point me towards which SFS files to look at, I can maybe sort it out myself and let you know what I find.

Best Regards,

Bergkamp



 
Logged

dpeters95

  • Modder
  • member
  • Offline Offline
  • Posts: 450
Re: Missing ship USS Shamrock Bay in CUP
« Reply #1 on: December 18, 2015, 09:04:12 PM »

bergkamp,
   I know Simon has told me that he has fixed the Shamrock Bay problem and more ships are headed our way!  If you still want to look, the WAW41.SFS file contains the Shamrock Bay.  That file was in the WAW Pt04 module.

Dennis
Logged

bergkamp

  • If you can't find it here, it doesn't exist
  • Modder
  • member
  • Offline Offline
  • Posts: 363
Re: Missing ship USS Shamrock Bay in CUP
« Reply #2 on: December 19, 2015, 03:44:25 AM »

Thanks, Dennis.

I will wait for the definitive fix from Monty. In the meantime, for my own curiosity, I will look at that SFS file.

Best Regards,

Bergkamp
Logged

bergkamp

  • If you can't find it here, it doesn't exist
  • Modder
  • member
  • Offline Offline
  • Posts: 363
Re: Missing ship USS Shamrock Bay in CUP
« Reply #3 on: December 31, 2015, 09:59:47 AM »

I have looked at this again and extracted the files from #WAW41. I found that by replacing the hier. file from the Shamrock Bay with the hier from Kitkun Bay, the Shamrock Bay now shows up in the FMB viewer. I found differences with the carrier deck crew and catapult mesh entries, which I have highlighted here:

Kitkun Bay:

Code: [Select]
[Carrier Deck Crew]
[flag]
Mesh flag
Parent _ROOT_
Attaching 0 -1 0 1 0 0 0 0 1 24.2036 -13.6311 17.7963
[Sailor1]
Mesh Sailor1
Parent _ROOT_
Attaching 1 0 0 0 1 0 0 0 1 32.8997 -13.3527 16.8088

[sailors6]
Mesh sailors6
Parent _ROOT_
Attaching 1 0 0 0 1 0 0 0 1 -19.8885 10.4721 14.2881

[catapult]
Mesh catapult
Parent _ROOT_
[catapult1a]
Mesh catapult
Parent _ROOT_
Attaching 0.848 0.5299 0 -0.5299 0.848 0 0 0 1 -14.5332 -9.29119 13.8358

[catapult4]
Mesh catapult4
Parent _ROOT_
[catapult4c]
Mesh catapult4
Parent _ROOT_
Attaching 0 1 0 -1 0 0 0 0 1 44.4266 -28.8302 14.3115

And Shamrock Bay:

Code: [Select]
[Carrier Deck Crew]
[flag]
Mesh flag
Parent _ROOT_
Attaching 0 -1 0 1 0 0 0 0 1 24.2036 -13.6311 17.7963
[Sailor2]
Mesh Sailor2
Parent _ROOT_
Attaching 0.95 0 0 0 1 0 0 0 1 31.3445 -12.0196 18.5498

[sailors6]
Mesh sailors6
Parent _ROOT_
Attaching 1 0 0 0 1 0 0 0 1 -19.7037 10.7002 14.2881

[catapult]
[catapult2a]
Mesh catapult2
Parent _ROOT_
Attaching -0.848 -0.5299 0 0.5299 -0.848 0 0 0 1 -32.2133 8.77747 13.9016

[Directour2a]
Mesh Directour2
Parent _ROOT_
Attaching 0.8191 0.5735 0 -0.5735 0.8191 0  0 0 1  -20.0119 9.86689 14.2566

I have recompiled #WAW41 back to SFS format and all now looks ok.

Best Regards,

Bergkamp

Logged

benitomuso

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2584
  • P.A.L.
Re: Missing ship USS Shamrock Bay in CUP
« Reply #4 on: January 16, 2016, 01:48:36 PM »

Bergkamp, could you please upload that fixed SFS?

Thanks
Logged

bergkamp

  • If you can't find it here, it doesn't exist
  • Modder
  • member
  • Offline Offline
  • Posts: 363
Re: Missing ship USS Shamrock Bay in CUP
« Reply #5 on: January 21, 2016, 09:11:31 AM »

Bergkamp, could you please upload that fixed SFS?

Thanks

My apologies for not replying. This got fixed overnight on the 16th and I failed to look at this topic any further.

Best Regards
Logged
Pages: [1]   Go Up
 

Page created in 0.251 seconds with 25 queries.