Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 5 6 7 [8]   Go Down

Author Topic: B-24D-140-CO (from 4.13) - v1.02  (Read 45833 times)

0 Members and 1 Guest are viewing this topic.

Addison129

  • member
  • Offline Offline
  • Posts: 2
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #84 on: December 27, 2018, 07:45:20 PM »

Forget what I said.
Logged

stoney69

  • member
  • Offline Offline
  • Posts: 130
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #85 on: December 30, 2018, 02:10:05 PM »

Sorry Addison129, I just saw your post. Did you get things sorted out ok?
Logged

Stefan SG

  • Modder
  • member
  • Offline Offline
  • Posts: 455
  • Braver than you believe. Stronger than you seem.
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #86 on: February 04, 2019, 01:18:32 PM »

Let me propose bombing sight fix for 4.12 for B-24D-140-CO:

http://www.mediafire.com/file/uh9doea50dihmt3/B-24D-140-CO_BombingSight_Fix_412.zip

Has the bombsight been fixed yet? It seems to me everything works except for the bombsight.
Logged

Epervier

  • 4.09 Guardian Angel !
  • SAS Team
  • member
  • Offline Offline
  • Posts: 8394
  • I'm French and Rebel_409! Nobody is perfect!
    • Some tinkering here
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #87 on: February 04, 2019, 01:25:03 PM »

Let me propose bombing sight fix for 4.12 for B-24D-140-CO:
Thanks for Imperialists !
First post updated ! ;)
Logged
If your results are not up to your expectations, tell yourself that as large oak was once an acorn ...

max_thehitman

  • SAS~Area51
  • Modder
  • member
  • Offline Offline
  • Posts: 8977
  • Beer...Girls...IL2+Mods!
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #88 on: February 04, 2019, 01:52:18 PM »

Thank you very much for the new fixes Stefan SG.
Mighty nice of you!

Big Cheers!


Logged
Everything I like is either illegal, immoral or fattening ! Welcome to SAS1946

whistler

  • Modder
  • member
  • Offline Offline
  • Posts: 2784
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #89 on: February 05, 2019, 02:18:17 AM »

Thanks Stefan! I shall try the fix later and report back.

From memory, activating this bird with JSGME in BAT breaks other bombers. I think it has to do with the new 4.13 turret animations. In any case it is good to see improvements! Thanks!
Logged
NG-HUD v3.6.1 | NG-MAP v3.2 | NG-CAM v2.0 | NG-PAL v1.2: https://www.sas1946.com/main/index.php/board,93.0.html

whistler

  • Modder
  • member
  • Offline Offline
  • Posts: 2784
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #90 on: February 05, 2019, 11:09:36 AM »

Fix working a treat in BAT! Thanks again Stefan! This bird is now ready for some serious bombing missions!

BAT users,

1) Place Stefan's fixes 6CB335626B1E7D0A and 31E73C8C1CE6FD0C in BATMODS\#WAW_ALT-B-24D-140-CO\#WAW3\!0000_Aircraft_Options
2) Activate #WAW_ALT-B-24D-140-CO with JSGME

Careful though, there apparently are some issues with the other Liberators when this one is activated.

From the mod comments:
Quote
#WAW_ALT-B-24D-140-CO
The new TD-413 Liberator ball turret code breaks all the other Liberators!
Activate this to fly the B-24D-140-CO but you will loose function on all other Liberators.
Logged
NG-HUD v3.6.1 | NG-MAP v3.2 | NG-CAM v2.0 | NG-PAL v1.2: https://www.sas1946.com/main/index.php/board,93.0.html

Piotrek1

  • member
  • Offline Offline
  • Posts: 1606
    • SAS IL BYTES BACK
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #91 on: February 05, 2019, 01:32:15 PM »

Thank you for the fix, Stefan.
Logged

ben_wh

  • member
  • Offline Offline
  • Posts: 333
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #92 on: February 09, 2019, 06:17:58 AM »

Thank you, Stefan, for the fix.

Tested only in HSFX7 but suspect this is the same situation with other 4.12 installation as well.

1)  Took Epervier's flyable version in the first post

2)  Applied 'nose wheels texture fix', also in the first post

3)  These scenarios were observed:

a)  If you apply Stefan's bombsight fix above (https://www.sas1946.com/main/index.php/topic,46782.msg666574.html#msg666574) -

You'd have a flyable B-24D-140-CO with usable bombsight, but this will conflict with other (older) B-24/ Liberator versions - ground start with landing gears up - as pointed out by several in this thread

b)  If you apply Spitwulf's fix here: https://www.sas1946.com/main/index.php/topic,46782.msg520911.html#msg520911

You'd have a B-24D-140-CO flyable, _without_ usable bombsight, but compatible with other B-24 (older) versions

If you apply both fixes the B-24D-140-CO may freeze when trying to access bombsight, and IL-2 crash when exiting mission.  (Noted that Spitwulf's fix was intended for 4.10)

Wonder if others have observed the same.

Cheers,


 
Logged

Airbourne

  • member
  • Offline Offline
  • Posts: 310
  • Nil Desperandum
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #93 on: February 10, 2019, 03:16:43 AM »

I just tried the same experiment in VP's Modpack with exactly the same results.
Logged

whistler

  • Modder
  • member
  • Offline Offline
  • Posts: 2784
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #94 on: February 10, 2019, 04:11:42 AM »

Yep, all B-24s work great with Stefan SG's fix (all stations, no CTDs) but the older won't deploy the gear on scramble :-X

We are closer though.
Logged
NG-HUD v3.6.1 | NG-MAP v3.2 | NG-CAM v2.0 | NG-PAL v1.2: https://www.sas1946.com/main/index.php/board,93.0.html

9ball

  • member
  • Offline Offline
  • Posts: 50
Re: B-24D-140-CO (from 4.13) - v1.02
« Reply #95 on: March 17, 2019, 03:23:57 PM »

I agree that Stefan SG’s Bombsight fix is a step forward, but the fact is a fully functioning B-24D-140-CO is still incompatible with most of the other B-24’s.

The problem hinges on this class file: 2E1ADF6EDF8A6C64, which when used, breaks six of the eight available B-24 Mods.
Unfortunately Stefan SG’s Bombsight fix requires this class to function correctly.
Hopefully some experienced java master will take up the baton and make this Liberator killing class file play nice with the other B-24’s.

Until then, I’ve made a JSGME re-package of Spitwulf’s fix for DBW and 4.12, with additional 3do’s, that fix anomalies in the Forward gun/Bombardier position.
With the patch you can have four(seven via Mods)fully working B-24’s and the B-24D-140-CO without a working bombsight.
Their are three additional B-24 Mods you can add to BAT, The B-24J Liberator, The PB4Y-1 Liberator, and the Liberator GR-MK.I, they all work with this patch.

B-24 Series Compatibility Patch(Original by Spitwulf) Download here: http://www.mediafire.com/file/cw6yv7fmintwd4b/JSGME_re-package_of_Spitwulf_B-24_fix.7z/file
Un-zip and drop the included folder into your BAT(3.5) MUSKETEER game, and unable via JSGME.

The B-24-140-CO Bombsight Fix by Stefan SG breaks this patch, and causes the belly flop gear problem.
I’ve tested the patch with QMB/FMB missions on heavily Modded and virgin BAT(3.5) versions, with no apparent issues.
Unfortunately the Compatibility patch does not seem to work on earlier versions of BAT.

*All credit for this patch goes to Spitwulf. These are his original class files, all I’ve done is make them a little easier to use and test.
Thanks 9ball,
Logged
Pages: 1 ... 5 6 7 [8]   Go Up
 

Page created in 0.215 seconds with 24 queries.