Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2   Go Down

Author Topic: C.U.P. Module-03 World at War PART-09  (Read 10042 times)

0 Members and 1 Guest are viewing this topic.

SAS~Monty27

  • SAS Team
  • member
  • Offline Offline
  • Posts: 3850
  • Action and Adventure!
    • SPEEDMACHINE
C.U.P. Module-03 World at War PART-09
« on: June 01, 2015, 03:24:01 AM »

C.U.P. Module-03 World at War PART-09

My bad!

Something went wrong with this upload.  I think an incomplete version, or errors in compression, whatever, it ain't all there. 

We have had 40+ great upload packages for CUP and this is the first time I screwed up an upload.

So please, chill out and wait for it.  Its of no use right now and if you are broken as a result the choices are:

1)Fix it yourself
2)Wait for a few days

Once it is up properly - Then I will accept any comments and re-open the thread.

***************************

FAQ: Oh no I buggered my install! - No worries!

How to reset to a clean WAW Pt-08


JSGME Disable all #WAW OPTIONS
JSGME Disable al #CUP OPTIONS

Inside main directory Il2 minus out (-#WAW)
Re-install #WAW from WAW Pt-08

JSGME Enable options to taste
MissonPRO, VisualMOD etc...

***************************

The fact is that in messing about with carrier parking and SASEngineMOD, late in the compilation, I took my eye off the ball. 

Missing or moved classfiles broke many stationaries.  I also had busted 3dos that had already passed testing and were not broken at that stage.

If an item passes testing and then gets broken it can sometimes be over-looked.

I don't like 'patches' and 'fixes' - CUP has good rep and its my responsibility to compile something properly when its uploaded.

***************************

A Clean WAW Pt-08
WAW Part-08 is stable, not broken and works fine.  I have gone back to square one to start again with Part-09 and avoid the errors that occurred through late tinkering.

Carrier Parking is all good - no need to mess with it
Carrier Catapults work where they should - can add extra Essex classes to catapult.ini (will be in update)


SAS~Monty27
Logged

Griffon_301

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2199
Re: C.U.P. Module-03 World at War PART-09
« Reply #1 on: June 01, 2015, 03:37:11 AM »

Great stuff Simon!

although I do have all the aircraft and loads of other stuff of this upgrade in my modded WAW already, its good to get the "whole Monty" :D in sfs format too, another steps towards perfection :)

thanks a lot, looking forward to more goodness :)
Logged

SAS~Monty27

  • SAS Team
  • member
  • Offline Offline
  • Posts: 3850
  • Action and Adventure!
    • SPEEDMACHINE
Re: C.U.P. Module-03 World at War PART-09
« Reply #2 on: June 01, 2015, 03:44:17 AM »

Hi Phil, yep, time for another mod-folder cleanout.  It is nice to cut down on the sub-folders in there and keep it slim.
Logged

Griffon_301

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2199
Re: C.U.P. Module-03 World at War PART-09
« Reply #3 on: June 01, 2015, 04:17:51 AM »

yep :) hehe I know how my evening is going to look like now :)
Logged

{64s}Takeshi

  • member
  • Offline Offline
  • Posts: 201
Re: C.U.P. Module-03 World at War PART-09
« Reply #4 on: June 01, 2015, 04:19:59 AM »

Many thanks for these improvement  8)

Battle for France, here we come!  Our thanks also to the modders who bring these lost aircraft back to life.



But it's a pity that Freddy's D520 is not included  :\'(
Logged

decipher

  • Missioneer
  • member
  • Offline Offline
  • Posts: 297
Re: C.U.P. Module-03 World at War PART-09
« Reply #5 on: June 01, 2015, 04:27:28 AM »

downloading now, can't wait to fiddle this into my custom CUP installation :D
i know i know, clean install would be easier, but i love to finetune things, and figuring out how the different modding things work together also enables me to help others better, sometimes.

either way: i salute to your enduring motivation and hard work! when i have all the updates running i hopefully will be in the mood for some new QMB building sessions.

EDIT: looking good so far, glad that i could contribute a little to this! full packed carrier decks seem to work fine with most navy japanese planes, but from my quick first tests it seems that the JapanCat's A6M's don't take advantage of this.
they space out like before with only 2 Zeros per row. default A6M2-21 fits 3 in a row.




Logged

fightingirish

  • member
  • Offline Offline
  • Posts: 102
  • It's only a game....isn't it?!?
Re: C.U.P. Module-03 World at War PART-09
« Reply #6 on: June 01, 2015, 06:17:03 AM »

Hi Guys,

d/l'd the latest installments today and firstly thankyou again for your wonderful work in bringing out the CUP modules.

I noticed a slight issue when looking out of the cockpit in the BR.20M:




as you can see, the cockpit appears ahead of the cockpit view. I noticed that this happened for all the BR.20 types.
My installation is purely vanilla game plus CUP modules with no other added mods. Wasn't sure if a log would be needed or not as the game still functions despite the issue noted in the picture.
Logged

decipher

  • Missioneer
  • member
  • Offline Offline
  • Posts: 297
Re: C.U.P. Module-03 World at War PART-09
« Reply #7 on: June 01, 2015, 06:24:20 AM »

just a heads up, the included engine mod does not include the western engine mod AI patch.

with the plain updated waw-9 pack AI planes still seem to crash into hills and the ground constantly.


on a personal note... it sadly ends in a mess with my custom engine mod where i have included the western patch and jcats merged effects 2. crash to desktop when AI gets moved to take-off position on carriers.... probably too many different versions of the same classfiles messing with each other... maybe i can figure this out... but very frustrating (not your fault, my fault, for messing around so much. hehe)..

Logged

SAS~Monty27

  • SAS Team
  • member
  • Offline Offline
  • Posts: 3850
  • Action and Adventure!
    • SPEEDMACHINE
Re: C.U.P. Module-03 World at War PART-09
« Reply #8 on: June 01, 2015, 07:06:25 AM »

just a heads up, the included engine mod does not include the western engine mod AI patch.

with the plain updated waw-9 pack AI planes still seem to crash into hills and the ground constantly.


on a personal note... it sadly ends in a mess with my custom engine mod where i have included the western patch and jcats merged effects 2. crash to desktop when AI gets moved to take-off position on carriers.... probably too many different versions of the same classfiles messing with each other... maybe i can figure this out... but very frustrating (not your fault, my fault, for messing around so much. hehe)..

Welcome to my world.  8)  Those AIs have been a constant problem.  But if the patch breaks the carrier, no good.  But cannot the AI waypoints can prevent this, due to their course, altitude, formation and actions set?
Logged

decipher

  • Missioneer
  • member
  • Offline Offline
  • Posts: 297
Re: C.U.P. Module-03 World at War PART-09
« Reply #9 on: June 01, 2015, 07:33:10 AM »

for full missions / campaigns.. probably but for QMBs i think only the western AI patch can help, because the flight height is dynamic and all included planes in a QMB will start on the player selected height i think. so if its below the highest landscape...
also when AI has to go around on landing they tend to crash into ground without the western patch...

anyway... i compared the folders... and wonder. you did not change any of the classfiles in the engine_mod folder it seems? so this full carrier deck load... would you mind sharing which classfiles are responsible? i am guessing you put them in the !0000_classfiles folder, wich grew from 2351 to 2748 files. or is the full carrier deck loading based on the different button file? i didnt check that yet.

cheers!
Logged

SAS~Monty27

  • SAS Team
  • member
  • Offline Offline
  • Posts: 3850
  • Action and Adventure!
    • SPEEDMACHINE
Re: C.U.P. Module-03 World at War PART-09
« Reply #10 on: June 01, 2015, 07:55:43 AM »

Thanks deci, that explains some things.  They are either in !0000_Classfiles or !SAS_Engine_Mod - The CUP uploads reflect my exact install, nothing else.
Logged

decipher

  • Missioneer
  • member
  • Offline Offline
  • Posts: 297
Re: C.U.P. Module-03 World at War PART-09
« Reply #11 on: June 01, 2015, 08:05:53 AM »

ok. i compared the !SAS_Engine_Mod folders of part 8 with part 9. they are identical. is there any way for you to remember or find out which classfiles exactly are for the full deck mod? okay i crosschecked folders with winmerge to compare files and found 6 classfiles that are used in the western patch and are in the new part 9 classfiles folder... not that it matters much for anyone else, with the default engine_mod it seems to work, so the normal users should be fine i guess.

:)

only for people who use engine_mod with western patch in cup:
edit: i don't want to derail the thread too much, but for anyone who is using a modified engine mod with the western patch (and knows what they are doing) and experience crashing/freezing when AI is taking off carriers after installing part 9, i was able to fix this for myself by disabling 2A0BC4B8216AA6A4 and 9EE807369FED1864. this is for expert mod meddlers only, since it might have other grave consequences (as always) :D and i am too tired to investigate further, but my game loaded, western patch was active (checked mountainflight mission with no crash), and had 4 b5n2's take off from carrier deck without crashing...

now to get some sleep :D
Logged
Pages: [1] 2   Go Up
 

Page created in 0.049 seconds with 30 queries.