Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: No marking on static planes?  (Read 2395 times)

0 Members and 1 Guest are viewing this topic.

Baffrah

  • member
  • Offline Offline
  • Posts: 61
No marking on static planes?
« on: April 15, 2015, 09:15:45 AM »

Hello guys!
In every DGen campaigns I tried with CUP (actually: stock german fighter south, stock ussr fighter leningrad, and Greybeard's Murmansk campaign), I found that the markings were not displayed on any of the static planes on airfield. It's not a very big deal, but is there something I can do about that?
Thank's!
Logged

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 6652
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: No marking on static planes?
« Reply #1 on: April 15, 2015, 12:51:22 PM »

It's caused by the SAS engine mod. For me this bug completely ruined the dgen campaigns.
You can not remove it since its in a sfs file. I'm not sure whos working on java fixes for CUP, maybe try to report this error in the SAS engine mod topics.

Baffrah

  • member
  • Offline Offline
  • Posts: 61
Re: No marking on static planes?
« Reply #2 on: April 15, 2015, 12:57:39 PM »

Thank's for ur answer vpmedia. I'll try to repport it on the topic you said... when i'll have cured my actual problem since the last CUP update; WAW isn't working anymore at all!  :\'(
Logged

Griffon_301

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2210
Re: No marking on static planes?
« Reply #3 on: April 15, 2015, 12:59:31 PM »

what is not working Baffrah? do you crash at start up? if so where? and have you added any mods before adding #8?
Logged

Baffrah

  • member
  • Offline Offline
  • Posts: 61
Re: No marking on static planes?
« Reply #4 on: April 15, 2015, 01:14:13 PM »

Wow, that's what I call fast response! ;)
Well, no I haven't had any mod before #8.
Everything is loading fine, until the mission loads 100%. Then it freeze, and got the "IL-2 6Dof/TIR Enable Executable for modded IL-2 Sturmovik 1946 has stopped working". The same I faced in early CUP day's, cause by the Pal_visual mod for 4.12. But it's something different now, as whatever mod enabled and even with nothing enabled in jsgme, it just happens.
JTW is working. DOF is working.
I tried to reinstall every WAW module in order, with no luck.


Logged

Griffon_301

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2210
Re: No marking on static planes?
« Reply #5 on: April 15, 2015, 01:42:19 PM »

thats weird...pls post your log file
Logged

Baffrah

  • member
  • Offline Offline
  • Posts: 61
Re: No marking on static planes?
« Reply #6 on: April 15, 2015, 02:04:30 PM »

Here we go. Very big one, so I just post here some parts that I think can help

Code: [Select]
INTERNAL ERROR: Str2FloatClamp() - Clamped 75 -> 32 (delta = -43) to Range 0..32
INTERNAL ERROR: Str2FloatClamp() - Clamped 120 -> 60 (delta = -60) to Range 0..60
Cannot load sound preset motor.DB-600_Series.start.begin (java.lang.Exception: Invalid preset format)
Ship: Value of [IJNMusashi_1942]:<Mesh> not foundCan't set property
java.lang.RuntimeException: Can't set property
at com.maddox.il2.objects.ships.BigshipGeneric$SPAWN.getS(BigshipGeneric.java:226)
at com.maddox.il2.objects.ships.BigshipGeneric$SPAWN.LoadShipProperties(BigshipGeneric.java:422)
at com.maddox.il2.objects.ships.BigshipGeneric$SPAWN.<init>(BigshipGeneric.java:774)
at com.maddox.il2.objects.ships.ShipJFC1.<clinit>(ShipJFC1.java:22)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at com.maddox.rts.Spawn.get_WithSoftClass(Spawn.java:84)
at com.maddox.rts.Spawn.get_WithSoftClass(Spawn.java:57)
at com.maddox.il2.game.Main.preloadChiefClasses(Main.java:243)
at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1648)
at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1579)
at com.maddox.il2.game.MainWin3D.beginApp(MainWin3D.java:212)
at com.maddox.il2.game.Main.exec(Main.java:432)
at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)
Car: Value of [AustinAmb]:<Soldiers> (3.0) is out of range (1.0;2.0)
Can't set property
java.lang.RuntimeException: Can't set property
at com.maddox.il2.objects.vehicles.cars.CarGeneric$SPAWN.getF(CarGeneric.java:1493)
at com.maddox.il2.objects.vehicles.cars.CarGeneric$SPAWN.LoadCarProperties(CarGeneric.java:1602)
at com.maddox.il2.objects.vehicles.cars.CarGeneric$SPAWN.<init>(CarGeneric.java:1619)
at com.maddox.il2.objects.vehicles.cars.TomooseCar.<clinit>(TomooseCar.java:31)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at com.maddox.rts.Spawn.get_WithSoftClass(Spawn.java:84)
at com.maddox.rts.Spawn.get_WithSoftClass(Spawn.java:57)
at com.maddox.il2.game.Main.preloadChiefClasses(Main.java:243)
at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1648)
at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1579)
at com.maddox.il2.game.MainWin3D.beginApp(MainWin3D.java:212)
at com.maddox.il2.game.Main.exec(Main.java:432)
at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)
Problem in car spawn: com.maddox.il2.objects.vehicles.cars.TomooseCar$AustinAmb
Car: Value of [Firetruck]:<Soldiers> (3.0) is out of range (1.0;2.0)
Can't set property
java.lang.RuntimeException: Can't set property
at com.maddox.il2.objects.vehicles.cars.CarGeneric$SPAWN.getF(CarGeneric.java:1493)
at com.maddox.il2.objects.vehicles.cars.CarGeneric$SPAWN.LoadCarProperties(CarGeneric.java:1602)
at com.maddox.il2.objects.vehicles.cars.CarGeneric$SPAWN.<init>(CarGeneric.java:1619)
at com.maddox.il2.objects.vehicles.cars.TomooseCar.<clinit>(TomooseCar.java:32)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at com.maddox.rts.Spawn.get_WithSoftClass(Spawn.java:84)
at com.maddox.rts.Spawn.get_WithSoftClass(Spawn.java:57)
at com.maddox.il2.game.Main.preloadChiefClasses(Main.java:243)
at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1648)
at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1579)
at com.maddox.il2.game.MainWin3D.beginApp(MainWin3D.java:212)
at com.maddox.il2.game.Main.exec(Main.java:432)
at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)
Problem in car spawn: com.maddox.il2.objects.vehicles.cars.TomooseCar$Firetruck
No spawner for 'com.maddox.il2.objects.vehicles.planes.Plane$BF_109K4C3'
FM called 'FlightModels/Fi-156B-2.fmd' is being loaded from Alternative File: 'gui/game/buttons'

INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
INTERNAL ERROR: Str2IntClamp() - Clamped 20 to Range 0..1
warning: no files : music/crash


null
java.lang.ClassNotFoundException
at com.maddox.rts.ObjIO.classForName(ObjIO.java:138)
at com.maddox.il2.gui.GUIBriefingGeneric._enter(GUIBriefingGeneric.java:1379)
at com.maddox.il2.gui.GUIBriefing._enter(GUIBriefing.java:200)
at com.maddox.il2.game.GameState.enter(GameState.java:97)
at com.maddox.il2.gui.GUIBriefingGeneric.enter(GUIBriefingGeneric.java:925)
at com.maddox.il2.gui.GUIBriefing.enter(GUIBriefing.java:193)
at com.maddox.il2.gui.GUIDGenBriefing.enter(GUIDGenBriefing.java:22)
at com.maddox.il2.game.GameStateStack.change(GameStateStack.java:36)
at com.maddox.il2.game.GameStateStack.change(GameStateStack.java:24)
at com.maddox.il2.gui.GUICampaigns.doStart(GUICampaigns.java:483)
at com.maddox.il2.gui.GUICampaigns.access$100(GUICampaigns.java:32)
at com.maddox.il2.gui.GUICampaigns$DialogClient.notify(GUICampaigns.java:85)
at com.maddox.gwindow.GWindow.notify(GWindow.java:144)
at com.maddox.gwindow.GWindowDialogControl._notify(GWindowDialogControl.java:51)
at com.maddox.il2.gui.GUIButton._notify(GUIButton.java:18)
at com.maddox.gwindow.GWindowDialogControl.mouseClick(GWindowDialogControl.java:86)
at com.maddox.il2.gui.GUIButton.mouseClick(GUIButton.java:22)
at com.maddox.gwindow.GWindow._mouseButton(GWindow.java:556)
at com.maddox.gwindow.GWindowRoot.doMouseButton(GWindowRoot.java:251)
at com.maddox.gwindow.GWindowManager.doMouseButton(GWindowManager.java:69)
at com.maddox.il2.engine.GUIWindowManager.msgMouseButton(GUIWindowManager.java:126)
at com.maddox.rts.MsgMouse.invokeListener(MsgMouse.java:98)
at com.maddox.rts.Message._send(Message.java:1217)
at com.maddox.rts.Message.sendToObject(Message.java:1191)
at com.maddox.rts.Message.sendToArray(Message.java:1147)
at com.maddox.rts.Message.sendTo(Message.java:1128)
at com.maddox.rts.Message.trySend(Message.java:1115)
at com.maddox.rts.Time.loopMessages(Time.java:180)
at com.maddox.rts.RTSConf.loopMsgs(RTSConf.java:101)
at com.maddox.il2.game.MainWin3D.loopApp(MainWin3D.java:131)
at com.maddox.il2.game.Main.exec(Main.java:449)
at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)
 INTERNAL ERROR: Str2FloatClamp() - Clamped 5 -> 2 (delta = -3) to Range 0..2
INTERNAL ERROR: Str2FloatClamp() - Clamped 2e+006 -> 1e+006 (delta = -1e+006) to Range 0..1e+006

ERROR file: File users/peterson/Icons not found
Mission: campaign/gb/DGen_M_Murmansk41peterson0/19410911-0.mis is Playing
INTERNAL ERROR: Can't open file 'PaintSchemes/Pilots/Par défaut'
java.lang.NoSuchFieldError: listenTACAN
at com.maddox.il2.objects.air.Cockpit.updateBeacons(Cockpit.java:1000)
at com.maddox.il2.objects.air.Cockpit.access$600(Cockpit.java:21)
at com.maddox.il2.objects.air.Cockpit$Draw.preRender(Cockpit.java:100)
at com.maddox.il2.objects.air.Cockpit.preRender(Cockpit.java:834)
at com.maddox.il2.game.Main3D$RenderCockpitMirror.preRender(Main3D.java:686)
at com.maddox.il2.engine.Renders.b(Unknown Source)
at com.maddox.il2.engine.Renders.paint(Unknown Source)
at com.maddox.il2.engine.RendersTicker.msgTimeOut(Renders.java:637)
at com.maddox.rts.MsgTimeOut.invokeListener(MsgTimeOut.java:73)
at com.maddox.rts.Message._send(Message.java:1217)
at com.maddox.rts.Message.sendToObject(Message.java:1191)
at com.maddox.rts.Message.sendTo(Message.java:1134)
at com.maddox.rts.Message.trySend(Message.java:1115)
at com.maddox.rts.Time.loopMessages(Time.java:252)
at com.maddox.rts.RTSConf.loopMsgs(RTSConf.java:101)
at com.maddox.il2.game.MainWin3D$Background.step(MainWin3D.java:159)
at com.maddox.rts.BackgroundTask.doRun(BackgroundTask.java:167)
at com.maddox.il2.game.MainWin3D.loopApp(MainWin3D.java:108)
at com.maddox.il2.game.Main.exec(Main.java:449)
at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)
Logged

western0221

  • Modder
  • member
  • Offline Offline
  • Posts: 6790
  • Live in Japan
    • IL-2 itaki blog
Re: No marking on static planes?
« Reply #7 on: April 15, 2015, 11:33:01 PM »

It's caused by the SAS engine mod. For me this bug completely ruined the dgen campaigns.
You can not remove it since its in a sfs file. I'm not sure whos working on java fixes for CUP, maybe try to report this error in the SAS engine mod topics.

I want to fix that SAS Engine MOD bug and need information about dgen workings, functions.
But no one helps me, I cannot begin it.
Logged

hello

  • member
  • Offline Offline
  • Posts: 278
Re: No marking on static planes?
« Reply #8 on: April 15, 2015, 11:40:41 PM »


I want to fix that SAS Engine MOD bug and need information about dgen workings, functions.
But no one helps me, I cannot begin it.

You would have to contact Asura. He is in the know about any workings of DGen.

http://www.sas1946.com/main/index.php/topic,20104.0.html
Logged

Baffrah

  • member
  • Offline Offline
  • Posts: 61
Re: No marking on static planes?
« Reply #9 on: April 16, 2015, 03:59:54 AM »

So, I suppose my actual CUP install is a total SNAFU...
Moreover, I was still using the torrent download v1, with all the little fixes from CUP's early days... I guess the problem lie somewhere over there and that is all messed up.
Nevermind. In a few days, i'm gonna re-start from scrach, erasing everything from my current install, downloading a new fresh torrent v2, make a nice clean new install, etc. etc... Yes. I'll do.

Sorry about the off-topic in my own topic, btw. :P
Logged

Asura

  • Modder
  • member
  • Offline Offline
  • Posts: 446
Re: No marking on static planes?
« Reply #10 on: April 17, 2015, 12:37:59 AM »

It's caused by the SAS engine mod. For me this bug completely ruined the dgen campaigns.
You can not remove it since its in a sfs file. I'm not sure whos working on java fixes for CUP, maybe try to report this error in the SAS engine mod topics.

I want to fix that SAS Engine MOD bug and need information about dgen workings, functions.
But no one helps me, I cannot begin it.

Ask - all that I know I will tell. :)
Logged

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 6652
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: No marking on static planes?
« Reply #11 on: April 17, 2015, 04:15:25 AM »

My best guess would be that this dgen/markings problem has to do with the fact that additional parameters were added to the static aircraft by Team Daidalos in the 4.12 patch which resulted in some code changes or additions. I'm not a java programmer so I cant really help solving this problem.

I was testing the SAS engine mod only for a week but I noticed two other things:
- AAA accuracy was really bad
- the game did not remember the my previously selected skins so I had to reselecet them every time which is a big problem if youre testing skins (this is maybe releated to PAL Mission Pro + SAS engine mod used together)

These three reasons were enough to decide for the removal of the mod.
Pages: [1]   Go Up
 

Page created in 0.143 seconds with 27 queries.