Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 ... 8 9 10 [11]   Go Down

Author Topic: "IL-2 SCW" - Spanish Civil War Mod Pack  (Read 62866 times)

0 Members and 1 Guest are viewing this topic.

clam liquid

  • member
  • Offline Offline
  • Posts: 6
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #120 on: January 25, 2017, 03:18:27 PM »

Still working on my problem, I found that UP3 alone, when enabled via jgsme, caused the crash.

 An UP3 RC4 update patch helped and got UP3 going, but then jsgme just hangs if you try to load IL-2 SCW with all 11 patches.

Also UP3 patched hangs if you try to load it over a successfully enabled IL2-SCW.

Oddly UP3 with patch allows you to select a spain campaign, perhaps because these were added outside the jsgme folder.  Of course it would probably never fly. 

What a zoo,
Logged

PhantomII

  • member
  • Offline Offline
  • Posts: 386
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #121 on: January 25, 2017, 07:40:35 PM »

Hi Clam, I may be wrong but I don't think you need UP3 activated to play SCW. all you need to do is activate the SCW mod that is in jsgme and it should start. To quote the install process:

3. In your IL-2 root folder click on the icon named “JSGME.exe”. You will find one entry named “IL-2 SCW Mod Pack for DBW”. Select it, then click on the top arrow button (“Enable selected mod”). The Mod Pack will then be enabled. (It can take a while.) After this process is finished, close JSGME, and start IL-2 the regular way. (To the disable the Mod Pack, simply reverse the process in JSGME.)

Maybe saying the obvious but be sure your selector is set to DBW.
Logged

PhantomII

  • member
  • Offline Offline
  • Posts: 386
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #122 on: January 27, 2017, 09:53:47 PM »

Hey Clam, just curious, did you get your SCW mod up and running?
Logged

SAS~Poltava

  • Avid FMB user
  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 3554
  • Help Ukraine fight
    • Check out my modded campaigns
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #123 on: January 28, 2017, 06:59:40 AM »

Hi Clam, I may be wrong but I don't think you need UP3 activated to play SCW. all you need to do is activate the SCW mod that is in jsgme and it should start. To quote the install process:

Exactly! It is getting DBW running that is the key! Just see that your selector is set to DBW (version 1.71). Then start it up without any JSGME-additions at all, just to see that DBW is working.

If that is the case, DBW works (you see the screen with the blue clouds etc), then quit, activate "IL-2 SCW" through JSGME, as per the instructions amd start again! No need to activate UP3 etc.
Logged
You want to give financial support to a front line Ukraine unit fighting the Russian invaders? Paypal kyivragnarock@gmail.com

rotagen

  • member
  • Offline Offline
  • Posts: 20
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #124 on: February 19, 2024, 07:53:09 AM »

Hey all, looks like this thread is old but I'm still interested in SCW stuff.

I haven't played IL-2 in quite some time and it is probably not updated fully, but just a couple questions.

Is there a single large download for DBW (dark blue world?) or do I have to download the main one and all those updates?

Secondly, is there a particular version of IL-2 that is required for this mod to work ?  Thanks.

Been playing Jane's WW2F and RB3D mostly, Still like all those old customizeable sims.. I find the newer sims are all multiplayer and mostly eye-candy without much dogfighting or single player content.
Logged

Frankiek

  • SAS Team
  • member
  • Online Online
  • Posts: 2513
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #125 on: February 19, 2024, 11:48:59 AM »

Yes there is a megapack https://www.sas1946.com/main/index.php/topic,21514.0.html
that will bring you from IL-2 4.07 to DBW1.71 and then you can install the SCW module.

However you may want to look at the latest BAT that is the legitimate successor of DBW https://www.sas1946.com/main/index.php/board,264.0.html

The TGA module of BAT includes all the SCW material and more and is constantly updated

BAT is based on IL-2 4.12.2 and here there is a mega patch that will bring 4.07 (or no matter what version) up to 4.12.2

If you the GOG or Steam version you most likely have version 4.13.4 in this case you will need the unpatcher https://www.sas1946.com/main/index.php/topic,55464.0.htmlthat will bring you down to 4.12.2


Logged

rotagen

  • member
  • Offline Offline
  • Posts: 20
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #126 on: February 27, 2024, 10:53:09 AM »

Hello:

I'm starting to get back into flying my combat sims and SCW aircraft are some of my favorite... some great work here !!

I haven't played my IL-2 in years, I've been enjoying the old classics Like Jane's ww2 fighters and RB3D the past couple weeks though.

I remember at some point installing some SCW planes onto IL-2 ... Is there a specific IL-2 version I need in order to install these mods?

I'm sure there is a lot of new stuff here.

I have version 3.0.6.10 installed .... I read the summary on the first page but I don't think it mentioned... Thanks!
Logged

Frankiek

  • SAS Team
  • member
  • Online Online
  • Posts: 2513
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #127 on: February 27, 2024, 11:26:42 AM »



I remember at some point installing some SCW planes onto IL-2 ... Is there a specific IL-2 version I need in order to install these mods?

I'm sure there is a lot of new stuff here.

I have version 3.0.6.10 installed .... I read the summary on the first page but I don't think it mentioned... Thanks!

Well is not mentioned as this specific download is located in the Old Mod Packs-DBW section so everything you will find here was supposed to be installed in DBW.

The last DBW version available is 1.71 and DBW needs to be installed on IL-2 version 4.10.1

If you don't have DBW just go here https://www.sas1946.com/main/index.php/topic,21514.0.html

However if you would like to have a more recent pack with a lot of SCW content you could also consider to install BAT that has a specific module called TGA covering aviation in the '30s
https://www.sas1946.com/main/index.php/board,264.0.html
Logged

rotagen

  • member
  • Offline Offline
  • Posts: 20
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #128 on: February 28, 2024, 08:12:09 AM »

Thanks for your help!

I will start installing soon.
Logged

Draken

  • member
  • Offline Offline
  • Posts: 1049
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #129 on: February 28, 2024, 11:40:58 AM »

You could also install Ultraspain on a clean v4.12.2 , by adding the following patches .
https://www.sas1946.com/main/index.php/topic,61333.0.html
Logged

rotagen

  • member
  • Offline Offline
  • Posts: 20
Re: "IL-2 SCW" - Spanish Civil War Mod Pack
« Reply #130 on: March 08, 2024, 06:32:41 AM »

Thanks for the reply... I learned about BAT after downloading a few DBW things... boy I am rusty...

Been downloading all the BAT stuff the past few days, I'm hoping most or all of the Spain civil war content will work nicely with this huge wonderful mod once I get it all installed... Cheers !
Logged
Pages: 1 ... 8 9 10 [11]   Go Up
 

Page created in 0.032 seconds with 25 queries.