Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 [3] 4 5 6 ... 8   Go Down

Author Topic: Auto DiffFM+ (Updated 2013/01/04)  (Read 40913 times)

0 Members and 1 Guest are viewing this topic.

mojojojo

  • the only guy who uses the wildcat in multiplayer
  • member
  • Offline Offline
  • Posts: 1367
Re: Auto DiffFM
« Reply #24 on: April 09, 2012, 03:24:13 PM »

The Wellington flies returns!  ;D
the wellington worked fine with 4.10 anyway.
this is a great mod. im happy to fly the Yak-3 VK-107 3xB20s
Logged
i7 4790K quad core 4.4GHz/8GB DDR3-1600/ASUS Z87-A/ EVGA GTX 970 4GB/128GB A-Data SSD+1TB HDD/EVGA 650w 80+ gold PSU/ NZXT Source 530 gaming case

Korrigan

  • SAS Honourable Member
  • member
  • Offline Offline
  • Posts: 713
Re: Auto DiffFM
« Reply #25 on: April 09, 2012, 03:30:50 PM »

Great ! Thank you very much Pablo !
It's great to be flying the SU-26 again
Solo, you only need to add this line:
Su-26 air.SU_26M2 1 NOINFO r01 SUMMER
to your air.ini to have the SU-26 back in DBW.
Logged

Badmuthafunker

  • member
  • Offline Offline
  • Posts: 384
Re: Auto DiffFM
« Reply #26 on: April 09, 2012, 04:54:54 PM »

The Wellington flies returns!  ;D
the wellington worked fine with 4.10 anyway.
this is a great mod. im happy to fly the Yak-3 VK-107 3xB20s

Oops, excuse the typo!  :-[

Not in my 4.10. So I'm happy.  :)
Logged

Roger Smith

  • "Cast in the name of God, ye not guilty" -Big O Boot up message
  • member
  • Offline Offline
  • Posts: 946
  • HgZ? He's just another Jason Beck
Re: Auto DiffFM
« Reply #27 on: April 09, 2012, 04:56:59 PM »

Great ! Thank you very much Pablo !
It's great to be flying the SU-26 again
Solo, you only need to add this line:
Su-26 air.SU_26M2 1 NOINFO r01 SUMMER
to your air.ini to have the SU-26 back in DBW.
I did. I am said that it is great to be flying it once again now that it works in 4.101
Logged

dimax

  • member
  • Offline Offline
  • Posts: 7
Re: Auto DiffFM
« Reply #28 on: April 22, 2012, 04:47:45 AM »

***  New Version for 4.11 included (Apr the 21st) ***

Since the release of the v4.10m when Team Daidalos decided to encode the buttons with a different keyword, diverse problems arised due to that fact. Old planes, old buttons, former FMs required to be adapted, recoded to the encoding demanded for v4.10m.

The strangest thing is what we know, that from v4.11m they decided to come back to the original keyword. So all the buttons and different FMs we made should be translated again.

To avoid any of these problems and due to the fact that I was kind of sick of it, I decided to make a DiffFM independent of the version.

So: you have buttons in v4.101 it will work, buttons in v4.11, it will work. Some planes having DiffFMs from v4.09m, they will work. New planes from v4.11 with DiffFM they will work too.

To wrap up, the buttons from gui/games can be in any possible format (of the two known to the moment). The individual FMs for planes in development (inside the plane MOD directory) can be in any format too.

For development, I set up a new feature, that at least for me showed to be very useful. I established the next setting in Conf.ini

Code: [Select]
[Mods]
PALButtonsPrefix=

That is the default, and for that you don't have to add anything to your Conf.ini, but if you do something like this:

Code: [Select]
[Mods]
PALButtonsPrefix=test.

Then your game will try to load the FMs from files starting with test. (in this example). So if you have files named:

test.buttons (in the typical gui/game folder), the FMs will be loaded from there and not from your stable buttons, so you don't have to backup anything important.

The same is valid for individual FMs. If in the directory where you have the F4 Phantom you add a file like this:

test.F4E      (under the same example of before, this FM will be loaded preferably to the F4E)

In case there wasn't any "test." FM file, the normal ones (including buttons are loaded).


Credits to the author of the original DiffFM. As far as I know it is a work of Sani.

Regards,
                    Pablo

PD Updated on Apr the 21st: the 4.101 version is a DBW DiffFM only. It includes the extra features for Jets, etc., as developed by SAS Team. Theorically it will work in UP3 too but not in a Vanilla or standard MODded v4.101.
The v4.11 of the MOD, is not DBW compatible (we still didn't have any DBW for v4.11). So it will work giving you the chance to add any MODded plane (with buttons of any version) to your v4.11 game. It doesn'e mean that all will work flawlessly because some other details could be a problem in some particular cases, but most of the games of v4.101 will work in v4.11 with this one.



What about a Version for 4.101 with Modact 3.06 only ?
Logged

mojojojo

  • the only guy who uses the wildcat in multiplayer
  • member
  • Offline Offline
  • Posts: 1367
Re: Auto DiffFM
« Reply #29 on: April 22, 2012, 05:09:23 AM »

im not sure but that will probably still work.
Logged
i7 4790K quad core 4.4GHz/8GB DDR3-1600/ASUS Z87-A/ EVGA GTX 970 4GB/128GB A-Data SSD+1TB HDD/EVGA 650w 80+ gold PSU/ NZXT Source 530 gaming case

benitomuso

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2574
  • P.A.L.
Re: Auto DiffFM
« Reply #30 on: April 22, 2012, 01:27:44 PM »

What about a Version for 4.101 with Modact 3.06 only ?

Dimax,
              the main reason that it doesn't work with Modact 3.06 is that DBW has as a baseframe everything required for JetWar, but in fact, if you have Modact 3.06 and JetWar 1.2 or 1.1 as a MOD package for it, my Auto DiffFM will work properly.

  This site (and basically most of the community) uses DBW as a standard, that's why in some way it's assumed that you will have it. Obviously there are exceptions, but it's very difficult to make MODs compatible with ALL the exceptions.

  Regards,
                      Pablo
Logged

BT~Tarik

  • Modder
  • member
  • Offline Offline
  • Posts: 1521
Re: Auto DiffFM
« Reply #31 on: April 23, 2012, 03:48:20 AM »

Great ! One more step towards a fully moddable 4.11, and of course less compatibility problems ! Thanks a lot !  :)
Logged

henkypenky

  • member
  • Offline Offline
  • Posts: 861
  • BAT, WAW & 3.8 Pegasus
Re: Auto DiffFM
« Reply #32 on: April 23, 2012, 05:21:15 AM »

Benito, I'm afraid your right - of course as you have made this - I tried to install the Bf-110 family in my 4.101 / Modact 3.06 and it only works partially  :'(
Logged

Knochenlutscher

  • "Klaatu... verata... n... Necktie. Nectar. Nickel. Noodle."
  • Modder
  • member
  • Offline Offline
  • Posts: 2250
  • aka Segfej
Re: Auto DiffFM
« Reply #33 on: April 23, 2012, 06:39:03 AM »

 ??? Pablo, my friend, *freaking out*  :'(
works, the Schmittfire (4.09m) is up again in my 4.101m DBW 1.7 ultracool IL-2.
She's there...No words mate, just amazing
Thanks Pablo for being so kind to us
Logged
Wiseman: Did you speak the exact words? Ash: Look, maybe I didn't say every single little tiny syllable, no. But basically I said them, yeah.

Alemart_el_Redentor

  • Major, Argentine Virtual Air Force. Owner, Tsiou L&Sg.
  • member
  • Offline Offline
  • Posts: 31
    • Yuxtapuestoelmono on deviantART
Re: Auto DiffFM
« Reply #34 on: April 23, 2012, 01:46:57 PM »

What about a Version for 4.101 with Modact 3.06 only ?

Dimax,
              the main reason that it doesn't work with Modact 3.06 is that DBW has as a baseframe everything required for JetWar, but in fact, if you have Modact 3.06 and JetWar 1.2 or 1.1 as a MOD package for it, my Auto DiffFM will work properly.

  This site (and basically most of the community) uses DBW as a standard, that's why in some way it's assumed that you will have it. Obviously there are exceptions, but it's very difficult to make MODs compatible with ALL the exceptions.

  Regards,
                      Pablo

Sorry to ask this again, but, if i have only SAS Modact 3.06, what else do i need to have to install?, or i will have to install DBW yes or yes?.
Thanks! :D
Logged

benitomuso

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2574
  • P.A.L.
Re: Auto DiffFM
« Reply #35 on: April 23, 2012, 01:59:02 PM »

What about a Version for 4.101 with Modact 3.06 only ?

Dimax,
              the main reason that it doesn't work with Modact 3.06 is that DBW has as a baseframe everything required for JetWar, but in fact, if you have Modact 3.06 and JetWar 1.2 or 1.1 as a MOD package for it, my Auto DiffFM will work properly.

  This site (and basically most of the community) uses DBW as a standard, that's why in some way it's assumed that you will have it. Obviously there are exceptions, but it's very difficult to make MODs compatible with ALL the exceptions.

  Regards,
                      Pablo

Sorry to ask this again, but, if i have only SAS Modact 3.06, what else do i need to have to install?, or i will have to install DBW yes or yes?.
Thanks! :D

For everybody:

  -If you are running Il-2 v4.101, my AutoDifFM MOD requires the Supersonic class, something which is present in DBW by default, so you don't have to do anything else but just copying the MOD if you have any DBW 1.6 or 1.7. In case of having UP3, it basically should work too, because most of the framewor included is the same (but I haven't tested it in UP3). But with a single MODAct v4.101 you really need to have the JetWar (preferable 1.2) installed, so the dependencies of the DiffFM are solved by the JetWar package. As a wrap up:

  AutoDiffFM for v4.101:

  1-DBW + AutoDiffFM : OK.
  2-UP3 + AutoDiffFM : Should Work (not tested by me).
  3-ModAct 3.06 + JetWar 1.2 + AutoDiffFM: Should Work (not tested by me).


  and AutoDiffFM for v4.11:

  1-MODAct (different alpha versions) + AutoDiffFM (for v4.11) : OK.

  Regards,
                        Pablo
Logged
Pages: 1 2 [3] 4 5 6 ... 8   Go Up
 

Page created in 0.018 seconds with 27 queries.