Special Aircraft Service

the SAS Hangar => New Member Safety Area => Topic started by: RogueFossil on May 08, 2022, 03:24:16 PM

Title: [solved] IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 08, 2022, 03:24:16 PM
Hi fellow pilots!
I'm being a fan of IL-2 and the BAT mod for several years, I really love this game and the modpack as well and I greatly appreciate the community's work which keeps this game truly alive!

Unfortunatelly, my IL-2 is in the big trouble now, let's see what happened:
I had a perfecelty working IL-2 with BAT installation and fully working conf.ini file on Windows 10 x64.
I had to reinstall my system (still Win10 x64), no hardawre changes. Now the game won't start at all: I just see the splash scren for a second and then it collapses.
I reinstalled the game and checked if unmodded stock game (4.12.2) will work or not. And it does not work either. What did I try to resolve this issue:
The game is in the "D:\Games\IL2" directory, so it won't mess with wrong path issues.

Nothing worked for me. It feels really desperate and I have no idea what to do next. For now I try to revive the stock game. I'm sure that the problem is caused by the OS, but I can't really find out at which level.
I will appreciate any help!

Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 09, 2022, 08:42:29 AM
Little update: it seems to be that it's somewhere at the Win10 policy level, we have BEX event here.
(https://i.postimg.cc/NFXsBZsq/BEX.png) (https://postimages.org/)
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: Radoye on May 09, 2022, 09:42:25 AM
Probably missing some registry values. Maybe you could reinstall the game into a different location? Just the standard unmodded game, to run through the proper installation process. Leave your current install as-is.

Then once installed the second instance, try running your current install. If it works, and if you're brave enough (or desperate for extra disk space), manually delete the new install. Do not uninstal, just delete the whole folder. Or just leave it be there, if you're OK with that.

Hopefully this helps.
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 09, 2022, 10:04:32 AM
Thanks for the response Radoye. I tried it, but unfortunatelly, it did not help. Moreover, I tried to install old disc version (4.07) and downloaded the shared game folder with fully working 4.14 pack as well, none of these worked for me, same issue, same error. 
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: SAS~Storebror on May 09, 2022, 10:14:35 AM
You have enabled DEP.
Disable it again.
https://www.sas1946.com/main/index.php/topic,62139.msg684423.html#msg684423

]cheers[
Mike
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 09, 2022, 10:19:40 AM
I switched it off via bcdedit and restarted my computer, no effect.
(https://i.postimg.cc/YCjJZ074/DEP.png) (https://postimages.org/)
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 09, 2022, 10:44:17 AM
Here is some more info on the error:
Code: [Select]
Faulting application name: il2fb.exe, version: 0.0.0.0, timestamp: 0x44fd7bbb
Faulting module name: jvm.dll, version: 0.0.0.0, timestamp: 0x3af53001
Exception code: 0xc0000005
Error offset: 0x000b08b0
Faulting process ID: 0x261c
Faulting application start time: 0x01d863c2dc04f87c
Faulting application path: D:\Games\IL2\il2fb.exe
Faulting module path: D:\Games\IL2\bin\hotspot\jvm.dll
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: SAS~Storebror on May 09, 2022, 11:50:48 AM
It's greyed out, not switched off.
Your Windows 10 doesn't look legit.

]cheers[
Mike
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 09, 2022, 12:09:51 PM
OK, here it is. I switched it off with bcdedit.exe /set {current} nx AlwaysOff, it greyed out afterwards. Now I switched it to OptIn. :)
Spoiler
(https://i.postimg.cc/fysj3m9g/DEP2.png) (https://postimages.org/)
[close]

From topic linked earlier:
Quote
First steps to try would be to reinstall the graphics driver and to make sure that DEP (Data Execution Prevention) is turned on for essentials Windows Programs and Services only.
I did that and it did not help
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: SAS~Storebror on May 09, 2022, 10:39:29 PM
As mentioned before, your Windows 10 doesn't look legit.
Reinstall a genuine Windows 10 copy and it'll work.
50 bucks on the table if you insist.

]cheers[
Mike
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 10, 2022, 03:42:16 AM
Why do you think it's not legit? I installed it from the genuine USB image and activated with the key, it works fine at all aspects except IL-2. All Windows updates are working fine as well as each native service.
Moreover, I can't understand, how would it affect the game launch? Didn't you mean that non-legit Windows 10 may have some mandatory services corrupt?
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: SAS~Storebror on May 10, 2022, 09:57:47 AM
If someone else wants to take over, I'm bailing out at this point. 'Nuff being said.

]cheers[
Mike
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: bomberkiller on May 10, 2022, 11:26:09 AM
A lot can go wrong!

Hello Fossil,

can you share something about your hardware please.

Perhaps you are playing on an old notebook (insufficient memory - graphic on CPU...).

What graphics are you flying with?

Have you set 16bit instead of 32bit in the graphics card driver or in the monitor software? It has to be 32bit!

If Nvidia driver:

Have you completely uninstalled the driver and then reinstalled the correct driver. If not, try it once and then install without "Experience"...!

If none of this helps, uninstall your virus scanner (switching it off is not enough)!

You then look for updates for Win10 again.

I wish you luck!

Wbr, Gerhard
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 10, 2022, 01:43:23 PM
Hi bomberkiller, thanks for help!
Unfortunatelly, the problem still the same. I completely uninstalled Nvidia driver and performed clean install without GeForce Experience. No result. After that, I installed recent updates including optional updates via Windows update. Still no result. Color depth is 32bit.

I don't use virus scanners or anti-virus/anti-malware tools. I also switched off Windows Defender through the policy settings, disabled both UAC and DEP.
So, my specs are:
At the previous Windows installation, IL-2 worked perfectly fine and beatiful.
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: bomberkiller on May 10, 2022, 03:11:27 PM
Wunderbar!

Your hardware is very good!

Please, send me your conf.ini, here or per PM.

Quote
At the previous Windows installation, IL-2 worked perfectly fine and beatiful.

You did install the MSI drivers (CD/ DVD), right?

Regards

Gerhard  :)
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: Knochenlutscher on May 10, 2022, 07:27:48 PM
Insert IL-2 Disc and run Deinstall, this cleans up Registry, then you can reinstall Game and proceed again
with that Installation.
Keep a Backup of the old working BAT. when installed again you're good to go again.
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: SAS~Storebror on May 10, 2022, 10:46:28 PM
Sorry for jumping in once more, but...

switched off Windows Defender (...), disabled (...) UAC

Don't.
I'm out again ;)

]cheers[
Mike
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 10, 2022, 10:58:28 PM
Quote
Insert IL-2 Disc and run Deinstall, this cleans up Registry, then you can reinstall Game and proceed again
I tried that earlier and it did not help.

Quote
You did install the MSI drivers (CD/ DVD), right?
I downloaded them from MSI web-site and I guess it should be fine. At least there are no quesstion marks/unknown devices in device manager.

Quote
conf.ini
Here we go! There will be two conf.inis - the first one is from the stock game which I try to revive (4.12.2).
The second one is the last working conf.ini from my previous installation with BAT.

conf.ini from Stock Game
Code: [Select]
[il2]
title=Il2-Sturmovik Forgotten Battles
hotkeys=HotKey game

[window]
width=1600
height=900
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=0
FullScreen=1
DrawIfNotFocused=1
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0
WideScreenFoV=1
UIColor=0
UIDetail=0
UIBackground=ru

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

[NET]
speed=5000
routeChannels=0
serverChannels=31
localPort=21000
remotePort=21000
SkinDownload=1
serverName=No Name
serverDescription=
remoteHost=
localHost=
socksHost=
checkServerTimeSpeed=1
checkClientTimeSpeed=0
disableNetStatStatistics=0
showPilotNumber=1
showPilotPing=1
showPilotName=1
showPilotScore=1
showTeamScore=0
cumulativeTeamScore=0
showPilotArmy=1
showPilotACDesignation=1
showPilotACType=1
filterUserNames=0
reflyKIADelay=0
maxAllowedKIA=-1
reflyKIADelayMultiplier=0.0
reflyDisabled=0
allowMorseAsText=1
allowCustomSounds=1

[MaxLag]
farMaxLagTime=10.0
nearMaxLagTime=2.0
cheaterWarningDelay=5.0
cheaterWarningNum=-1

[chat]
region=(dx=0.6925,dy=0.071666665,x=0.0,y=0.0)

[game]
Arcade=0
HighGore=1
mapPadX=0.88666683
mapPadY=-0.0011111111
viewSet=17
Intro=0
NoSubTitles=0
NoChatter=0
NoHudLog=0
NoLensFlare=0
iconTypes=3
eventlog=eventlog.lst
eventlogkeep=0
3dgunners=1
ScreenshotType=1
RecordingIndicator=0
MapAlpha=0.99
SaveTrk=1
IconUnits=0
SkipParatrooperViews=0
NoMissionInfoHud=1
noKillInfoHud=0
BlockMorseChat=0
SmallMapWPLabels=1
ShowMorseAsText=1

[HotKey game]
PrintScreen=ScreenShot
P=pause
Pause=pause

[HotKey gui]
Escape=activate

[HookViewFly Config]
timeFirstStep=2.0
deltaZ=10.0

[HookView]
MouseLeft=Len

[HookView Config]
AzimutSpeed=0.1
TangageSpeed=0.1
LenSpeed=1.0
MinLen=1.0
DefaultLen=20.0
MaxLen=3000.0
Speed=6
LeanF=0.39
LeanS=0.39
Raise=0.2
RubberBand=0.5

[HotKey builder]
MouseLeft=objectMove
MouseRight=popupmenu
Enter=freeView
Shift MouseLeft=worldZoom
Alt MouseLeft=select+
Alt MouseRight=select-
Alt Ctrl=unselect
PageDown=change+
PageUp=change-
End=change++
Home=change--
Ctrl MouseLeft=insert+
Insert=insert+
NumPad-0=insert+
F=fill
Ctrl MouseRight=delete+
NumPad.=delete+
Delete=delete+
Backspace=cursor
Tab=cursor
F10=land
F11=onLand
NumPad-=normalLand
NumPad+=toLand
NumPad-5=resetAngles
NumPad-8=resetTangage90
NumPad-7=stepAzimut-5
NumPad-4=stepAzimut-15
NumPad-1=stepAzimut-30
NumPad-9=stepAzimut5
NumPad-6=stepAzimut15
NumPad-3=stepAzimut30

[MouseXYZ]
F1=SpeedSlow
F2=SpeedNormal
F3=SpeedFast
MouseRight=XYmove
F4 MouseRight=Zmove
MouseMiddle=Amove
F5 MouseRight=Amove
F6 MouseRight=Tmove
F7 MouseRight=Kmove

[MouseXYZ Config]
RealTime=1

[HotKey Console]
Shift Tab=Activate
[Console]
HISTORY=1024
HISTORYCMD=1024
LOAD=console.cmd
SAVE=console.cmd
LOG=0
LOGTIME=0
LOGFILE=log.lst
LOGKEEP=0

[sound]
SoundUse=1
SoundEngine=1
Speakers=0
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=8
ObjectVolume=14
MusState.takeoff=1
MusState.inflight=1
MusState.crash=1
MusFlags.play=1
MasterVolume=14
Attenuation=7
SoundMode=3
SamplingRate=2
NumChannels=3
SoundExt.occlusions=0
SoundFlags.hardware=1
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=12
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=0
ActLevel=0
MicLevel=0
SoundFlags.forceEAX1=0

[rts]
;ProcessAffinityMask=1
mouseUse=2
joyUse=1
trackIRUse=1
DisableIME=0
locale=ru
UseSmartAxis=0

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
Invert=0

[rts_joystick]
X=0 1 4 9 16 25 36 49 64 81 100 0
Y=0 1 4 9 16 25 36 49 64 81 100 0
Z=0 10 20 30 40 50 60 70 80 90 100
RZ=0 10 20 30 40 50 60 70 80 90 100 0
FF=0
U=0 10 20 30 40 50 60 70 80 90 100 0
V=0 10 20 30 40 50 60 70 80 90 100 0

[Render_DirectX]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=1
TexFlags.UsePaletteExt=1
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=15
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0
Water=1
Effects=1

[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=0
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=0
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=1
TexFlags.UsePaletteExt=1
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=0

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=3
LandShading=3
LandDetails=2

LandGeom=3
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=2
Effects=1
ForceShaders1x=0
PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-1.0


[close]
conf.ini from previous BAT Installation
Code: [Select]
[il2]
title=Il2-Sturmovik Forgotten Battles
hotkeys=HotKey game

[HotKey Console]
Shift Tab=Activate

[Console]
HISTORY=128
HISTORYCMD=128
LOGFILE=log.txt
LOG=1
LOGKEEP=0
LOGTIME=0

[HotKey gui]
Escape=activate

[window]
width=1600
height=900
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=0
FullScreen=1
DrawIfNotFocused=1
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0
WideScreenFoV=1
UIColor=0
UIDetail=0
UIBackground=rnd

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

[NET]
speed=5000
routeChannels=0
serverChannels=31
localPort=21000
remotePort=21000
SkinDownload=1
serverName=No Name
serverDescription=
remoteHost=
localHost=
socksHost=
checkServerTimeSpeed=1
checkClientTimeSpeed=0
disableNetStatStatistics=0
showPilotNumber=1
showPilotPing=1
showPilotName=1
showPilotScore=1
showTeamScore=0
cumulativeTeamScore=0
showPilotArmy=1
showPilotACDesignation=1
showPilotACType=1
filterUserNames=0
reflyKIADelay=0
maxAllowedKIA=-1
reflyKIADelayMultiplier=0.0
reflyDisabled=0
allowMorseAsText=1
allowCustomSounds=1

[MaxLag]
farMaxLagTime=10.0
nearMaxLagTime=2.0
cheaterWarningDelay=5.0
cheaterWarningNum=-1

[chat]
region=(dx=0.6925,dy=0.071666665,x=0.0,y=0.0)

[game]
TypeClouds=1
Arcade=0
HighGore=1
mapPadX=0.88666683
mapPadY=-0.0011111111
viewSet=17
Intro=0
NoSubTitles=0
NoChatter=0
NoHudLog=0
NoLensFlare=0
iconTypes=3
eventlog=eventlog.lst
eventlogkeep=0
3dgunners=1
ScreenshotType=1
RecordingIndicator=0
MapAlpha=0.99
SaveTrk=1
IconUnits=0
SkipParatrooperViews=0
NoMissionInfoHud=1
noKillInfoHud=0
BlockMorseChat=0
SmallMapWPLabels=1
ShowMorseAsText=1
mapPadMode=1
hudMode=4
MapPadSmall=0
MapIconLarge=0
MapPadAlpha=0.6

[HotKey game]
PrintScreen=ScreenShot
P=pause
Pause=pause

[HookViewFly Config]
timeFirstStep=2.0
deltaZ=10.0

[HookView]
MouseLeft=Len

[HookView Config]
AzimutSpeed=0.1
TangageSpeed=0.1
LenSpeed=1.0
MinLen=1.0
DefaultLen=20.0
MaxLen=3000.0
Speed=6
LeanF=0.2
LeanS=0.2
Raise=0.089999996
RubberBand=0.04

[HotKey builder]
MouseLeft=objectMove
MouseRight=popupmenu
Enter=freeView
Shift MouseLeft=worldZoom
Alt MouseLeft=select+
Alt MouseRight=select-
Alt Ctrl=unselect
PageDown=change+
PageUp=change-
End=change++
Home=change--
Ctrl MouseLeft=insert+
Insert=insert+
NumPad-0=insert+
F=fill
Ctrl MouseRight=delete+
NumPad.=delete+
Delete=delete+
Backspace=cursor
Tab=cursor
F10=land
F11=onLand
NumPad-=normalLand
NumPad+=toLand
NumPad-5=resetAngles
NumPad-8=resetTangage90
NumPad-7=stepAzimut-5
NumPad-4=stepAzimut-15
NumPad-1=stepAzimut-30
NumPad-9=stepAzimut5
NumPad-6=stepAzimut15
NumPad-3=stepAzimut30
Ctrl C=copy
Ctrl X=cut
Ctrl V=paste
Ctrl Q=incHeight
Ctrl A=DecHeight

[MouseXYZ]
F1=SpeedSlow
F2=SpeedNormal
F3=SpeedFast
MouseRight=XYmove
F4 MouseRight=Zmove
MouseMiddle=Amove
F5 MouseRight=Amove
F6 MouseRight=Tmove
F7 MouseRight=Kmove

[MouseXYZ Config]
RealTime=1

[sound]
SoundUse=1
SoundEngine=1
Speakers=0
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=1
RadioEngine=2
MusicVolume=8
ObjectVolume=14
MusState.takeoff=0
MusState.inflight=0
MusState.crash=0
MusFlags.play=1
MasterVolume=14
Attenuation=5
SoundMode=1
SamplingRate=1
NumChannels=3
SoundExt.occlusions=0
SoundFlags.hardware=1
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=14
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=1
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=0
ActLevel=0
MicLevel=0
SoundFlags.forceEAX1=0

[rts]
ProcessAffinityMask=1
mouseUse=2
joyUse=1
trackIRUse=1
DisableIME=0
locale=
UseSmartAxis=0
JoyProfile=0

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
Invert=0
SensitivityZ=1.0

[rts_joystick]
X=0 1 4 9 16 25 36 49 64 81 100 0
Y=0 1 4 9 16 25 36 49 64 81 100 0
Z=0 10 20 30 40 50 60 70 80 90 100
RZ=0 10 20 30 40 50 60 70 80 90 100 0
FF=0
U=0 10 20 30 40 50 60 70 80 90 100 0
V=0 10 20 30 40 50 60 70 80 90 100 0
1X=0 10 20 30 40 50 60 70 80 90 100 0 0
1Y=0 10 20 30 40 50 60 70 80 90 100 0 0
1RZ=18 50 50 100 100 100 100 100 100 100 100 70 0
1U=0 100 100 100 100 100 100 100 100 100 100 0 0
1V=0 100 100 100 100 100 100 100 100 100 100 0 0

[Render_DirectX]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=1
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=0
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=0

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=4
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

[Render_OpenGL]
TexQual=3
TexMipFilter=3
TexCompress=0
TexFlags.UseDither=0
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=0
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=1
TexFlags.UsePaletteExt=1
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=0

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=3
LandShading=3
LandDetails=2

LandGeom=3
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=4
Effects=1
ForceShaders1x=0
PolygonOffsetFactor=-0.0625
PolygonOffsetUnits=-1.0

[Mods]
Flyby=1
FlybyFov=60.0
ToggleMusic=1
RandomSplash=1
PALHUDMode=1
SpeedbarTAS=1
SpeedbarSIToo=1
SpeedbarShowExtraInfo=1
netCallsign=
Stab4all=1
PALShowChocks=1
PALShowCatGear=1
DumpFuel=1
SpeedbarUnits=0
PALGameMenuStatusBar=1
PALGameMenuShowFPS=0
PAL3DStart=0
PAL3DSepAim=0.7
PAL3DSepGun=1.35
PAL3DSepPit=1.5
PAL3DSepExt=25.0
PAL3DConvAimL=-0.01
PAL3DConvAimR=-0.01
PAL3DConvGunL=-0.09
PAL3DConvGunR=-0.09
PAL3DConvPitL=-0.13
PAL3DConvPitR=-0.13
PAL3DConvExtL=-0.55
PAL3DConvExtR=-0.55
PAL3DDOFfNumber=0.0
PAL3DDOFFocus=28.27506
PAL3DAdjustVariable=1
PAL3DFullColorFrames=0
PAL3DRenderStereo=1
PAL3DFilterLeft=R___
PAL3DFilterRight=_GB_
PAL3DCockpitSoftViewEnabled=1
PAL3DCockpitSoftView=0.075
PAL3DCockpitTurretInertiaEnabled=1
PAL3DCockpitTurretInertia=0.0010
PAL3DFollowInertiaEnabled=1
PAL3DFollowInertia=0.009999999776482582
PAL3DFollowInertiaAngle=0.01
PAL3DExternalSoftView=0.075
PAL3DExternalTrackIR=0
PAL3DExternalMouseInertia=1
ngHUDposition=0,0,0,0
ngHUDsector=1
ngHUDsubtitles=8
ngHUDmaptime=0
ngHUDpause=0
ngHUDfpsbar=0
ngHUDlogbottom=1
ngHUDloglines=3
PALMODsColor=1
ngMAPfriendly=1
ngMAPhostile=0
ngMAPfilters=0
ngMAPnoise=1
ngHUDshiftmsg=5
ngCAMkillswitch=0
ngCAMspeedext=2
ngCAMspeedint=2
ngCAMfovdefault=90
ngCAMfovspeed=2
ngCAMfovlog=0
[close]

Quote
Don't.
I suppose it worth checking out, I'll try enabling it again.
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: -=MaD=- on May 11, 2022, 07:18:29 AM
I had a similar problem once. For me helped to try different OpenGL.dll files. I had different ones on my pc and with one of these in the main folder 1946 worked again. Just my experience... Probably a try?
Please backup BEFORE!!!

Gesendet von meinem B├╝geleisen mit Tapatalk

Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: RogueFossil on May 11, 2022, 12:18:04 PM
Well, IT'S ALIVE!!!

Mike's advice helped. I switched on Windows Defender and UAC, gave permission to il2fb.exe and it's good to go. It seems that I switched it off with locked(?) state therefore blocking any possibility to change this status.
The skies are open now! Thanks everyone for help and special thanks to Mike for an bull's eye shot!  :)
I'm back to BAT now 8)
Title: Re: IL-2 won't work after Windows 10 reinstall
Post by: bomberkiller on May 12, 2022, 04:06:18 AM
Hello Fossil,

wonderful, you're back on board.  :)

It would be very nice if you would mark your post as "solved".

Best regards

 ]cheers[

Gerhard