Special Aircraft Service

Individual Mod Downloads for IL-2 1946 => SAS Essentials / Basic Mods => SAS Modact => Topic started by: SAS~Storebror on October 27, 2016, 07:12:03 AM

Title: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:12:03 AM
(http://s17.postimg.cc/e7jqp2e8f/easy_prey.jpg) (http://postimg.cc/image/q9f4j7ngr/full/)

Screw it, why not? Modact 6.2!  :D

In our ongoing attempt to teach the unteachables, SAS once again is proud to present:

the SAS Seriously KickAss Mod Activator v6.20 for IL-2 4.13.2m!!


Contents:



Modact 6.2x



AI Flyables Pack 6.2x (not yet available)



SAS Featured JSGME Optional Mods for Modact 6.2x

SAS Featured JSGME Optional Mods Package Contents:



Cheers to SAS Team and Modders for testing

Special thanks (with no claim of completeness) go to:

8) Salut!

SAS~Storebror aka Mike
Title: Download Links for SAS Modact 6.20 [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:13:19 AM
DOWNLOAD LINKS for MODACT v6.20 for 4.13.2m: (132 MB)
Please note it is STRONGLY suggested you start with a fresh 4.13.2m install before switching over to Modact 6.20

Modact 6.20 (Mediafire) (http://www.mediafire.com/file/u008vh1badcc073)

Other Mirrors welcome, please post download links in this thread, thanks!

~ Torrent: (not yet available)
Please note that a fair use of Torrents implies that you keep seeding the downloaded file at least until you reached an Up:Download ratio of 2.0 on that file.
Cutting the line before this ratio has been reached would be unfair to other members who rely on Torrent seeders for that file, too.
Remember: Others like good download speed the same like you did!
Title: Download Links for SAS Modact 6.2x Patches
Post by: SAS~Storebror on October 27, 2016, 07:13:43 AM
No Patches yet.
Title: Installation Instructions for SAS Modact 6.20 [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:14:05 AM
Installation Instructions for SAS Modact 6.20:

Run the self-extracting installer, select your IL-2 4.13.2m game folder as target for installation, let the installer do it's job, run the game and enjoy!
(Please note it is STRONGLY suggested you start with a fresh 4.13.2m install before switching over to Modact 6.20)


For those who still want to upgrade their existing Modact Installation, this is the way which worked for the developers, though it's still strictly unsupported and in case of trouble you have to start with a fresh 4.13.2m installation instead of asking for support (which you won't get in that case):


For users who have an older Modact 4.0/3.0x and need to upgrade:

Unfortunately we don’t have much good news for you. With any game version change, it brings multiple changes and it is difficult to predict all of the side-effects. Therefore as much as pain it is, we STRONGLY recommend you create a fresh Il-2 install, patched all the way to 4.13.2m before installing Modact 6.20. For those still on Modact v3.06/v4.0, DBW 1.71 4.101m, HSFX 6 installs, they aren’t lost forever. We suggest porting your mods across one by one and seeing what happens.

You can try just patching your current install to 4.13.2m and plonking this over the top but it is likely it won’t work. You should do this at your own risk!
Title: Installation Instructions for SAS Modact 6.2x Patches
Post by: SAS~Storebror on October 27, 2016, 07:14:29 AM
No Patches yet.
Title: Changelog, Hints, Known Bugs etc. for SAS Modact 6.2x [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:14:52 AM
Modact 6.2x Changelog (newest first):
Code: [Select]
*** Modact 6.20 (Full Package): ***

- supported base game version: 4.13.2m

Known Bugs:
Code: [Select]
* CTO Mod doesn't support angle carrier decks yet.
Hints:
Like to have some HSFX eye candy in Modact 6?
Easy to achieve: Just copy all fb_hfx*.sfs files from your HSFX 7 folder to the "SFS_AUTO" folder of Modact 6.
It's about 5 Gigabytes in total, bear with us that we don't mirror that amount of data here. If you like the files, download HSFX 7 and you get them for free.

Missing Swastikas (Hakenkreuz) in Modact 6?
Open your conf.ini, search for the "[game]" section, add a line "HakenAllowed=1" (or change "HakenAllowed=0" to "HakenAllowed=1" if such line already exists) and say thanks to TD for this undocumented "feature".
Title: Download Links for SAS AI Flyables Pack 6.20 [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:15:14 AM
Not available yet, we're working on it.
Title: Download Links for SAS AI Flyables Pack 6.2x Patches [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:15:35 AM
No Patches yet.
Title: Installation Instructions for SAS AI Flyables Pack 6.20 [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:15:58 AM
Not available yet, we're working on it.
Title: Installation Instructions for SAS AI Flyables Pack 6.2x Patches [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:17:01 AM
No Patches yet, hence no installation instructions.
Title: Changelog, Hints, Known Bugs etc. for SAS AI Flyables Pack 6.2x [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:17:25 AM
No Hints yet.
Title: Download Links for SAS Featured JSGME Optional Mods for Modact 6.2x [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:17:48 AM
DOWNLOAD LINKS for SAS Featured JSGME Optional Mods for Modact 6.2x: (104 MB)
A working Modact 6.2x installation is required for this pack!

JSGME Mods for Modact 6.2x (Mediafire) (http://www.mediafire.com/file/7fo836nmp2u4t2t)

Other Mirrors welcome, please post download links in this thread, thanks!

~ Torrent: (Not available yet)
Please note that a fair use of Torrents implies that you keep seeding the downloaded file at least until you reached an Up:Download ratio of 2.0 on that file.
Cutting the line before this ratio has been reached would be unfair to other members who rely on Torrent seeders for that file, too.
Remember: Others like good download speed the same like you did!
Title: Download Links for SAS Featured JSGME Optional Mod Patches for Modact 6.2 [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:18:14 AM
No Patches yet.
Title: Installation Instructions for SAS JSGME Mods for Modact 6.2 [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:18:37 AM
Installation Instructions for SAS Featured JSGME Optional Mods for Modact 6.2:

Run the self-extracting installer, select your IL-2 4.13.2m + Modact 6.2x game folder as target for installation and let the installer do it's job.
Activate any mods of your choice in JSGME, run the game and enjoy!

(Please note that a working IL-2 4.13.2m + Modact 6.2x installation is required for this Pack!)


For upgrading instructions please refer to the regarding part of the Installation Instructions for SAS Modact 6.20 (http://www.sas1946.com/main/index.php/topic,52794.msg574379.html#msg574379) Post.
Title: Installation Instructions for SAS JSGME Mod Patches for Modact 6.2 [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:19:00 AM
No patches yet.
Title: Changelog, Hints, Known Bugs etc. for JSGME Mod Patches for Modact 6.2 [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:19:27 AM
No Patches yet, hence no hints.
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on October 27, 2016, 07:40:01 AM
You asked for it, you got it.
Have fun with Modact 6.2.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m
Post by: duffys tavern on October 27, 2016, 01:42:51 PM
Does this have a "CTO" mod?
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on October 28, 2016, 12:15:22 AM
No.
I don't know of any 4.13.x compatible CTO mod which comes without issues yet.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SGT68 on October 28, 2016, 03:34:05 AM
Thank you very much Mike.  If I added Boomers Object Pack manually from Ultrapack files, would it be enough just to copy across Ultrapacks static.ini file overwriting the default one? Or would careful merging have to be performed? I guess its probably too early to tell, in which case I could try it and report findings, cos Boomers Object Pack imo is essential stuff. Thanks again
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on October 28, 2016, 05:01:03 AM
You will have to try it yourself I'm afraid.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: trent on October 28, 2016, 07:54:15 AM


Great work, Mike! Thank you for all your effort!  :)

Best Regards

Trent
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: printenduevel on October 28, 2016, 09:05:27 AM
Dubelle Merci
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: royor on October 29, 2016, 04:13:40 AM
my first ever post, so be gentle. download shows scantilly clad girl,install buttons are in foreign language
is this safe to install? thanks
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on October 29, 2016, 10:39:28 AM
download shows scantilly clad girl,install buttons are in foreign language is this safe to install?
The girl has a tattoo on her upper arm which tells that she loves SAS, so I guess it's safe to say she's trustworthy 8)
As much as the german language buttons are concerned, this was my mistake.
I forgot to force Winrar to create the self extracting file with english language UI controls.
This is fixed now, you can just redownload the file and the buttons will be english.
Content is the same, so if you're not too afraid of german language buttons, you can as well keep the old file.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: rkalhorn109 on November 02, 2016, 07:23:56 PM
Quick and easy installation.  Thanks, Mike!
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: mikojan3 on November 03, 2016, 11:21:33 AM
worked very fine thanxs mike  :P :P :P
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Crazy G on November 08, 2016, 12:44:00 AM
For the benefit of an uneducated man: which are the differences between 6.1 to 6.2? Thanks,
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: western0221 on November 08, 2016, 01:27:40 AM
For the benefit of an uneducated man: which are the differences between 6.1 to 6.2? Thanks,

Base game version is 4.13.1m or 4.13.2m
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Seegurke93 on November 10, 2016, 08:29:18 AM
Hello everyone! I am new to SAS

I have been playing IL2 for years and also downloaded several skins from other sites. I also fly real planes. I did my PPL this year and will finish my ATPL next year to fly some airliners...btw it all began with this game years ago ;)

 I have never tried any mods.

I just downloaded the 6.20 for my 4.13.2m version. I testet it and it looks like it worked. The background is different and also the planes are in a different order in QMB.

Is there anything else this mod does? I also got the feeling that the engine sounds are a bit better.

Greetings from Germany
Max
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Seegurke93 on November 10, 2016, 08:31:40 AM
BTW the girl on the download is Catherine Bell ;) Love her since I saw JAG for the first time. I got the feeling that this is the right place to be :) Love to all ya SimPilots  :P
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on November 10, 2016, 08:57:06 AM
Welcome at SAS :)

This is just a mod activator, meaning that it doesn't change too much in the game itself, just enables you to install additional mods.
As such, it comes with a soundmod included because that's required to use additional mod planes which use sounds not belonging to the standard (stock) game.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Seegurke93 on November 10, 2016, 09:49:21 AM
Hey Mike,

Thanks for the intel. I also downloaded the 2nd link, the JSGME. What does it do?

I dream of heaving new ships and more maps and also someday a flyable Ju52 and Avro as well as a B17.
Will that be possible by the mod alone whenthe required files are available?
I would like to know more about that by not reading all old posts on this webside :D I hope That is ok :=)

Max
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on November 10, 2016, 09:52:42 AM
Hi Max,

You won't be able to avoid reading a bit, this is a matured game and so are the guidelines ;)
The JSGME pack contains mods which can be enabled/disabled by simple clicks through the "JSGME.exe" tools which is in your IL-2 game folder once you've installed that pack.
Flyable AI planes are still on the todo list for Modact 6.x, if you're eager to fly them you should run another IL-2 game from a different folder, patch it to 4.12.2m only and install Modact 5.3 on top.
Modact 5.3 comes with AI flyables pack, including the Ju 52 and B-17.
Avro Lancaster is available as a separate mod, working with Modact 5.3 too.

Or do it the easy way:
CUP has all of this and much more.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Seegurke93 on November 10, 2016, 01:28:55 PM
Thanks Mike.

I will wait untill all the good stuff is available for this modact.  :)
Title: Re: Download Links for SAS Modact 6.20 [4.13]
Post by: Izengrimm on November 10, 2016, 10:52:30 PM
DOWNLOAD LINKS for MODACT v6.20 for 4.13.2m: (132 MB)
Morning. Can you upload this somewhere else, please? Torrent or another filehost? I can't go on mediafire, doesn't work. Link page (Mediafire) only reloads again and again every time.
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on November 11, 2016, 02:54:46 AM
I can't go on mediafire, doesn't work. Link page (Mediafire) only reloads again and again every time.
Switch off "Data saving" in your Opera browser and it will work.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Izengrimm on November 11, 2016, 09:46:28 AM
Thanks Mike! All done.


Regards - Max
Title: It's tail fin Swastika discussion time again
Post by: SGT68 on November 23, 2016, 02:51:04 AM
I'm building up a Modact 6.20 install, testing whether certain mods and planes will work and I've come across this:

Being one who is not squeamish or politically correct and an advocate of historical accuracy to boot.. I have always enabled my tail fin swastikas. A German plane just does not look right without it. Several of you no doubt feel the same.

I have also always appreciated that not everyone feels like this, and at the end of the day IL-2s host developers are running a business and swastikas are apparently illegal in some countries, so I have appreciated the JSGME swastika enabling/disabling mod compromise.

In 4.13.20  6.20 it appears to have been bypassed. You won't get swastikas mod or no mod. So i download and runa tool called il2hk which sits in root folder and once executed the swastikas show up.

But here is my gripe, and it certainly is not a complaint about Modact 6.20 which is really growing on me.. IL2HK has to be executed EVERY time the game is run.  I really hate this type of arrogance and control that is exerted over MY pc. MY pc. That's right  ... .mmmmyyy  PC..

Why is this happening any ideas?

Could  i create a batch file that runs il2kh.exe then il2fb.exe after that?
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on November 23, 2016, 02:56:31 AM
-->> http://www.sas1946.com/main/index.php/topic,52794.msg574381.html#msg574381

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SGT68 on November 23, 2016, 03:02:37 AM
HakenAllowed=1

Thank you VERY much


Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: zalak on November 28, 2016, 01:25:36 PM
Hello all!
I have a question. Does SAS Modact 6.2 allow to install maps? If it allows, how i do it. I read http://www.sas1946.com/main/index.php/topic,35419.0.html, but maps don't work.
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on November 28, 2016, 11:01:03 PM
Maps work the same way in Modact 6.2 like anywhere else, there's no difference.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m
Post by: DU30 on January 08, 2017, 02:06:56 AM
Thank you for this update and i downloaded the AI flyable from 4.12.2 and it works in this version. Thanks again.
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m
Post by: Ryan Chadwick on January 17, 2017, 10:06:00 AM
Hey, followed all install instructions and crashes 1second into load page.  i must of missed somthing, updated with all patches etc and crashes when i press launch IL2
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on January 17, 2017, 10:38:35 AM
Let me do a wild guess...
Your game is patched to 4.13.2? No? Start from scratch.
Steam?
This and the following two posts are vital for Steam IL-2 users:
http://www.sas1946.com/main/index.php/topic,24643.msg256833.html#msg256833

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Ryan Chadwick on January 17, 2017, 11:10:39 AM
hey, its fresh install from disc, added all patches in order, with  4.13.2 installed too.

thanks

Ryan
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on January 17, 2017, 11:32:23 AM
Then there's no reason why Modact shouldn't work if you installed it correctly.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Ryan Chadwick on January 17, 2017, 11:49:51 AM
ok, ill delete and do a full fresh install, and try again.  really hope this works!

Ryan
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Ryan Chadwick on January 17, 2017, 12:00:29 PM
reinstalled, and splash screen loads for around 0.05 of a second then closes.

oh well i give up. thanks anyways

Ryan
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on January 17, 2017, 12:19:28 PM
As much as I'd like to help, with this little information all I can say is that it worked for everyone else before, so there's no good reason it shouldn't work for you too.
The installation is extremely simple, there's no changes to the game that could break anything, so...
Whatever it is, it's probably a very simple mistake you made, but as I'm not standing in your shoes and not looking through your eyes, I can't help much at the moment.

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: SAS~Storebror on January 18, 2017, 07:55:33 AM
Just to point out the obvious...
You did run "IL-2 Selector.exe" once and applied settings after installing Modact, didn't you?

Best regards - Mike
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Cloyd on January 18, 2017, 02:16:16 PM
I had a similar problem today with Modact 5.3. I was setting up a fresh 4.12 install from the megapatch to investigate a map issue. I was unable to change resolution in-game to my native resolution. Every time I tried I got kicked back to the desktop when I hit apply. When I re-started the game none of the resolution changes I made, or any changes I made to settings, were applied.

When I manually made the changes to the [window] section of my conf.ini to match my 14 other installs, all was good. After that, all in-game changes would save.

A weird problem that I never experienced before.

Cloyd
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: mikojan3 on January 24, 2017, 05:55:24 AM
hello everyone i am to search the right map for malta mission anyone know the right version for modact 6.2?
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Treetop64 on January 26, 2017, 03:34:52 PM
Wow, the splash screens alone are reason enough to download this version of the ModAct, let alone the compatibility with v4.13.2.  They're beautiful!
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: DiegoG on January 29, 2017, 08:21:31 PM
Hi Mike, Sir!
 The mod wheels by Geronimo seems not to work after 4.13.1, i have double cheked allways with fresh install...  1946 + megapatch + 4.13.x +related Modact.
work fine on 4.13 but not on 4.13.1 or 4.13.2 not shure about the engine cool. and props. . #sas folder is working since i can add new airplanes

I have checked with the P-40E by the way...and some addons like retextured cockpits like he-111 H6 don´t work either but that it´s no your concern!

Thank for your time anyway!
Diego.
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Treetop64 on January 29, 2017, 10:19:02 PM
I was also still seeing a lot of the old default "square wheels".  Deactivated the mod that came with ModAct 6.2 and looked for an alternative.

Found this (http://www.sas1946.com/main/index.php/topic,34533.0.html).  Works fine in ModAct 6.2 for 4.13.2.  You want to download the All in One DBW version.  Then unfreeze the "#_Nuevo Mod de Ruedas DBW" file (you can rename the file to whatever you want) and manually dump it into your #SAS folder.  Covers almost every aircraft in the game, plus a few mod-addition types.
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: DiegoG on January 31, 2017, 01:17:03 PM
I was also still seeing a lot of the old default "square wheels".  Deactivated the mod that came with ModAct 6.2 and looked for an alternative.

Found this (http://www.sas1946.com/main/index.php/topic,34533.0.html).  Works fine in ModAct 6.2 for 4.13.2.  You want to download the All in One DBW version.  Then unfreeze the "#_Nuevo Mod de Ruedas DBW" file (you can rename the file to whatever you want) and manually dump it into your #SAS folder.  Covers almost every aircraft in the game, plus a few mod-addition types.

Doesn't works for me...but thanks anyway i will find the solution soon or later ;)
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: Seegurke93 on February 06, 2017, 05:41:34 AM
I also added the AI Flyable mod from 12.2 and it works <3 I hope someday there will be more ships. I cant figure out how to get the ship mods to work in 4.13.2m
If anyone knows, please contact me
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: ROMULO on February 15, 2017, 11:02:23 AM
First give thanks for all this selfless work. :)

I also added the AI Flyable mod from 12.2 and it works <3 I hope someday there will be more ships. I cant figure out how to get the ship mods to work in 4.13.2m
If anyone knows, please contact me

AI Flyable of 12.2 causes failures to load models:
N1K1-Jb. 1944
N1K2-Ja.1944
 At least in my installation, the rest I have to keep checking but it works


Post Edited for fix quote !
Title: Re: SAS Modact 6.2 for IL-2 4.13.2m [4.13]
Post by: ROMULO on February 15, 2017, 02:37:55 PM
Well after some tests:

Quote
Too many vertexes or faces per shadow hier mesh!
WARNING: TrenderManger:: Trianglelist_Projective Shadow ( ) - internal buffer over flow
Too many vertexes or faces per shadow hier mesh!
warning: no files: music/ crash
Quote

Only susede with AI Flyable mod from 12.2 and with these aircraft, the why ?