Special Aircraft Service

Individual Mod Downloads (unmarked mods might not be compatible with your version of IL-2) => Other Mod Types => ModWorx => Topic started by: 4S_Vega on September 28, 2015, 04:53:35 AM

Title: Weapons Pack V 1.3 2016.09.23 + 4.10 version
Post by: 4S_Vega on September 28, 2015, 04:53:35 AM
Hi all!  :)

This pack contains all the bombs, pylons, rockets, missiles, droptanks, pods, machine guns and guns used in aircrafts from 1945 till now, except for some of those already included in the mod " jet era".

(http://i265.photobucket.com/albums/ii206/Fuzz77/A-1/07aaee5e-0e69-43db-823a-b504d574681b_zps9qjxokji.png) (http://s265.photobucket.com/user/Fuzz77/media/A-1/07aaee5e-0e69-43db-823a-b504d574681b_zps9qjxokji.png.html)
(http://i265.photobucket.com/albums/ii206/Fuzz77/F-16/42375d25-9cea-436e-a759-dab2578565d9_zpsobwixnbb.png) (http://s265.photobucket.com/user/Fuzz77/media/F-16/42375d25-9cea-436e-a759-dab2578565d9_zpsobwixnbb.png.html)
(http://i265.photobucket.com/albums/ii206/Fuzz77/F4E/1b5b4ad6-2671-4441-a017-dc6ab34a3936_zpsyqrzzafo.png) (http://s265.photobucket.com/user/Fuzz77/media/F4E/1b5b4ad6-2671-4441-a017-dc6ab34a3936_zpsyqrzzafo.png.html)

This mod is a package of reference for modders who want to release an aircraft, so as to avoid to install each time the loadouts in each individual plane.

In this way you can also save many bytes in the folder of IL2, and we will have a weapons package equal for all.

The 00_WeaponsPack folder replace also the "#_ModernWeapon" folder, which it is entirely contained. 

The pack contained also upgraded weapons, so I highly recommend you to install it

(http://i265.photobucket.com/albums/ii206/Fuzz77/F-105/7497c6e7-f896-4813-8d9d-df1d7e0f75e8_zps9rrvcqc2.png) (http://s265.photobucket.com/user/Fuzz77/media/F-105/7497c6e7-f896-4813-8d9d-df1d7e0f75e8_zps9rrvcqc2.png.html)
(http://i265.photobucket.com/albums/ii206/Fuzz77/L-39_159/be0ae03b-9133-497d-8efd-7ee8ffd3c379_zpsxm3im64h.png) (http://s265.photobucket.com/user/Fuzz77/media/L-39_159/be0ae03b-9133-497d-8efd-7ee8ffd3c379_zpsxm3im64h.png.html)
(http://i265.photobucket.com/albums/ii206/Fuzz77/Mig-21/83f08d7f-c0cf-44f7-ac7d-477a63c228ff_zpsvcn2czj9.png) (http://s265.photobucket.com/user/Fuzz77/media/Mig-21/83f08d7f-c0cf-44f7-ac7d-477a63c228ff_zpsvcn2czj9.png.html)

CREDITS

Quote
Aviator Mod Team
SAS_S3
BT_Wasted
SAS_Anto
Beowolf
OC_Tiger
Ranwers
Mario71
Storebror
Ont_R
Western221
CY6
GJE_52
Flakiten
crazyflak

and other that I forget

Download last ver 1.3

http://www.mediafire.com/download/a2grqm218auxdpi/%21+00_WeaponsPack_V1.3_20160923.rar




for who run 4.10 version of the game, pls install this version of WeaponsPack


http://www.mediafire.com/download/pkffi36qom665ft/%21+00_WeaponsPack_4.10.rar
Title: Re: Weapons Pack V 1.0
Post by: Whiskey_Sierra_972 on September 28, 2015, 05:34:01 AM
Very useful addition mate!

Now future weapons upgrade or addition can be managed more easily with only one folder in which search for conflicts , dependences or older files!

A great THANKS for your hard work about!
Title: Re: Weapons Pack V 1.0
Post by: S3231541 on September 28, 2015, 06:37:39 AM
Can you upload the source code for all the weapons? Thanks.
Title: Re: Weapons Pack V 1.0
Post by: 4S_Vega on September 28, 2015, 06:45:05 AM
Can you upload the source code for all the weapons? Thanks.

weapons are always the same, just few of them are upgraded

maybe i can upload these last?
Title: Re: Weapons Pack V 1.0
Post by: S3231541 on September 28, 2015, 06:48:04 AM
No need, I'll make do. Some how.... :P

Thanks. :D
Title: Re: Weapons Pack V 1.0
Post by: SAS~Tom2 on September 28, 2015, 03:39:22 PM
Thanks Vega! :)
Title: Re: Weapons Pack V 1.0
Post by: AG-51 Hoss on September 28, 2015, 06:42:13 PM
What version of the game is this for? it doesn't say on the title.  Is it just for Jet War only? or any install?

Cheers

Hoss
Title: Re: Weapons Pack V 1.0
Post by: 4S_Vega on September 28, 2015, 11:56:44 PM
What version of the game is this for? it doesn't say on the title.  Is it just for Jet War only? or any install?

Cheers

Hoss

It works better with Jet Era installed
Title: Re: Weapons Pack V 1.0
Post by: KingTiger503 on September 29, 2015, 08:07:13 AM
Thanks Vega, All Weapon Pack and Modern Weapons are Working Now, I can See a New Weapons Loadout, Thanks.
Title: Re: Weapons Pack V 1.0 - AAM missles causing freeze/crash
Post by: xxxautoxxx on October 07, 2015, 02:08:00 PM
hi, Is anyone experiencing this? - when trying to fire AAM/sidewinder from several aircraft (A4-E, D etc but NOT new A4-M) , AMX Ghibili/BAF, and few others, the game will freeze/crash :)
did this BEFORE installing new Weapons Pack mod...and after installation...as well as having removed theprevious  Modern Weapons folder.
newr A/C and missles (soviet and nato/US all work fine - just older sidewinders on certain aircraft types).

thanks.

Auto

Title: Re: Weapons Pack V 1.1 2015.10.17
Post by: 4S_Vega on October 17, 2015, 07:12:50 AM
Ver. 1.1 at first post, it fix some weapons bug
Title: Re: Weapons Pack V 1.1 2015.10.17
Post by: SAS~Tom2 on October 17, 2015, 08:47:19 AM
 :) Thanks.
 :P
Tom
Title: Re: Weapons Pack V 1.2 2015.11.14 + 4.10 version
Post by: 4S_Vega on October 18, 2015, 11:40:28 AM
at first post also 4.10 version of weapons pack
Title: Re: Weapons Pack V 1.1 2015.10.17 + 4.10 version
Post by: bomberkiller on October 18, 2015, 03:07:58 PM
Quote
for who run 4.10 version of the game, pls install this version of WeaponsPack

Thank you very much!

Best regards, Gerhard  :)
Title: Re: Weapons Pack V 1.1 2015.10.17 + 4.10 version
Post by: SAS~Tom2 on October 21, 2015, 07:09:56 AM
Mig-21, latest pack, error and crash.

No matter if named before or after Migs.

Mig-21PFM, clean loadout for test of the Mig-21 buffetting bug

Code: [Select]
[15:05:34] INTERNAL ERROR: Str2FloatClamp() - Clamped 1e+015 -> 1e+006 (delta = -1e+015) to Range 0..1e+006
[15:05:34] INTERNAL ERROR: Str2FloatClamp() - Clamped 1e+015 -> 1e+006 (delta = -1e+015) to Range 0..1e+006
[15:05:35] FM called 'FlightModels/MiG-21PFM.fmd:MIG21' is being loaded from File: 'mig21'
[15:05:35] FM called 'FlightModels/MiG-21PFM.fmd:MIG21' is being loaded from Alternative File: 'mig21'
[15:05:35] FM called 'FlightModels/Tumanski:MIG21.emd' is being loaded from File: 'mig21'
[15:05:35] FM called 'FlightModels/Tumanski:MIG21.emd' is being loaded from Alternative File: 'mig21'
[15:05:35] Flight Model File FlightModels/MiG-21PFM.fmd:MIG21 contains no Mach Drag Parameters.
[15:05:35] FM called 'FlightModels/MiG-21PFM.fmd:MIG21' is being loaded from File: 'mig21'
[15:05:35] FM called 'FlightModels/MiG-21PFM.fmd:MIG21' is being loaded from Alternative File: 'mig21'
[15:05:36] ERROR loading sound control sample.339_idle_x4.wav.rpm
[15:05:37] java.lang.NoClassDefFoundError: com/maddox/il2/objects/weapons/PylonGP9
[15:05:37] at com.maddox.il2.objects.air.MIG_21.onAircraftLoaded(MIG_21.java:892)
[15:05:37] at com.maddox.il2.objects.air.MIG21PFM.onAircraftLoaded(MIG21PFM.java:126)
[15:05:37] at com.maddox.il2.objects.air.Aircraft.load(Aircraft.java:2691)
[15:05:37] at com.maddox.il2.game.Mission.loadAir(Mission.java:1666)
[15:05:37] at com.maddox.il2.ai.Wing.load(Wing.java:144)
[15:05:37] at com.maddox.il2.game.Mission.loadWings(Mission.java:1344)
[15:05:37] at com.maddox.il2.game.Mission._load(Mission.java:762)
[15:05:37] at com.maddox.il2.game.Mission.access$600(Mission.java:120)
[15:05:37] at com.maddox.il2.game.Mission$BackgroundLoader.run(Mission.java:463)
[15:05:37] at com.maddox.rts.BackgroundTask.doRun(BackgroundTask.java:155)
[15:05:37] at com.maddox.il2.game.MainWin3D.loopApp(MainWin3D.java:108)
[15:05:37] at com.maddox.il2.game.Main.exec(Main.java:449)
[15:05:37] at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)



Only with latest version, MA 5.3, the usual stuff we need for the Migs. Engine mod from post one of Western's Engine Mod patch thread, not latest Beta.
Title: Re: Weapons Pack V 1.1 2015.10.17 + 4.10 version
Post by: 4S_Vega on October 21, 2015, 09:21:14 AM
Very strange, but...only you have this problem?

In my game Mig-21s works with last pack, that have just few files different from early

Mig-21 pack works only with weapons pack
Title: Re: Weapons Pack V 1.1 2015.10.17 + 4.10 version
Post by: SAS~Tom2 on October 21, 2015, 11:15:23 AM
It happens only with the latest Weapons pack.  :-\
For me.  ;)
Title: Re: Weapons Pack V 1.1 2015.10.17 + 4.10 version
Post by: 4S_Vega on November 14, 2015, 10:58:58 AM
ver 1.2 at first post
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: TheGrumpyKestrel on November 21, 2015, 03:15:08 AM
Hi
Could anyone give me a short guide or tip on how to install this? I'm a bit of a newbie and unfamiliar with installing things other than aircraft.
If so, thank-you very much. I really need this.
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Mopat on November 21, 2015, 05:14:11 AM
Welcome, Grumpy! Its reltively easy. After downloaded and unpacked this pack, drop the WeaponsPack library onto your MODS library-when all your planes already. No need to add air.ini or something. But be careful! If you have ModernWeapons package (or an outdated variant of this pack!) please remove it. Good flying!
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Mopat on November 21, 2015, 05:48:32 AM
After installing ver 1.2, F-4 central drop tanks are tilted horizontally 90 degree. All F-4 variants. Other ordenance in central hardpoint seems ok. Game 4.12.2+AI flyable +SAS modact. (Former TFM-412...) Interesting, that aircraft with Mk.34 torpedos, also lost its weapon list after Mk.34. So, Liberator GR.V are without any weapon, HellcatMk.III lost only its last loadout option(Mk.34), Grumman Super Duck also have some bombs and Mk.53. Anybody else experienced this?(Even ver 1.1) Log reports nothing special. Planes working. For example every jets working, all have weapons...So, i accidentally delete some "Mk.34 and friends" modpack? But i think GR.V and Duck have own weapons itself.
THX, Mopat
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: 4S_Vega on November 21, 2015, 06:59:18 AM
After installing ver 1.2, F-4 central drop tanks are tilted horizontally 90 degree. All F-4 variants. Other ordenance in central hardpoint seems ok. Game 4.12.2+AI flyable +SAS modact. (Former TFM-412...) Interesting, that aircraft with Mk.34 torpedos, also lost its weapon list after Mk.34. So, Liberator GR.V are without any weapon, HellcatMk.III lost only its last loadout option(Mk.34), Grumman Super Duck also have some bombs and Mk.53. Anybody else experienced this?(Even ver 1.1) Log reports nothing special. Planes working. For example every jets working, all have weapons...So, i accidentally delete some "Mk.34 and friends" modpack? But i think GR.V and Duck have own weapons itself.
THX, Mopat

I know, Phantom 2.0 will be released today with new center hook ;)
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Mopat on November 21, 2015, 08:12:02 AM
THX, Vega, its a fast reply! :D
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 15, 2015, 02:13:03 PM
Hello,when i installed this mod,fyring a missile would result in a game crash,i tried with both the 1.1 and 1.2 versions and it did the same,what am i doing wrong?
Code: [Select]
Load bridges
Load static objects
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from File: 'f9f'
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from Alternative File: 'f9f'
FM called 'FlightModels/PWJ48:F9F.emd' is being loaded from File: 'f9f'
FM called 'FlightModels/PWJ48:F9F.emd' is being loaded from Alternative File: 'f9f'
Flight Model File FlightModels/F9F8T.fmd:F9F contains no Mach Drag Parameters.
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from File: 'f9f'
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from Alternative File: 'f9f'
Hook '_CANNON03' NOT found in mesh of class com.maddox.il2.objects.air.F9F8T
Hook '_CANNON04' NOT found in mesh of class com.maddox.il2.objects.air.F9F8T
FM called 'FlightModels/MiG-17.fmd' is being loaded from Alternative File: 'gui/game/buttons'
FM called 'FlightModels/KlimovEngine.emd' is being loaded from Alternative File: 'gui/game/buttons'
Flight Model File FlightModels/MiG-17.fmd contains no Mach Drag Parameters.
FM called 'FlightModels/MiG-17.fmd' is being loaded from Alternative File: 'gui/game/buttons'
1>                                                                                                                                                                                                                                                                                                 
Command not found:                                                                                                                                                                                                                                                                                                   
Mission: QuickQMBPro/BoB/BoBRedNone00.mis is Playing
warning: no files : music/inflight
java.lang.NoSuchMethodError
at com.maddox.il2.objects.weapons.Missile.startEngineDone(Missile.java:1375)
at com.maddox.il2.objects.weapons.Missile.doStart(Missile.java:673)
at com.maddox.il2.objects.weapons.Missile.start(Missile.java:1316)
at com.maddox.il2.objects.weapons.RocketGun.interpolateStep(RocketGun.java:184)
at com.maddox.il2.objects.weapons.RocketGun.tick(RocketGun.java:206)
at com.maddox.il2.engine.Interpolators.tick(Interpolators.java:222)
at com.maddox.il2.engine.Actor.interpolateTick(Actor.java:434)
at com.maddox.il2.engine.InterpolateAdapter.msgTimeOut(InterpolateAdapter.java:174)
at com.maddox.rts.MsgTimeOut.invokeListener(MsgTimeOut.java:73)
at com.maddox.rts.Message._send(Message.java:1217)
at com.maddox.rts.Message.sendToObject(Message.java:1191)
i have the 4.12 steam version,i hope thesres something i van do,i really want my f9f's to have misiles
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Whiskey_Sierra_972 on December 15, 2015, 02:50:45 PM
Hi Vega!

I find an issue with this mod!

It have some interference with the loadouts of the Corsair (F4U) and after the 6th (154 gal tank and 1000 lbs bomb) it stop....

....the first missing loadout (disabling this mod all work on the F4U) is the 154 gal with the napalm bomb....

....hope in your help!

If you like you can PM me....
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: SAS~Malone on December 15, 2015, 10:59:26 PM
there are also issues with missing Liberator (and other CC planes)loadouts because of wrong/missing files concerning the Mk24 FIDO as well.
this pack will have to be updated at some point again, anyway, so best to make note of anything that needs fixing.
for instance, in my pack that works for these planes, it's referenced as Mk24FIDO.
in your pack, the Mk24_Flare is referenced, but no FIDO - i wonder if this is a potential issue?
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 16, 2015, 11:11:19 AM
Hello? can somebody help me?
i tried with diferent versions but the new weapons will still crash the game,irealld dnt know what im doing wrong,i folowed instrictons correctly.
 
Code: [Select]
Load bridges
Load static objects
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from File: 'f9f'
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from Alternative File: 'f9f'
FM called 'FlightModels/PWJ48:F9F.emd' is being loaded from File: 'f9f'
FM called 'FlightModels/PWJ48:F9F.emd' is being loaded from Alternative File: 'f9f'
Flight Model File FlightModels/F9F8T.fmd:F9F contains no Mach Drag Parameters.
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from File: 'f9f'
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from Alternative File: 'f9f'
Hook '_CANNON03' NOT found in mesh of class com.maddox.il2.objects.air.F9F8T
Hook '_CANNON04' NOT found in mesh of class com.maddox.il2.objects.air.F9F8T
FM called 'FlightModels/MiG-17.fmd' is being loaded from Alternative File: 'gui/game/buttons'
FM called 'FlightModels/KlimovEngine.emd' is being loaded from Alternative File: 'gui/game/buttons'
Flight Model File FlightModels/MiG-17.fmd contains no Mach Drag Parameters.
FM called 'FlightModels/MiG-17.fmd' is being loaded from Alternative File: 'gui/game/buttons'
1>                                                                                                                                                                                                                                                                                                 
Command not found:                                                                                                                                                                                                                                                                                                   
Mission: QuickQMBPro/BoB/BoBRedNone00.mis is Playing
warning: no files : music/inflight
java.lang.NoSuchMethodError
at com.maddox.il2.objects.weapons.Missile.startEngineDone(Missile.java:1375)
at com.maddox.il2.objects.weapons.Missile.doStart(Missile.java:673)
at com.maddox.il2.objects.weapons.Missile.start(Missile.java:1316)
at com.maddox.il2.objects.weapons.RocketGun.interpolateStep(RocketGun.java:184)
at com.maddox.il2.objects.weapons.RocketGun.tick(RocketGun.java:206)
at com.maddox.il2.engine.Interpolators.tick(Interpolators.java:222)
at com.maddox.il2.engine.Actor.interpolateTick(Actor.java:434)
at com.maddox.il2.engine.InterpolateAdapter.msgTimeOut(InterpolateAdapter.java:174)
at com.maddox.rts.MsgTimeOut.invokeListener(MsgTimeOut.java:73)
at com.maddox.rts.Message._send(Message.java:1217)
at com.maddox.rts.Message.sendToObject(Message.java:1191)

Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: SAS~Malone on December 16, 2015, 10:38:35 PM
Krauss, can you please provide more information as to what type of install/game version you are running?
we can't help without that info, as well.......
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 17, 2015, 03:22:48 AM
Krauss, can you please provide more information as to what type of install/game version you are running?
we can't help without that info, as well.......
Ah damn,im sorry.
I have a steam 4.12.2 m version,with the SAS esential mods,including buttons and the engine on their latest versions,the p40 pack,jet era mod,the dh vampire mod and revently added the grummanf9f pack added,i erased all data from Weapos pack so i can start over.
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: SAS~Storebror on December 17, 2015, 04:50:32 AM
Please check which of your mod(s) contains a file "35AE75DA10682FAA".
It's none of the packs you've mentioned, but one other mod besides the latest engine mod has that file.
That's your candidate for fixing the issue.

Best regards - Mike
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 17, 2015, 09:57:03 AM
Please check which of your mod(s) contains a file "35AE75DA10682FAA".
It's none of the packs you've mentioned, but one other mod besides the latest engine mod has that file.
That's your candidate for fixing the issue.

Best regards - Mike
Well,i searched for it in my game's files and is not there,is it within the weapons mod?
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: SAS~Malone on December 17, 2015, 10:43:27 AM
Mike, i decided to check my Modact Mods folder for other instances of that classfile, as well - and i found one in a folder named !Guided_Missiles, as well as in the Engine Mod.
what do you recommend in this case?
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 17, 2015, 12:03:11 PM
Im really considering ditching this and just instaling C.U.P. all together,would it be a better idea?
and would i have to erase the jet era  pack i already added?
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 19, 2015, 05:56:13 AM
Im really considering ditching this and just instaling C.U.P. all together,would it be a better idea?
and would i have to erase the jet era  pack i already added?
i Changed my mind on that,and im very sorry for the felf bump,but i really want this to work.
is there anything else thing i can provide so you may help me?
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: SAS~Storebror on December 22, 2015, 11:09:59 PM
Please check which of your mod(s) contains a file "35AE75DA10682FAA".
i searched for it in my game's files and is not there
This means you don't have the Engine Mod installed at all.
That's the issue.
Install the Engine Mod and you should be fine.

i found one in a folder named !Guided_Missiles, as well as in the Engine Mod.
If everything's working fine I recommend not to touch a running system.

Best regards - Mike
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 23, 2015, 02:14:51 AM
Please check which of your mod(s) contains a file "35AE75DA10682FAA".
i searched for it in my game's files and is not there
This means you don't have the Engine Mod installed at all.
That's the issue.
Install the Engine Mod and you should be fine.

Best regards - Mike
If you mean the SAS Engine Mod v2.7 for 4.12.2m,I installed it,unless i gotta do more that just drag it to my #SAS folder?
(http://puu.sh/m5Nwy/7f7d9cfc7d.png)
I also have Buttons,but not the 10.5 version,do i install that as well?
By the way,i am sorry for bein a pain mike,i wish you luck and a merry christmas.
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: SAS~Storebror on December 23, 2015, 03:54:26 AM
There's several things you should pay attention to.
First and foremost, your !SAS_Engine_Mod has to contain a file "35AE75DA10682FAA", otherwise something went massively wrong when you installed that mod.
Second, while you did install the Jetwar 1.3 package, you apparently forgot to install the Jetwar 1.33 hotfix.
Third, while you did install some Engine Mod, you did not install the latest version.
There's been many things done to the Engine Mod after it's last official release 2 years ago, the latest patch can usually be found around the end of this thread:
http://www.sas1946.com/main/index.php/topic,39075.0.html

Last but not least, if I were you I would disable the CTO mod in JSGME (so that the folder "CTO_Modact5" disappears) since as much as I got from western's Engine Mod patch thread, there should be some newer code inside his latest patch already.

Best regards - Mike
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 23, 2015, 04:35:13 AM
I disabled the cto mod,i have the jet age 1.33 hotfix,i had the 2.7 version of the engine,but after instaling that patch,is working!
Thank you so much mike,i cant thank you enought for helping me after all i done.
the guided missiles are working as intended and i can finaly install more aircraft that require this.
Well,catapults now dot seem to work,but im sure i can solve that myself,i dont even use them much annyways.
Thank you mike and all of sas for being so great,i really like this comunity.
i wish you all luck and a merry christmas!
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: SAS~Storebror on December 23, 2015, 05:30:17 AM
I'm glad that you got it working, congratulations to your first successfully fixed IL2 issue ;)
Now that the missiles are working, you might want to try re-enabling the CTO Mod in order to see whether this has any negative effect and/or wether this puts back the catapults in place.

Best regards - Mike
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Krauss brs on December 23, 2015, 05:50:24 AM
Yes,i did just that and it works,is just that i was using a catapult meant for ww2 aircraft.
I guess i should look into instaling new carriers.
Still,thank you so much mike,youre the best!
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: Danneskjold on April 15, 2016, 08:36:30 AM
There's several things you should pay attention to.
First and foremost, your !SAS_Engine_Mod has to contain a file "35AE75DA10682FAA", otherwise something went massively wrong when you installed that mod.
Second, while you did install the Jetwar 1.3 package, you apparently forgot to install the Jetwar 1.33 hotfix.
Third, while you did install some Engine Mod, you did not install the latest version.
There's been many things done to the Engine Mod after it's last official release 2 years ago, the latest patch can usually be found around the end of this thread:
http://www.sas1946.com/main/index.php/topic,39075.0.html

Last but not least, if I were you I would disable the CTO mod in JSGME (so that the folder "CTO_Modact5" disappears) since as much as I got from western's Engine Mod patch thread, there should be some newer code inside his latest patch already.

Best regards - Mike

Hi!

I'm getting the same error, but none of this seems to fix anything.

When I try to load up the latest SAS engine mod, it causes the game to crash on start up.  Where are the error logs so I can show what's happening?

The other mods I have installed are Jet War 1956 with all the patches, The F-100D/F, the F9F package, SAS Engine Mod v27.7, and SAS Common Utilities 109.
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: creeperdude on April 16, 2016, 07:05:39 AM
Hello,when i installed this mod,fyring a missile would result in a game crash,i tried with both the 1.1 and 1.2 versions and it did the same,what am i doing wrong?
Code: [Select]
Load bridges
Load static objects
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from File: 'f9f'
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from Alternative File: 'f9f'
FM called 'FlightModels/PWJ48:F9F.emd' is being loaded from File: 'f9f'
FM called 'FlightModels/PWJ48:F9F.emd' is being loaded from Alternative File: 'f9f'
Flight Model File FlightModels/F9F8T.fmd:F9F contains no Mach Drag Parameters.
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from File: 'f9f'
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from Alternative File: 'f9f'
Hook '_CANNON03' NOT found in mesh of class com.maddox.il2.objects.air.F9F8T
Hook '_CANNON04' NOT found in mesh of class com.maddox.il2.objects.air.F9F8T
FM called 'FlightModels/MiG-17.fmd' is being loaded from Alternative File: 'gui/game/buttons'
FM called 'FlightModels/KlimovEngine.emd' is being loaded from Alternative File: 'gui/game/buttons'
Flight Model File FlightModels/MiG-17.fmd contains no Mach Drag Parameters.
FM called 'FlightModels/MiG-17.fmd' is being loaded from Alternative File: 'gui/game/buttons'
1>                                                                                                                                                                                                                                                                                                 
Command not found:                                                                                                                                                                                                                                                                                                   
Mission: QuickQMBPro/BoB/BoBRedNone00.mis is Playing
warning: no files : music/inflight
java.lang.NoSuchMethodError
at com.maddox.il2.objects.weapons.Missile.startEngineDone(Missile.java:1375)
at com.maddox.il2.objects.weapons.Missile.doStart(Missile.java:673)
at com.maddox.il2.objects.weapons.Missile.start(Missile.java:1316)
at com.maddox.il2.objects.weapons.RocketGun.interpolateStep(RocketGun.java:184)
at com.maddox.il2.objects.weapons.RocketGun.tick(RocketGun.java:206)
at com.maddox.il2.engine.Interpolators.tick(Interpolators.java:222)
at com.maddox.il2.engine.Actor.interpolateTick(Actor.java:434)
at com.maddox.il2.engine.InterpolateAdapter.msgTimeOut(InterpolateAdapter.java:174)
at com.maddox.rts.MsgTimeOut.invokeListener(MsgTimeOut.java:73)
at com.maddox.rts.Message._send(Message.java:1217)
at com.maddox.rts.Message.sendToObject(Message.java:1191)
i have the 4.12 steam version,i hope thesres something i van do,i really want my f9f's to have misiles

Any fix to this yet?
Title: Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
Post by: 4S_Vega on September 22, 2016, 05:16:39 PM
Version 1.3 at first post
Title: Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
Post by: Whiskey_Sierra_972 on September 23, 2016, 11:44:46 AM
Installed and seem got working flawless....

I only noticed a couple of rockets misplaced inside their launcher....the most noticeable is the Zuni....

....is related to this mod or to the plane arming code?

Moreover , now can you take a look at the Crusader?

The Zuni loadout is always missing and maybe a couple of droptank can be added with the Sidewinders loadouts....

(https://upload.wikimedia.org/wikipedia/commons/d/db/F-8D_armament_NAN9-63.jpg)

(http://4.bp.blogspot.com/-BapUCn-KIYM/UU8Onax-1kI/AAAAAAAAEz0/39IoVw9HJx0/s1600/F8U+External+Tanks+web.jpg)
Title: Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
Post by: 4S_Vega on September 23, 2016, 05:24:52 PM
Crusader's rocket pods is one of the bugs that i never understood till now  :(
Title: Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
Post by: SAS~Gerax on October 17, 2016, 10:02:50 AM
It have some interference with the loadouts of the Corsair (F4U) and after the 6th (154 gal tank and 1000 lbs bomb) it stop....

Have exactly this bug also with Weapons Pack V 1.3.

Edit: solved it with loading the
"Corsairs_weapons complement"
before this weapons pack ..
Title: Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
Post by: SAS~Storebror on November 29, 2016, 06:37:53 AM
Would be nice if credits could be added to this mod.

Best regards - Mike
Title: Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
Post by: Hubberranz on February 22, 2017, 11:09:05 PM
Hi 4S_Vega

I operate: ! 00_WeaponsPack_V1.3_20160923  in 412.2 SAS.5.3 heavily modded.

I just made install of B-26B Marauder version2.2 for 412 : http://www.sas1946.com/main/index.php/topic,17791.msg529533.html#msg529533  by SAS~Gerax; works on clean 412.
Main B-26B post points to that location ( at bottom see HERE ).
Within this mod, is included the patch: Weapons classfiles patch (add in the "weapons complement" folder overwriting) http://www.mediafire.com/?c37znerjabydc65 of main post.
[ 260LbsBombFrag + M26Incendiary ]

This patch contains three classfiles: 03EDC4A4249322E4 7/13/2011 8:57am 1.69Kb  ; this one conflicts with  03EDC4A4249322E4 2/28/2011 3:50am 1.37Kb of WeaponsPack.
                                                    B86C976C19BD6ACC  not found in pack.   BombGunM26Inc .
                                                    C5BF4CD24886E65A   not found in pack.   BombM26Inc .
                                                    'M26Incendiary' file not found in arms pack.
Conflict is: weapons dropdown shows only first 4 entries; 260LbsBombFrag don't work and stops the dropdown; no error reported. ( ... 03EDC4A4249322E4 2/28/2011 in use. )
(https://www.mediafire.com/convkey/7595/xf9cf7swubs55l07g.jpg) (https://www.mediafire.com/view/?xf9cf7swubs55l0)
Before: dropdown stops at *16x250lbs .
I have neutralized -arms file in B-26B mod ; restored, same results;   
had to do this--> -03EDC4A4249322E4 to classfile of Weapon's pack. Opposite: neutralize file or files in in B-26B mod, did not work.

(https://www.mediafire.com/convkey/b214/fjv6611a1cxpza67g.jpg) (https://www.mediafire.com/view/?fjv6611a1cxpza6)
After: dropdown reachs '100xParaF' then 'none' (  412.2 SAS modact 5.3 ).

Newer 03EDC4A4249322E4 7/13/2011 of mod is therefore in use (along with the other two classfiles), and more classes as seen below:
everything now works normally...

February 2011 versus July 2011.
Does your class file needs such update? ( Plus the two ? ) Or will these B-26B classfile(s) ( newer ) cause some problems elsewhere... (?)

update: 78D212DA9AA53450 ( 260LbsBombFrag ) is present in both mod and pack; B-26B's one is more recent and bypassed: no conflict detected...
            CD1096DA6DB769E4 + F024CEE239989064 ( BombTorpMk13Late ) are found only in Marauder, not present in "AerialTorpedoes mod".
           
Regards.