Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Sound Issue  (Read 1243 times)

0 Members and 1 Guest are viewing this topic.

ol' Navy

  • member
  • Offline Offline
  • Posts: 582
Sound Issue
« on: September 12, 2019, 06:31:31 PM »

I have downloaded and installed everything you smart guys have published lately, up through Le Grand Cirque and its two patches, thru 3.7.2.  All seems to have gone well, I thought, until I tried playing the newly installed Marine campaign last night.  Now it seems as though something is messed up someplace.  I have ended up with no engine or gun sounds, in or outside the cockpit.  It seems as though sometime when I move my mouse around the screen during a mission, in one position or another (?) in relation to the aircraft, I get some engine noise then but then when the aircraft turns, it is lost again. Voice stuff (pilots talking, etc) seems to be fine.  What do you reckon I have done wrong this time?  I have no qualms about going back to some previous patch and starting from there, but I don't remember for sure how you do that.  What do you smart fellers advise?  I haven't added any strange mod to my game.  That stuff scares me.  Any advice or help you can give one who is pretty old (77 last week) and not smart, as always, is much appreciated.  By the way, just for shits and giggles, I tried another campaign last evening also, to make sure it wasn't just the Marine one, and it had the same issue.  Thank you for your patience. 
Logged

SAS~vampire_pilot

  • SAS Team
  • member
  • Offline Offline
  • Posts: 4337
  • The man of a million fixes
Re: Sound Issue
« Reply #1 on: September 12, 2019, 10:24:30 PM »

logfile please.

Did you ever have normal sound in BAT 3.7?
all aircraft in all era modules or just some aircraft?
Logged

vonofterdingen

  • Missioneer
  • member
  • Offline Offline
  • Posts: 723
Re: Sound Issue
« Reply #2 on: September 13, 2019, 12:04:09 AM »

Be sure and post your log file as Vampire says.

It may be unrelated to your game however. Check your sound card driver.

  Recently I had two  sound issues.  One was because during an nVidia driver update, the nVidia installer made its driver the default and disabled my Realtek driver. I had sound but it was very faint.

The second sounds like your case. During the latest Windows 10 update a couple days ago my  Sound Blaster configuration changed  from 2 speaker  to Surround sound. I have no clue why or how.  As a result as I moved the mouse around the sound would disappear or go soft when it was meant to play on a speaker that did not exist.
Logged

texaco

  • member
  • Offline Offline
  • Posts: 31
Re: Sound Issue
« Reply #3 on: September 13, 2019, 03:02:13 AM »

You can try this, what fixed it for me was right click on speaker icon > sound settings > sound control panel > properties for speakers under playback device list > enhancements tab > check disable all sound effects.
Logged

ol' Navy

  • member
  • Offline Offline
  • Posts: 582
Re: Sound Issue
« Reply #4 on: September 13, 2019, 11:26:01 AM »

Sound was normal as far as my 77 yr old years can tell, prior to my installing the two latest patches.  The deal about the Win 10 update just lately, heck, I hadn't even considered that as a possibility.  Far as "log file" is concerned, heck, I gave up on understanding that a long while ago.  And although I completely(?) understand you smart guy's concern about it, I will just have to tough it when it comes to my issue except for trying the last two responses. I'll get back to you after I have.  Thank you for your help and your patience.
Logged

vonofterdingen

  • Missioneer
  • member
  • Offline Offline
  • Posts: 723
Re: Sound Issue
« Reply #5 on: September 13, 2019, 01:22:39 PM »

You don't need to understand the log file yourself; heck, it means nothing to me. However there are people here that can look at it and possibly determine your problem. It isn't hard to post and there could be a big benefit.
Logged

ol' Navy

  • member
  • Offline Offline
  • Posts: 582
Re: Sound Issue
« Reply #6 on: September 13, 2019, 01:24:06 PM »

You can try this, what fixed it for me was right click on speaker icon > sound settings > sound control panel > properties for speakers under playback device list > enhancements tab > check disable all sound effects.

I was able to do this, and it worked.  I now have what you guys I guess would consider "normal" sound.  The older I get (shaky hands, old eyes and hearing, etc) I put fewer and fewer demands on my PC and my one and only game, BAT.  But I was, amazingly, able to tell something was amiss here.  You guys have helped me out for years now, and I do truly appreciate the effort and the patience you have shown to actually read and try to understand my probably cryptic queries.  Thanks.
Logged

Gubi

  • Flying Ass Clown #34
  • Modder
  • member
  • Offline Offline
  • Posts: 719
Re: Sound Issue
« Reply #7 on: September 13, 2019, 03:58:46 PM »

Me too 'ol Navy.  Windows update this morning...off to work.  Back to DBW and the sound is shit.  Checked the rig and all the other programs sounds are wonderful.  Updated a driver, and the other sounds were even better.  Got an old copy of IL-2 from my backup and the same.  Muffled sound, when I move the mouse, in F2, it comes and goes as I pass around the aircraft.  I compared .conf files from the earlier ones and they seem to match.  Worked myself to death with the in game sound controls...and poop.  I have not changed a thing except for the auto Windows 10 update this AM.  I can't seem to find anything wrong in the log...but might have to share it...I've never shared my problems.   I'm stuck in a motel for another week, away from my computer guru at home.  Has anybody else experienced this with the new Windows 10 update?  I mean, from, like this morning...  I tried the Windows paths described above...and I don't see the same things they're talking about.  ...and I've been using Victor's SoundMod for about a year now...updated a while back.

Anyway, I just want to see if anyone else has experienced this scary thing?

[eh]  I just realized this was in the BAT section.  I just read it from the chat.  My symptoms are exactly what 'ol Navy described though.  Moderator's please move this as appropriate...or...execute me...

  Cheers and Prost

[2d edit]  WTF?  It has taken care of itself.  Am I mad?  ...ohhh...my babies with sound...  Didn't do a thing, except resign myself to getting through this motel business...and kept a bird flying.  It sounded like shit.  I think:  Went and listened to some jams...and posted one...thinking about the shit sounds of my DBW.  Went back to her.  She's as good as new.  Amazing.  True story, right now.  I am a moron...
Logged
I am a moron.

vonofterdingen

  • Missioneer
  • member
  • Offline Offline
  • Posts: 723
Re: Sound Issue
« Reply #8 on: September 13, 2019, 10:55:24 PM »

Windows works wondrous ways
Logged

Flying H

  • member
  • Offline Offline
  • Posts: 1116
  • "And you can fly, high as a kite if you want to..
Re: Sound Issue
« Reply #9 on: September 14, 2019, 01:09:50 PM »

Yeah, and windows fucks up in various ways! I´ve had to reinstall all drivers for soundcard, grafics, keyboard, TARGET and more! Didn`t have to reinstall my games though that a few has with IL2GB but I was quite pissed tonoght when I was going to stream tonights hockey games and found out I had no sound at all! By the way the warthog stick isn´t responding although the rest of the trustmaster family is! Working on a solution with the help from TM support. (A bit of whining from "poor" me)
Logged
And you can fly, high as a kite, if you want to.........

ol' Navy

  • member
  • Offline Offline
  • Posts: 582
Re: Sound Issue
« Reply #10 on: September 15, 2019, 11:51:38 AM »

Funny, or unusual, as it may be - I haven't had Windows 10 do much of anything strange to me.  It's a good thing.  As for the game, I have you guys to ask and to straighten me out.  With Windows, it's not that simple I suppose.  I guess I would need to call MS.  I can just keep hoping that nothing occurs there.  Friends of mine, over the years, have all pretty much gone, and my kids and grandkids aren't around much anymore.  I'm pretty much left to my own devices, few as they may be.  Anyhow, thanks to each of you.
Logged

Flanker27

  • member
  • Offline Offline
  • Posts: 131
Re: Sound Issue
« Reply #11 on: September 17, 2019, 08:15:23 AM »

Iv cheated a bit, iv disabled my win ten updates as far as the sound issues go I would check the software that the card came with(realtek audio manager, Dolby sound options etc.) as sometimes those like to turn stuff on or off or you have to set them to use speakers or headphones manually, if it happened as soon as it updated I blame windows and am not sure quite how to help
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 26 queries.