Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: F4F-4 problems  (Read 596 times)

0 Members and 1 Guest are viewing this topic.

blackshark

  • member
  • Offline Offline
  • Posts: 317
F4F-4 problems
« on: August 14, 2019, 06:38:32 AM »

Hi I have problems with F4F-4 (and discovered the same problems for FM-2), while F4F-3 is ok.

I already solved the "exploding problem at mission start" problem (deleting WingLIn_D0 etc ....).

But now I have a very strange problem on the carrier at the take-off:
- the player plane works fine (first of the group of four) and I can take-off from the carrier
but
- the second plane (AI) does not take-off ... at the start of the mission it starts the engine, then after the player plane take-off, the second plane (AI) turns the engine off ... than automatically is placed at the catapult but the engine stay turned-off and it does not take-off at all ... as a consequence all the other AI planes (with engines "on") wait on the deck and nothing happen ...
I tried with FM-2 and it's the same problem.
I tried with F4F-3 and it works like a charm ... all planes take-off and everything is ok ...

I need your help ...
Logged

WxTech

  • Modder
  • member
  • Offline Offline
  • Posts: 1283
Re: F4F-4 problems
« Reply #1 on: August 16, 2019, 12:39:12 AM »

Perhaps related to wing folding? Have you tried other planes, with and without folding wings, to see if this might be the underlying cause? Knowing this would facilitate a more focused look into the related Java code...
Logged

blackshark

  • member
  • Offline Offline
  • Posts: 317
2
« Reply #2 on: August 16, 2019, 02:39:55 PM »

Hi WxTech
after your post I tried other planes ... f4f-3, f6f (all versions), corsair (all versions), zero (3 versions) and all of them work fine.

Then I tried to use, as the F4F-4 player plane, not the first one of group of four but the second of the four and in this case everything works ... the first (AI) plane take-off, then I as the player take-off, then the third and fourth (AI) take-off without any problem ...
So I can say that the only problem is with F4F-4 (and FM-2) if the player is the first plane and the AI is the second plane ... but all the campaign (USS ENTERPRISE campaign) is based on the player as captain, so first of the group of four ... I made the first 8 missions  with F4F-3 and everything was ok, then with all the missions with the F4F-4 I have that problem ...
Well, it's very strange, never had a problem like that before  :(


One more thing, I love your cockpit mods ... I installed the "WxTech Wildcats cockpit mod for stock Wildcats v3" and it works fine with F4F-3 but, related to my problem, with it installed I was not able to use the F4F-4 plane ... at the start of the mission I cannot go into the cockpit of the player's F4F-4 plane ... I can only see it from outside (with F2) so I cannot give any input to the plane.
But if I remove the F4F-4 folders from your mod (and maintain only the F4F-3 folder, that works like a charm) then I can go into the F4F-F cockpit and use the player's plane, but have the problems that I wrote in the first post of the thread with the second plane of the group of four (so the AI plane) ...
What could be wrong ?
Logged

rollnloop

  • member
  • Offline Offline
  • Posts: 232
Re: F4F-4 problems
« Reply #3 on: August 18, 2019, 09:22:24 PM »

Quote
- the second plane (AI) does not take-off ... at the start of the mission it starts the engine, then after the player plane take-off, the second plane (AI) turns the engine off ... than automatically is placed at the catapult but the engine stay turned-off and it does not take-off at all ... as a consequence all the other AI planes (with engines "on") wait on the deck and nothing happen ..

Just a shot in the dark, but as squadron leader there is a radio command to ask wingmen to start engines (usually it's not useful except with "taxi to take off" waypoints), see if it works ?
Logged
Pages: [1]   Go Up
 

Page created in 0.012 seconds with 25 queries.