Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: BAT Not Recognising My Joystick  (Read 142 times)

0 Members and 1 Guest are viewing this topic.

MJJWalsh

  • member
  • Offline Offline
  • Posts: 32
BAT Not Recognising My Joystick
« on: May 26, 2019, 06:25:43 PM »

I've been enjoying BAT 3.6.2 until suddenly today it stopped recognising my T1600M joystick - it is only responding to key board commands.  I've exited the game several times, and restarted the PC but nothing doing.  I've not added any Mods and the only change I've made since it was working properly was to load the set of WAW Brazilian single missions recently posted.  The joystick is working properly - I've checked its 'properties' and I have no problem with CLOD and IL2 BOS/BOM, where everything is working normally.  Any quick ideas before I post logfiles etc?  Thanks for your help.
Mike
Logged

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 17733
  • Failure is not an option.
    • What goes around comes around, you'll see
Re: BAT Not Recognising My Joystick
« Reply #1 on: May 26, 2019, 10:30:43 PM »

Windows has a habit of changing controller IDs when you unplug/plug a joystick, especially when using a different USB port on plugging in again.
You can check whether your jostick is working at all by checking your control settings and trying to reassign something down in the Hotas section.
Other than that, the only thing that would keep a joystick that is visible and working in the Windows Game Controller settings from working in IL-2 would be if the total number of game controllers on your PC exceeds IL-2's limit.
If the T1600M is your only game controller, we can rule that out.

]cheers[
Mike
Logged
Learn. Challenge. Improve. In loving memory of the times when I cared...

MJJWalsh

  • member
  • Offline Offline
  • Posts: 32
Re: BAT Not Recognising My Joystick
« Reply #2 on: May 27, 2019, 04:01:53 AM »

Dear Mike,
Thank you for your prompt reply - and your last point which solves the problem.  I'd connected a steering wheel for some laps on Assetto Corsa for the first time for several months and together with the joystick and headphones that was 3 USBs activated.  Removing the wheel has sorted the problem.  So why hadn't it hadn't come to light previously?  I've been flying IL2 BOS/BOM/BpP and CLOD recently in preference to 1946.  However BAT 3.6.2 with NG HUD/CAM/MAP, plus the promise of a re-worked 'Years of Triumph' saw me back with the game.  I'm also 12 missions into the new USS Enterprise campaign and have only ended in the drink once so far (IIRC probably reflects the real life accident rate on carriers!).  I then encountered the problem after installing the wheel.  An odd quirk of the game, but not a problem now I know the issue!  Many thanks for your help.
Regards Mike 
Logged
Pages: [1]   Go Up
 

Page created in 0.012 seconds with 25 queries.