Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Strange fps bug with contrails  (Read 390 times)

0 Members and 1 Guest are viewing this topic.

kit75

  • member
  • Offline Offline
  • Posts: 5
Strange fps bug with contrails
« on: January 10, 2019, 05:32:12 AM »

The appearance of 7-8 aircraft in the mission there is a drop in fps to 15.In the default Il-2 everything works fine with more aircraft.

After a complete BAT reinstallation has not changed anything.Tried all the options to improve the fps,no change.

my computer:
I3 6100U 2.3 Ghz
940MX 2 GB
12 GB OF RAM
BAT on the SSD

Also found that the fall of fps is a load drop on both CPU and GPU.

Any idea what that might be?
Logged

SAS~vampire_pilot

  • SAS Team
  • member
  • Online Online
  • Posts: 3855
  • The man of a million fixes
Re: Strange fps bug
« Reply #1 on: January 10, 2019, 08:33:36 AM »

it all depends.
Generally, BAT WAW has less FPS than stock game or a smaller mod assembly, simply due to sheer size of it.
FPS in a mission also depends a lot on ground objects present and ground action going on or not. In fact this can be quite a resource dump even if you can't see anything of it. The aircraft amount mentioned it no general problem for BAT.

A logfile in your case can shed light on any specific issue you might have with your setup.
Logged

kit75

  • member
  • Offline Offline
  • Posts: 5
Re: Strange fps bug
« Reply #2 on: January 10, 2019, 08:56:07 PM »

I forgot to mention that such a drawdown occurs only when the contrails of more than three aircraft appear in the frame.
There is practically no difference between fps in WAW and TJA.
P.S. There is no Ground equipment in the mission.
P.P.S. In the larger mission of the fps drop is less noticeable(45-40 fps)

Log: pastebin.com/t8cD5bmp
Logged

Bigmug

  • member
  • Offline Offline
  • Posts: 47
Re: Strange fps bug
« Reply #3 on: January 11, 2019, 04:42:59 AM »

Hi!

Have a look at your conf.ini in the openGL section.
For your Laptop the settings should be effects=1, water=2, forest=2 and landshading=2

Furthermore you could drop down your Antialising in the GeForce settings to 2x or 4x.

For my GTX860M the settings in the NVIDIA GUI are:

anisotrophic filtering   8x
anialising FXAA  off
antialising   4x
antialising mode   overrun applications settings
antialising transparacy   8x (supersample)
CUDA   all
triple buffer   on
energy consuption mode   max. power
max. prerendered...    4
OpenGL rendering GPU    Geforce
shadercache   on
texture filtering - anisotrphical...   off
texture filtering - negative BIAS   Clamp
texture filtering - trilinear optimisation    on
threaded optimisation    on
vertikal sync   on  (for single player)
prerendered virtual....    1

For me BAT WAW ist running smooth with 35+ fps 

This all is a bit try and error. 

Good luck!

Big Mug
Logged

kit75

  • member
  • Offline Offline
  • Posts: 5
Re: Strange fps bug
« Reply #4 on: January 12, 2019, 03:02:11 AM »

Hi!

Have a look at your conf.ini in the openGL section.
For your Laptop the settings should be effects=1, water=2, forest=2 and landshading=2

NO FULL QUOTES PLEASE!!!!




Almost helped,but in this mission, as the fps would drop to 2-5,and drops.

Mission: www.mediafire.com/file/zltgo2v3p8cpmyp/BoG.mis

In VP everything works fine.
Logged

bomberkiller

  • Treffen sich zwei Jäger...!
  • Modder
  • member
  • Offline Offline
  • Posts: 3254
  • Bf-109G-6/R6 = Bomber Killer
Re: Strange fps bug with contrails
« Reply #5 on: January 12, 2019, 03:11:14 AM »

Avoid dust and smoke on the active map!  ;)

wbr, Gerhard  :)
Logged
FAC N° 9 ...cheers mein Schatz

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 6221
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: Strange fps bug with contrails
« Reply #6 on: January 12, 2019, 04:01:13 AM »

Quote
antialising transparecy   8x (supersample)

try 'antialising transparecy off'
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 26 queries.