Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: IL-2 1946 will no longer start  (Read 495 times)

0 Members and 1 Guest are viewing this topic.

ummagumma32

  • member
  • Offline Offline
  • Posts: 12
IL-2 1946 will no longer start
« on: May 15, 2018, 12:10:06 PM »

Hi I was wondering if anyone could help me out. I'm no longer able to get IL-2 1946 to start anymore. I do have the BAT installed on it and was able to play it fine with no issues. However, the game will no longer start. I've attached my file log and have tried to change the graphics settings trough the conf.ini file with no success. Can anyone please help? Thanks.

My PC info:
MSI
Windows 10
Processor: Intel Core i5-7300HQ CPU @ 2.50 GHz
RAM: 8G
System: 64 bit
Graphics Card: NVIDIA GeForce GTX 1050

Error Log
Code: [Select]
[May 15, 2018 5:52:25 PM] ------------ BEGIN log session -------------
[5:52:25 PM] OpenGL provider: dx8wrap.dll

[5:52:27 PM] OpenGL library:

[5:52:27 PM]   Vendor: 1C.Multimedia.Dev/Maddox.

[5:52:27 PM]   Render: DirectX8.
[5:52:27 PM]   Version: 1.1

[5:52:27 PM]   Extensions: GL_EXT_secondary_color GL_ARB_multitexture GL_EXT_texture_env_combine GL_ARB_texture_compression

[5:52:27 PM] Size: 1680x1050

[5:52:27 PM] ColorBits: 32

[5:52:27 PM] DepthBits: 24

[5:52:27 PM] StencilBits: 8

[5:52:27 PM] isDoubleBuffered: true

[5:52:27 PM]

[5:52:27 PM] *** Looking for Advanced CPU Instructions...
[5:52:27 PM] [x] PentiumPro

[5:52:27 PM] [x] Multimedia (MMX)

[5:52:27 PM] [x] 3D (SSE)

[5:52:27 PM] [x] 3D (SSE2)

[5:52:27 PM] [-] 3D (3DNow)

[5:52:27 PM] ColourBits 32, ABits 0, ZBits 24

[5:52:27 PM]

[5:52:27 PM] *** Looking for Render API Extensions ...

[5:52:27 PM] [-] 'GL_EXT_paletted_texture' extension - Palettized textures (8 bit RGBA palette).

[5:52:27 PM] [-] 'GL_EXT_compiled_vertex_array' extension - Compiled Vertex arrays.

[5:52:27 PM] [-] 'GL_EXT_clip_volume_hint' extension - Frustum clipping optimization.

[5:52:27 PM] [x] 'GL_EXT_secondary_color' extension - Secondary Color for 3D fog & specular optimization.

[5:52:27 PM] [-] 'GL_EXT_separate_specular_color' extension - SeparateSpecular for 3D fog & specular optimization.

[5:52:27 PM] [x] 'GL_ARB_multitexture' extension - Multitexturing.

[5:52:27 PM] [x] 'GL_EXT_texture_env_combine' extension - Multitextures advanced combining for special effects.

[5:52:27 PM] [-] 'GL_NV_texture_env_combine4' extension - Multitextures advanced combining for special effects.

[5:52:27 PM] [-] 'GL_EXT_texture_env_dot3' extension - Dot3 Bump advanced combining.

[5:52:27 PM] [-] 'GL_NV_depth_clamp' extension - Corrects Shadows rendering

[5:52:27 PM] [-] 'GL_NV_texture_shader' extension - NV Pixel Shaders

[5:52:27 PM] [x] 'GL_ARB_texture_compression' extension - Saves texture memory by 400%

[5:52:27 PM] [-] 'GL_EXT_texture_filter_anisotropic' extension - Anisotropic texture filtering.

[5:52:27 PM]

[5:52:27 PM] Maximum texture size : 8192

[5:52:27 PM] Maximum simultaneous textures :8

[5:52:27 PM] MaxAnisotropic (1.0 = none) : 1.000000

[5:52:27 PM] WARNING: 'Perfect' Mode required latest drivers with 'vertex buffer' support

[5:52:27 PM] WARNING: 'Perfect' Mode required pixels shaders

[5:52:27 PM] WARNING: 'Perfect' Mode required latest drivers with vertex shaders support'GL_ARB_vertex_program'

[5:52:27 PM] WARNING: 'Perfect' Mode is not supported for this combination of hardware and drivers.

[5:52:28 PM] java.lang.NoSuchFieldError: windowUse3RendersUI

[5:52:28 PM] at com.maddox.il2.engine.Renders.msgGLContext(Renders.java:150)

[5:52:28 PM] at com.maddox.il2.engine.Renders.setGlContext(Renders.java:138)

[5:52:28 PM] at com.maddox.il2.engine.RendersMain.setGlContext(RendersMain.java:73)

[5:52:28 PM] at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1604)

[5:52:28 PM] at com.maddox.il2.game.Main3D.beginApp(Main3D.java:1579)

[5:52:28 PM] at com.maddox.il2.game.MainWin3D.beginApp(MainWin3D.java:212)

[5:52:28 PM] at com.maddox.il2.game.Main.exec(Main.java:432)

[5:52:28 PM] at com.maddox.il2.game.GameWin3D.main(GameWin3D.java:235)
Logged

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 15487
  • Ask me if I care.
    • Friendly Fire isn't.
Re: IL-2 1946 will no longer start
« Reply #1 on: May 15, 2018, 10:53:24 PM »

You have mixed BAT with an IL-2 4.13 installation. "windowUse3RendersUI" is 4.13. BAT is 4.12.2.
You cannot use BAT with any 4.13 version.
Install Patch 4.12.2 on top and the game should work again.

]cheers[
Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - In loving memory of the times when I cared...

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 5934
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: IL-2 1946 will no longer start
« Reply #2 on: May 16, 2018, 12:56:09 AM »

Dont forget to switch to OpenGL, because youre in DirectX which in IL-2 1946 is the older/inferior graphics mode. Simply open your conf.ini located in the gameroot and set:

Quote
[GLPROVIDER]
GL=Opengl32.dll

also make sure that you got:
HardwareShaders=1 in the [Render_OpenGL] section.

I'm sure that theres a sample conf.ini in the documentation of BAT.
If not: https://www.google.com/search?q=sas1946+conf.ini+guide&ie=utf-8&oe=utf-8&client=firefox-b

ummagumma32

  • member
  • Offline Offline
  • Posts: 12
Re: IL-2 1946 will no longer start
« Reply #3 on: May 16, 2018, 08:45:55 AM »

Thank you for the replies. The patch update may have happened automatically through steam. That may explain why the game was working fine one day and then didn't the next day. Where may I find 4.12.2 and would installing that patch effect my current install of BAT?

Also, I have it on directX because on OpenGL I get crystalloid/spike shaped clouds. Not sure how to fix that when on OpenGL.
Logged

ecf111

  • member
  • Offline Offline
  • Posts: 227
Re: IL-2 1946 will no longer start
« Reply #4 on: May 16, 2018, 04:14:59 PM »

You can copy your IL2 folder from steam and put it somewhere else as well(NOT in Program Files), then steam updates won't affect anything. You can make as many copies as you like, so you can have a BAT version, a stock version, vpmodpack or any of the other variations of the game.

Here's a thread on unpatching and Steam, I haven't done any of it, just posting here to share with you.

https://www.sas1946.com/main/index.php/topic,55464.msg644712/boardseen.html#new

Logged
Create.

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 15487
  • Ask me if I care.
    • Friendly Fire isn't.
Re: IL-2 1946 will no longer start
« Reply #5 on: May 16, 2018, 10:09:46 PM »

Where may I find 4.12.2 and would installing that patch effect my current install of BAT?
You need to get rid of the 4.13 files.sfs and have the 4.12.2 one instead.
Since 4.13 also changes dt.dll file and 4.12.2 doesn't contain that file, you also have to install the previous patch (4.12.1) before that step.
So what you need to do is to first install 4.12.1 and then 4.12.2. This will work with your current install of BAT.
4.12.1 is available here: https://onedrive.live.com/download?cid=7F11E7867133791A&resid=7F11E7867133791A%21706&authkey=ACCzSi6EVwRw6mI
4.12.2 is available here: https://onedrive.live.com/download?cid=7F11E7867133791A&resid=7F11E7867133791A%21707&authkey=AKH0-4r7BmQba2o

I have it on directX because on OpenGL I get crystalloid/spike shaped clouds.
Looking at your screen resolution (1600x1050), it's likely that you're using a Laptop with integrated IntelHD graphics.
In that case there's nothing you can do. Stick to DirectX.

]cheers[
Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - In loving memory of the times when I cared...

ummagumma32

  • member
  • Offline Offline
  • Posts: 12
Re: IL-2 1946 will no longer start
« Reply #6 on: May 17, 2018, 03:44:14 AM »

Thank you, Gents. You all saved me hours of headache and frustration. I'm back in my Polish 303 campaign. Downgrading to 4.12.1 and then up to 4.12.2 solved the problem. I changed my game folder name to prevent Steam from updating. Thanks again. Cheers!
Logged

muzashi1963

  • member
  • Offline Offline
  • Posts: 14
  • The sky. That's what's up.
Re: IL-2 1946 will no longer start
« Reply #7 on: May 22, 2018, 04:18:06 AM »

Thanks for the patches, Storebror. Steam did the same to me, and updated my IL2.  Thought I had saved them (the patches) somewhere previously, but obviously not.  :-[
Logged
Pages: [1]   Go Up
 

Page created in 0.47 seconds with 26 queries.