Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Quick and dirty KI-61-KAId mod for 4.09  (Read 837 times)

0 Members and 1 Guest are viewing this topic.

_Hans

  • member
  • Offline Offline
  • Posts: 46
Quick and dirty KI-61-KAId mod for 4.09
« on: October 01, 2017, 02:47:17 AM »

I have JapanCat's KI-61 mods for 4.09, and I love it, but there's one version we're missing...

The KI-61-I-KAId.

The KAId was armed with the pair of .50 caliber MGs in the nose common to the Ko/Otsu/Hei series, but fitted with a pair of 30mm wing cannons, HO-155 to be exact.

I tried to make this myself but my compiler just refuses to cooperate, and maybe I've forgotten how...It's been years...

Basically my request is thus:

-Take existing KI-61 Hei.
-Reduce wing gun ammunition capacity to 60rpg (I freely admit, I have literally NO CLUE what the actual capacity was, and no way to find out how...But this seems reasonable...I think...) and change the guns to HO-155.  We may not have the HO-155 in game, in which case the MK-103 is actually quite similar in terms of ROF and muzzle velocity...
-Rename to KI-61-KAId.
Logged

SAS~Epervier

  • 4.09 Guardian Angel !
  • SAS Team
  • member
  • Offline Offline
  • Posts: 6808
  • I'm French and Rebel_409! Nobody is perfect!
    • Some tinkering here
Re: Quick and dirty KI-61-KAId mod for 4.09
« Reply #1 on: October 01, 2017, 03:10:47 AM »

I tried to make this myself but my compiler just refuses to cooperate, and maybe I've forgotten how...It's been years...
Check the code!
If you have that kind of line:
      Property.set(class1, "cockpitClass",
            com.maddox.il2.objects.air.CockpitKI_61.class);

Add to get this:
      Property.set(class1, "cockpitClass", new Class[] {
            com.maddox.il2.objects.air.CockpitKI_61.class });


Logged
A bove ante, ab asino retro, a stulto undique caveto.

_Hans

  • member
  • Offline Offline
  • Posts: 46
Re: Quick and dirty KI-61-KAId mod for 4.09
« Reply #2 on: October 01, 2017, 03:21:39 AM »

Sadly I think it's not the code but my install of Eclipse.  Or maybe something else.  I'm not sure.  I can't seem to get ANYTHING to compile!
Logged

SAS~vampire_pilot

  • SAS Team
  • member
  • Online Online
  • Posts: 2624
  • The man of a million fixes
Re: Quick and dirty KI-61-KAId mod for 4.09
« Reply #3 on: October 01, 2017, 04:30:52 AM »

usually the ability to compile smoothly is just as good as your classdump. Maybe yours is very outdated and missing files?
But eclipse should tell you which ones in the error screen.
Logged

_Hans

  • member
  • Offline Offline
  • Posts: 46
Re: Quick and dirty KI-61-KAId mod for 4.09
« Reply #4 on: October 01, 2017, 01:26:29 PM »

I think what's going on here is I'm trying to run a copy of Eclipse that's technically installed for a different OS in 32 bit IIRC......That install doesn't work anymore though.......

I should probably reinstall and try again but I remember it being a pain for some reason.
Logged

SAS~Epervier

  • 4.09 Guardian Angel !
  • SAS Team
  • member
  • Offline Offline
  • Posts: 6808
  • I'm French and Rebel_409! Nobody is perfect!
    • Some tinkering here
Re: Quick and dirty KI-61-KAId mod for 4.09
« Reply #5 on: October 01, 2017, 02:54:24 PM »

A stupid question: do you have Java installed in your Windows?
Have you installed JRE?
I use JRE 1.8 for my Eclipse!
Logged
A bove ante, ab asino retro, a stulto undique caveto.
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 25 queries.