Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2   Go Down

Author Topic: TROUBLESHOOTING 101 - pls read this and think about it before you post about a problem  (Read 9625 times)

0 Members and 1 Guest are viewing this topic.

Griffon_301

  • SAS Team
  • member
  • Offline Offline
  • Posts: 1481

SAS Moderator Note

If you require assistance with errors, Crash-To-Desktops (CTD) or mission failures, you need to post a log of the event.

Read how to get the log here, and the instant log here.

When you want to post only the relevant parts from the log
read here how to do this. (code option!)

If you want to post all lines of the logfile we suggest to use https://pastebin.com/
to paste your log and then paste the link here which you got from them.
Read and see here how to do this.


You also need to be on the latest BAT version!

You also must test the error behaviour with all JSGME mods or other 3rd party mods deactivated!


Ignoring these very simple requests repeatedly may result in an official warning by a moderator without any further consultation.

Thank you!

******************************



Dear guys!

BAT has grown into a very mature, stable and comprehensive mod package, containing loads of stuff and providing great content in a well organized and layed out way.
Simon has posted a Manual for BAT - so I will not go into further detail about the inner workings and the philosophy behind it.

the reason for my post is a different one and please read it carefully, think about it and remember it the next time you are about to post about a technical problem with your install.
 
first of all - the Log File! if your game crashes, pls provide a log file! read about how to get it and which parts from it we need and how to post those;
the reason is simple - going to the doctor and saying "I feel unwell" is nice, but does not get you anywhere nearer towards a good diagnosis.
so give us at least a fighting chance to help...

on the other hand SAS has a quite comprehensive Tech help base here providing good explanations for all the 5%, 20%, 30% etc crashes and many other trials and tribulations, a modded game can confront you with, so pls read these as well before you post the 500th iteration of a technical problem that can be easily solved by searching the forums and reading through what has been posted already...
I guess there is a good chance that about 85 to 90% of all problems have been dealt with already in other threads...

you might know already that BAT is a big, comprehensive mod pack, containing - per definition - loads of mods;
so if a single mod of the pack might cause you grief, try to find the release thread of this mod and read through this as well; you will be amazed how much information can be gathered from those threads...

lastly, read through the release posts of new BAT expansion packs too; you will see what is contained and get to know any known "problems" or incompatibilities that might still be in the game... to put it more harsh - RTFM :)

should there be other problems, of course feel free to post them...we are a community anyways; but if our "ressources" get drained by answering stuff that has been answered already over and over again...well you get the idea!

so, let´s work together here to make the best modpack still better...

cheers
phil
Logged

Uzin

  • Modder
  • member
  • Offline Offline
  • Posts: 2428
  • On lifetime holidays

Can anybody give a link to this, please ?
,
"first of all - the Log File! if your game crashes, pls provide a log file! read about how to get it and which parts from it we need and how to post those;"

Especially which part (not exceeding 50000 characters) should be given .
Searching fails.
Thanks in advance.
Logged

SAS~Skylla

  • SAS Team
  • member
  • Offline Offline
  • Posts: 1624
  • Flying Ass Clown N°24

What you are looking for is posted in another one of our widely ignored sticky topics :P

=> http://www.sas1946.com/main/index.php/topic,39780.msg446116.html#msg446116
Logged
When all else fails: read the instructions!

bigans

  • member
  • Offline Offline
  • Posts: 167

I have a doubt:
EXPANSIONS PACK (from one to twelve) should install before checkpoint Charlie and other version v.3.1, 3,2...or not.

Thank you for the help
Logged

SAS~vampire_pilot

  • SAS Team
  • member
  • Online Online
  • Posts: 4417
  • The man of a million fixes

no, these are not needed anymore

And please, refrain from posting general help requests in such threads. Make your own thread about your issue, thank you.
Logged

bigans

  • member
  • Offline Offline
  • Posts: 167

Thank you.  ;)
Logged

Unca-Fester

  • Graduate of the Dirk Gently School of mucking about.
  • Modder
  • member
  • Offline Offline
  • Posts: 166

No, these are not needed anymore...( referring to the no longer relevant BAT expansions..)


You know what would be great, is if you could put in big, friendly, helpful text that the latest BAT Expansion pack, ( Checkpoint Charlie?..) is all you need and that the older past expansion packs are for maintaining older BAT installs.

Because... I had to ask in a PM why there are so many expansion packs and it seems, ( at least from the download links subforum for BAT..)  that you need each and every one of them, when it's not necessary.

 As an IL2 n00b, I was getting increasingly despondent about the vast amount of .hdd filling content I needed to run BAT!
Logged

SAS~vampire_pilot

  • SAS Team
  • member
  • Online Online
  • Posts: 4417
  • The man of a million fixes

But this post contains it all in sequence:

https://www.sas1946.com/main/index.php/topic,53691.0.html

-Base game setting (4.12 and how to get there)
-Bat basic install part 1-29
-setting up base isntall and the dlls

and then:
"B.A.T. EXPANSION PACKS:"

- beginning with 3.0 Checkpoint Charlie
-3.1 Sealion
... and so on of course.



Logged

Unca-Fester

  • Graduate of the Dirk Gently School of mucking about.
  • Modder
  • member
  • Offline Offline
  • Posts: 166

Yes but it's not clear from just that download thread that the older expansion packs aren't deprecated, consolidated and better in the Checkpoint Charlie.

  Yeah, n00bs can be dummies.

  I guess I'm spoiled by having a small initial download with FlightGear,  plus here lately you can get all the scenery and new planes installed on the fly, (literally, FG downloads both plane and scenery expansions while you are flying online..)  I realize this is an apples to oranges analogy.  But, the BAT download forum has past links with very explicit demands that you need all of the prior expansion packs 1 through 12, I started down that rabbit hole and I went into information overload. 

So, ( just humor me, I'm a bit odd in my OCD )  a comforting, easy to read, note that the past expansion packs are deprecated would help others in the future,  The fellow I was conversing with in the PM mentioned that he himself was also confused, overwhelmed and a bit frustrated by the myriad choices.

I'm hoping in the future you folks could see your way to making the various eras available as their own suite, but maybe that doesn't work well within the K.I.S.S. structure of B.A.T.
Logged

Dushka

  • member
  • Offline Offline
  • Posts: 2

Reading this thread I am led to believe that the BAT files 1-29 plus the installer aren't needed./ Just Checkpoint Charlie and the expansion packs?
Logged

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 18133
  • Failure is not an option.
    • What goes around comes around, you'll see

I am led to believe that the BAT files 1-29 plus the installer aren't needed.
Don't know how you reached that conclusion but it's wrong.
The BAT 1-29 plus installer is always required.

From there on, it's the sequence of BAT 3.x modules that have to be installed, in that order: 3.0, 3.1, 3.2, 3.3.

Cheers!
Mike
Logged
You've got no one to follow, and no one will follow you. Ain't that a relief?

lachie254

  • member
  • Offline Offline
  • Posts: 5

Hello B.A.T MOD i have a problem i downloaded the B.A.T mod and it doesnt even launch so please fix your modpack because it is not working i did everything right and doesnt even launch.

Thanks.
Logged
Pages: [1] 2   Go Up
 

Page created in 0.021 seconds with 27 queries.