Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 3 [4]   Go Down

Author Topic: Weapons Pack V 1.3 2016.09.23 + 4.10 version  (Read 19517 times)

0 Members and 1 Guest are viewing this topic.

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 13582
  • Ask me if I care.
    • Friendly Fire isn't.
Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
« Reply #36 on: December 23, 2015, 03:54:26 AM »

There's several things you should pay attention to.
First and foremost, your !SAS_Engine_Mod has to contain a file "35AE75DA10682FAA", otherwise something went massively wrong when you installed that mod.
Second, while you did install the Jetwar 1.3 package, you apparently forgot to install the Jetwar 1.33 hotfix.
Third, while you did install some Engine Mod, you did not install the latest version.
There's been many things done to the Engine Mod after it's last official release 2 years ago, the latest patch can usually be found around the end of this thread:
http://www.sas1946.com/main/index.php/topic,39075.0.html

Last but not least, if I were you I would disable the CTO mod in JSGME (so that the folder "CTO_Modact5" disappears) since as much as I got from western's Engine Mod patch thread, there should be some newer code inside his latest patch already.

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - Over the Line!

Krauss brs

  • member
  • Offline Offline
  • Posts: 42
Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
« Reply #37 on: December 23, 2015, 04:35:13 AM »

I disabled the cto mod,i have the jet age 1.33 hotfix,i had the 2.7 version of the engine,but after instaling that patch,is working!
Thank you so much mike,i cant thank you enought for helping me after all i done.
the guided missiles are working as intended and i can finaly install more aircraft that require this.
Well,catapults now dot seem to work,but im sure i can solve that myself,i dont even use them much annyways.
Thank you mike and all of sas for being so great,i really like this comunity.
i wish you all luck and a merry christmas!
Logged

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 13582
  • Ask me if I care.
    • Friendly Fire isn't.
Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
« Reply #38 on: December 23, 2015, 05:30:17 AM »

I'm glad that you got it working, congratulations to your first successfully fixed IL2 issue ;)
Now that the missiles are working, you might want to try re-enabling the CTO Mod in order to see whether this has any negative effect and/or wether this puts back the catapults in place.

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - Over the Line!

Krauss brs

  • member
  • Offline Offline
  • Posts: 42
Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
« Reply #39 on: December 23, 2015, 05:50:24 AM »

Yes,i did just that and it works,is just that i was using a catapult meant for ww2 aircraft.
I guess i should look into instaling new carriers.
Still,thank you so much mike,youre the best!
Logged

Danneskjold

  • member
  • Offline Offline
  • Posts: 1
Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
« Reply #40 on: April 15, 2016, 08:36:30 AM »

There's several things you should pay attention to.
First and foremost, your !SAS_Engine_Mod has to contain a file "35AE75DA10682FAA", otherwise something went massively wrong when you installed that mod.
Second, while you did install the Jetwar 1.3 package, you apparently forgot to install the Jetwar 1.33 hotfix.
Third, while you did install some Engine Mod, you did not install the latest version.
There's been many things done to the Engine Mod after it's last official release 2 years ago, the latest patch can usually be found around the end of this thread:
http://www.sas1946.com/main/index.php/topic,39075.0.html

Last but not least, if I were you I would disable the CTO mod in JSGME (so that the folder "CTO_Modact5" disappears) since as much as I got from western's Engine Mod patch thread, there should be some newer code inside his latest patch already.

Best regards - Mike

Hi!

I'm getting the same error, but none of this seems to fix anything.

When I try to load up the latest SAS engine mod, it causes the game to crash on start up.  Where are the error logs so I can show what's happening?

The other mods I have installed are Jet War 1956 with all the patches, The F-100D/F, the F9F package, SAS Engine Mod v27.7, and SAS Common Utilities 109.
Logged

creeperdude

  • member
  • Offline Offline
  • Posts: 17
Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
« Reply #41 on: April 16, 2016, 07:05:39 AM »

Hello,when i installed this mod,fyring a missile would result in a game crash,i tried with both the 1.1 and 1.2 versions and it did the same,what am i doing wrong?
Code: [Select]
Load bridges
Load static objects
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from File: 'f9f'
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from Alternative File: 'f9f'
FM called 'FlightModels/PWJ48:F9F.emd' is being loaded from File: 'f9f'
FM called 'FlightModels/PWJ48:F9F.emd' is being loaded from Alternative File: 'f9f'
Flight Model File FlightModels/F9F8T.fmd:F9F contains no Mach Drag Parameters.
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from File: 'f9f'
FM called 'FlightModels/F9F8T.fmd:F9F' is being loaded from Alternative File: 'f9f'
Hook '_CANNON03' NOT found in mesh of class com.maddox.il2.objects.air.F9F8T
Hook '_CANNON04' NOT found in mesh of class com.maddox.il2.objects.air.F9F8T
FM called 'FlightModels/MiG-17.fmd' is being loaded from Alternative File: 'gui/game/buttons'
FM called 'FlightModels/KlimovEngine.emd' is being loaded from Alternative File: 'gui/game/buttons'
Flight Model File FlightModels/MiG-17.fmd contains no Mach Drag Parameters.
FM called 'FlightModels/MiG-17.fmd' is being loaded from Alternative File: 'gui/game/buttons'
1>                                                                                                                                                                                                                                                                                                 
Command not found:                                                                                                                                                                                                                                                                                                   
Mission: QuickQMBPro/BoB/BoBRedNone00.mis is Playing
warning: no files : music/inflight
java.lang.NoSuchMethodError
at com.maddox.il2.objects.weapons.Missile.startEngineDone(Missile.java:1375)
at com.maddox.il2.objects.weapons.Missile.doStart(Missile.java:673)
at com.maddox.il2.objects.weapons.Missile.start(Missile.java:1316)
at com.maddox.il2.objects.weapons.RocketGun.interpolateStep(RocketGun.java:184)
at com.maddox.il2.objects.weapons.RocketGun.tick(RocketGun.java:206)
at com.maddox.il2.engine.Interpolators.tick(Interpolators.java:222)
at com.maddox.il2.engine.Actor.interpolateTick(Actor.java:434)
at com.maddox.il2.engine.InterpolateAdapter.msgTimeOut(InterpolateAdapter.java:174)
at com.maddox.rts.MsgTimeOut.invokeListener(MsgTimeOut.java:73)
at com.maddox.rts.Message._send(Message.java:1217)
at com.maddox.rts.Message.sendToObject(Message.java:1191)
i have the 4.12 steam version,i hope thesres something i van do,i really want my f9f's to have misiles

Any fix to this yet?
Logged

4S_Vega

  • Modder
  • member
  • Online Online
  • Posts: 3289
Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
« Reply #42 on: September 22, 2016, 05:16:39 PM »

Version 1.3 at first post
Logged

Whiskey_Sierra_972

  • Modder
  • member
  • Offline Offline
  • Posts: 5458
  • In memory of my beloved hero: Saburo SAKAI!
Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
« Reply #43 on: September 23, 2016, 11:44:46 AM »

Installed and seem got working flawless....

I only noticed a couple of rockets misplaced inside their launcher....the most noticeable is the Zuni....

....is related to this mod or to the plane arming code?

Moreover , now can you take a look at the Crusader?

The Zuni loadout is always missing and maybe a couple of droptank can be added with the Sidewinders loadouts....



Logged

4S_Vega

  • Modder
  • member
  • Online Online
  • Posts: 3289
Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
« Reply #44 on: September 23, 2016, 05:24:52 PM »

Crusader's rocket pods is one of the bugs that i never understood till now  :(
Logged

SAS~Gerax

  • SAS Team
  • member
  • Offline Offline
  • Posts: 4290
Re: Weapons Pack V 1.2 2015.14.11 + 4.10 version
« Reply #45 on: October 17, 2016, 10:02:50 AM »

It have some interference with the loadouts of the Corsair (F4U) and after the 6th (154 gal tank and 1000 lbs bomb) it stop....

Have exactly this bug also with Weapons Pack V 1.3.

Edit: solved it with loading the
"Corsairs_weapons complement"
before this weapons pack ..
Logged
i7-4790K 4.00GHz, Asus Z97 Extreme 6, 16GB DDR3; 750GB SSDs, 2TB SSHD, 8TB int.+ext.HDs; Sound Blaster ZxR, beyerdynamic DT 880; Nvidia GTX-980 4GB, Acer 3840x2160 GSync; Win7 64bit.

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 13582
  • Ask me if I care.
    • Friendly Fire isn't.
Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
« Reply #46 on: November 29, 2016, 06:37:53 AM »

Would be nice if credits could be added to this mod.

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - Over the Line!

Hubberranz

  • Modder
  • member
  • Online Online
  • Posts: 792
Re: Weapons Pack V 1.3 2016.09.23 + 4.10 version
« Reply #47 on: February 22, 2017, 11:09:05 PM »

Hi 4S_Vega

I operate: ! 00_WeaponsPack_V1.3_20160923  in 412.2 SAS.5.3 heavily modded.

I just made install of B-26B Marauder version2.2 for 412 : http://www.sas1946.com/main/index.php/topic,17791.msg529533.html#msg529533  by SAS~Gerax; works on clean 412.
Main B-26B post points to that location ( at bottom see HERE ).
Within this mod, is included the patch: Weapons classfiles patch (add in the "weapons complement" folder overwriting) http://www.mediafire.com/?c37znerjabydc65 of main post.
[ 260LbsBombFrag + M26Incendiary ]

This patch contains three classfiles: 03EDC4A4249322E4 7/13/2011 8:57am 1.69Kb  ; this one conflicts with  03EDC4A4249322E4 2/28/2011 3:50am 1.37Kb of WeaponsPack.
                                                    B86C976C19BD6ACC  not found in pack.   BombGunM26Inc .
                                                    C5BF4CD24886E65A   not found in pack.   BombM26Inc .
                                                    'M26Incendiary' file not found in arms pack.
Conflict is: weapons dropdown shows only first 4 entries; 260LbsBombFrag don't work and stops the dropdown; no error reported. ( ... 03EDC4A4249322E4 2/28/2011 in use. )

Before: dropdown stops at *16x250lbs .
I have neutralized -arms file in B-26B mod ; restored, same results;   
had to do this--> -03EDC4A4249322E4 to classfile of Weapon's pack. Opposite: neutralize file or files in in B-26B mod, did not work.


After: dropdown reachs '100xParaF' then 'none' (  412.2 SAS modact 5.3 ).

Newer 03EDC4A4249322E4 7/13/2011 of mod is therefore in use (along with the other two classfiles), and more classes as seen below:
everything now works normally...

February 2011 versus July 2011.
Does your class file needs such update? ( Plus the two ? ) Or will these B-26B classfile(s) ( newer ) cause some problems elsewhere... (?)

update: 78D212DA9AA53450 ( 260LbsBombFrag ) is present in both mod and pack; B-26B's one is more recent and bypassed: no conflict detected...
            CD1096DA6DB769E4 + F024CEE239989064 ( BombTorpMk13Late ) are found only in Marauder, not present in "AerialTorpedoes mod".
           
Regards.
Logged
Pages: 1 2 3 [4]   Go Up
 

Page created in 0.027 seconds with 20 queries.