Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 [2] 3 4 5 ... 18   Go Down

Author Topic: I just got Reshade/SweetFX working in OpenGL...  (Read 57003 times)

0 Members and 1 Guest are viewing this topic.

Knochenlutscher

  • "Klaatu... verata... n... Necktie. Nectar. Nickel. Noodle."
  • Modder
  • member
  • Offline Offline
  • Posts: 1757
  • aka Segfej
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #12 on: June 30, 2015, 02:25:49 AM »

That's funny, yours working straight in main folder.
I have DBW with latest Selector, only works in bin for me.
@WindWpn check for bin, that should solve it  ;)

I took the original Read Me and studied a bit, here's what I found.
Code: [Select]
If it still does not work, make sure the DLL is loaded at all (a log file with
the DLL name is created). Repeat the  process with another name from the list.
Sometimes the game loads its DLLs from a different directory (a "bin" folder
for instance), so try to install ReShade to that one instead.

Download
Code: [Select]
ReShade 0.19.1 Public Beta with SweetFX 2.0 Beta 8.7z
and extract the "ReShade32.dll" file and rename it to "opengl32.dll"  This goes in your bin folder
and extract Reshade.fx, Sweet.fx and the SweetFX folder and put these in your bin folder too.

Absolutely gorgeous lil Tool. Contrasts are richer and smacking now eyecandy.
On our desert Maps it looks like FH2 Maps now, great. Say goodbye to yellow Maps.
Thanks a bunch Bee



Logged
Wiseman: Did you speak the exact words? Ash: Look, maybe I didn't say every single little tiny syllable, no. But basically I said them, yeah.

decipher

  • Missioneer
  • member
  • Offline Offline
  • Posts: 297
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #13 on: June 30, 2015, 02:43:03 AM »

interesting to see how much it sharpens the ground textures in some shots. i have to test this for myself sometime, see if it changes this so drastically for me too, since i already have added higher anisotropic filtering and anti-aliasing with nvidia inspector.

thanksfortheheadsup. will give this a try sometime
Logged

bomberkiller

  • Storebror's certified hero
  • Modder
  • member
  • Offline Offline
  • Posts: 2729
  • Bf-109G-6R6 = Bomber-Killer
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #14 on: June 30, 2015, 04:08:32 AM »

...with my 4.10.1 & DBW 1.71. My videocard: Nvidia 660 GTX.

Logged
FAC  N° 9 ...cheers

WindWpn

  • Modder
  • member
  • Offline Offline
  • Posts: 952
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #15 on: June 30, 2015, 07:05:38 AM »

That's funny, yours working straight in main folder.
I have DBW with latest Selector, only works in bin for me.
@WindWpn check for bin, that should solve it  ;)

No joy loading from bin utilizing TotalModder.  There is likely some other locale required or config requirement to make this work with TM.  If anyone finds solution, please post.  If not, when I have some further time to investigate, I may find the solution.

~S~
wind
Logged

benitomuso

  • SAS Team
  • member
  • Offline Offline
  • Posts: 2567
  • P.A.L.
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #16 on: June 30, 2015, 09:03:03 AM »

Wind,
              I have used it with TotalMODder without any troubles. There isn't anything TM3 could interfere with this.

  First, considering I have a Windows 7 64bit plenty of resources, I tried by renaming the 64 bit version to Opengl32.dll or specifying ReShade64.dll as the OpenGl Provider in Conf.ini, but it didn't worked, I had to specifically rename the ReShade32.dll to Opengl32.dll in the root of Il-2 1946 with the other amenities, and it worked OK.

  Regards,
                        Pablo

That's funny, yours working straight in main folder.
I have DBW with latest Selector, only works in bin for me.
@WindWpn check for bin, that should solve it  ;)

Wind

No joy loading from bin utilizing TotalModder.  There is likely some other locale required or config requirement to make this work with TM.  If anyone finds solution, please post.  If not, when I have some further time to investigate, I may find the solution.

~S~
wind
Logged

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 15232
  • Ask me if I care.
    • Friendly Fire isn't.
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #17 on: June 30, 2015, 09:06:57 AM »

No need to put it into the "bin" folder, really, not at all.
My money is on a different pile:
When reshade absolutely refuses to work for you, check the folder where you put the file "Opengl32.dll" in (the renamed Reshade32.dll, usually your IL-2 game folder) and watch out for a file "opengl32.log").
If that file doesn't exist, reshade didn't load at all.
If it exists, take a look inside.
If it contains a line like this
Code: [Select]
ERROR | Your graphics card does not seem to support OpenGL 4.3. Initialization failed.your graphics card just cannot handle Reshade.

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - In loving memory of the times when I cared...

WindWpn

  • Modder
  • member
  • Offline Offline
  • Posts: 952
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #18 on: June 30, 2015, 09:39:42 AM »

Yea interestingly, I appear to get a clean initialization of Reshade per the opengl32.log noted in:   http://www.sas1946.com/main/index.php/topic,46936.msg521559.html#msg521559

However, appears that il2fb.exe fails to load with an APPCRASH reported from Windows problems.

Thus, likely an issue associated with the il2 application load attempt.  Note, the il2 log.lst is empty, and the Initlog.lst appears loads as follows
Code: [Select]
2015-06-30 11:27:59:364 : ******************************************************************
2015-06-30 11:27:59:364 : *** New Wrapper by 'benitomuso' was activated, loading game... ***
2015-06-30 11:27:59:364 : **  Loading MODs Profile from: 'D:\Software Data\My Games\IL2 - 1946\IL-2 Sturmovik 1946\il2fb.mods'
2015-06-30 11:27:59:364 : **  Root Folder for MODs: 'D:\Software Data\My Games\IL2 - 1946\IL-2 Sturmovik 1946\jsgmemods\'
2015-06-30 11:27:59:364 : **  A total of 61588 files will MODify the Il-2 Sturmovik game when loading!
2015-06-30 11:27:59:364 : **  A total of 1 SFS files will be mounted when .preload is invoked!
2015-06-30 11:27:59:364 : ******************************************************************
2015-06-30 11:27:59:375 : JVM Parameters injector activated
2015-06-30 11:27:59:375 : Applying JVM Memory Settings from IL-2 Selector...
2015-06-30 11:27:59:375 : Adding JVM Option: -Xms444M
2015-06-30 11:27:59:375 : Adding JVM Option: -Xmx444M
2015-06-30 11:27:59:375 : Adding JVM Option: -Xss4096K
2015-06-30 11:27:59:375 : Adding JVM Option: -XX:PermSize=64M
2015-06-30 11:27:59:375 : Adding JVM Option: -XX:MaxPermSize=64M
2015-06-30 11:27:59:376 : Checking duplicate JVM Options...
2015-06-30 11:27:59:376 : Checking mandatory JVM Options...
2015-06-30 11:27:59:376 : Adding JVM Option: -Djava.class.path=.
2015-06-30 11:27:59:376 : Adding JVM Option: -Xincgc
2015-06-30 11:27:59:376 : Adding JVM Option: -Xverify:none
2015-06-30 11:27:59:376 : Adding JVM Option: -Xcomp
2015-06-30 11:27:59:376 : Final JVM Option List:
2015-06-30 11:27:59:376 : -Xms444M
2015-06-30 11:27:59:377 : -Xmx444M
2015-06-30 11:27:59:377 : -Xss4096K
2015-06-30 11:27:59:377 : -XX:PermSize=64M
2015-06-30 11:27:59:377 : -XX:MaxPermSize=64M
2015-06-30 11:27:59:377 : -Djava.class.path=.
2015-06-30 11:27:59:377 : -Xincgc
2015-06-30 11:27:59:378 : -Xverify:none
2015-06-30 11:27:59:378 : -Xcomp
2015-06-30 11:27:59:404 : Hooked "SAS_CreateJavaVM" function activated, injecting JVM Parameters
2015-06-30 11:27:59:419 : JVM Parameters injected successfully

At this point, something appears to crash between completion of the initlog and the log.lst?

~S~
wind

Logged

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 15232
  • Ask me if I care.
    • Friendly Fire isn't.
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #19 on: June 30, 2015, 10:08:04 AM »

Hm... strange.
Did you try updating your Selector to the latest version?
I've just kicked out a new one today due to a bug caused by a faulty Vista June 2015 update.

The opengl32.log should continue like this normally:
Code: [Select]
... | INFO  | Redirecting 'RegisterClassW(0018F924)' ...
... | INFO  | Installing delayed hooks for "C:\Windows\system32\opengl32.dll" ...
... | INFO  | > Found 360 match(es). Installing ...
... | INFO  | > Installed 360 hook(s).
... | INFO  | Redirecting ...
So apparently your Reshade freaks out right when the game window should be created.

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - In loving memory of the times when I cared...

Knochenlutscher

  • "Klaatu... verata... n... Necktie. Nectar. Nickel. Noodle."
  • Modder
  • member
  • Offline Offline
  • Posts: 1757
  • aka Segfej
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #20 on: June 30, 2015, 08:37:49 PM »

You're right Mike, bin was useless no log created.

OK, as I'm off on vacation I did a marathon to track up our issue.
Appearently it's the same log as yesterday, with latest Version of Selector.
That was not the culprit. Installation of 0.19 was only curious as it didn't showed what was wrong.
I tried the setup installation as well as the manual, at least it's not
demanding. No hope in sight.

I got a hint in the BF2 Modding Community, that in order to see if it's working at the end,
one can chose from an earlier built or special BF2 built. I did so, first Tests of BF2 builds were
worser than here, no Log at all. Just crashing FH2 or PR 1.3 Selectors.
Basicly it should work from my specs, as I have fella chaps in the BF2 community using it.
I can run BF3 and never had probs.
One fella talked about using earlier builds to test. Did so, there I got prompted a plethora of missing dlls from my system...  ???
I did further testing with ReShade_0.18.0_Public_Beta_with_SweetFX_2.0_Beta_8 from their Archives
http://sfx.thelazy.net/downloads/
and was prompted a Windows Error that my MSVCP110.dll is missing.??
Searched that file, manually inserted to my Vista, now I kept getting MSVCR110.dll is missing?
Visual C++ Redistributable für Visual Studio 2012 Update 4 is usually referred to both files
I have 5 of them installed none version 2012, maybe there's the trouble? Who knows what's missing next...
Installed this
Code: [Select]
Visual C++ Redistributable für Visual Studio 2012 Update 4 and see...
it works, I got message popping at Startscreen, DBW loading.
I remember, as far I got a hold about official Vista Updates I'm up to date, Visual C++ Installs I did, but somehow no Game or application
ever referred a line about it's need so far. Now I'm in urgent need of coffee...
Hope this Helps

Still I don't know why I can't run 0.19.0 or 0.19.1, so far only 0.18.0 works for me. Need to investigate further,
maybe it's another Microsoft Application needed, that I miss?!
Logged
Wiseman: Did you speak the exact words? Ash: Look, maybe I didn't say every single little tiny syllable, no. But basically I said them, yeah.

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 15232
  • Ask me if I care.
    • Friendly Fire isn't.
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #21 on: June 30, 2015, 11:46:42 PM »

Reshade 0.18 seems to be living in the dependency hell.
My dependency walker doesn't even survive opening that file and I cannot tell you what it is linked against and what not.
0.19 is much better in those terms, looking at it from within the dependency walker you'll notice that 99.9% of the DLL dependencies are from delayed loads and apparently missing library errors are caught and logged there. There's a couple of linked libraries I'm not quite sure of what they're used for though, e.g. GPS libraries are linked as well...

Playing around with Reshade 0.19.1 so far I can tell that it's working from the scratch for me as soon as I install it correctly:
  • Copy ReShade32.dll to <IL-2 Game Folder>\opengl32.dll
  • Copy ReShade.fx to <IL-2 Game Folder>\ReShade.fx
  • Copy Sweet.fx to <IL-2 Game Folder>\Sweet.fx
  • Copy SweetFx folder to <IL-2 Game Folder>, so that it forms up a new subfolder of your IL-2 Game Folder

I missed steps 2 and 3 once and wondered why no effect applied, just as a heads up...
For testing I'd recommend to set "USE_SPLITSCREEN      1" in SweetFX_settings.txt and "SweetFX_Greeting          1" in "Global_settings.txt" so you know whether it's working or not immediately at game start.

Any anti aliasing mode was not working on my GTX 970.
SMAA only makes all text ugly with spikes around it, but jagged lines on meshes and textures stay.
FXAA has no effect at all.
All other Reshade effects seem to be working fine for me.

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - In loving memory of the times when I cared...

Knochenlutscher

  • "Klaatu... verata... n... Necktie. Nectar. Nickel. Noodle."
  • Modder
  • member
  • Offline Offline
  • Posts: 1757
  • aka Segfej
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #22 on: July 01, 2015, 01:15:15 AM »

ReShade_0.18.0_Public_Beta_with_SweetFX_2.0_Beta_8
ReShade_0.18.1_Public_Beta_with_SweetFX_2.0_Beta_8

ReShade_0.18.3_Public_Beta_with_SweetFX_2.0_Beta_8
ReShade_0.18.4_Public_Beta_with_SweetFX_2.0_Beta_8
ReShade_0.18.7_Public_Beta_with_SweetFX_2.0_Beta_8
ReShade_0.19.0_Public_Beta_with_SweetFX_2.0_Beta_8
ReShade_0.19.1_Public_Beta_with_SweetFX_2.0_Beta_8


latest Test on 0.19.1
Enabled both Lines "USE_SPLITSCREEN      1" in SweetFX_settings.txt and "SweetFX_Greeting          1" in "Global_settings.txt"

Selector still crashes instantly.
Here's a screen showing my Gamefolder:


Logfile:
Code: [Select]
[01.07.2015 7:01:48] ------------ BEGIN log session -------------
OpenGL provider: opengl32.dll

opengl Logfile:
Code: [Select]
01/07/2015 09:01:48:983 [03900] | INFO  | Initializing Crosire's ReShade version '0.19.1.898' built on '2015-06-29 21:17:31' loaded from "D:\Spiele\DBW 1.71 LW\opengl32.dll" to "D:\Spiele\DBW 1.71 LW\il2fb.exe" ...
01/07/2015 09:01:49:005 [03900] | INFO  | Registering hooks for "C:\Windows\system32\d3d8.dll" ...
01/07/2015 09:01:49:005 [03900] | INFO  | > Delayed.
01/07/2015 09:01:49:005 [03900] | INFO  | Registering hooks for "C:\Windows\system32\d3d9.dll" ...
01/07/2015 09:01:49:005 [03900] | INFO  | > Delayed.
01/07/2015 09:01:49:005 [03900] | INFO  | Registering hooks for "C:\Windows\system32\d3d10.dll" ...
01/07/2015 09:01:49:006 [03900] | INFO  | > Delayed.
01/07/2015 09:01:49:006 [03900] | INFO  | Registering hooks for "C:\Windows\system32\d3d10_1.dll" ...
01/07/2015 09:01:49:007 [03900] | INFO  | > Delayed.
01/07/2015 09:01:49:007 [03900] | INFO  | Registering hooks for "C:\Windows\system32\d3d11.dll" ...
01/07/2015 09:01:49:007 [03900] | INFO  | > Delayed.
01/07/2015 09:01:49:007 [03900] | INFO  | Registering hooks for "C:\Windows\system32\dxgi.dll" ...
01/07/2015 09:01:49:007 [03900] | INFO  | > Delayed.
01/07/2015 09:01:49:007 [03900] | INFO  | Registering hooks for "C:\Windows\system32\opengl32.dll" ...
01/07/2015 09:01:49:007 [03900] | INFO  | > Delayed.
01/07/2015 09:01:49:007 [03900] | INFO  | Registering hooks for "C:\Windows\system32\user32.dll" ...
01/07/2015 09:01:49:007 [03900] | INFO  | > Libraries loaded.
01/07/2015 09:01:49:022 [03900] | INFO  | > Found 5 match(es). Installing ...
01/07/2015 09:01:49:047 [03900] | INFO  | > Installed 5 hook(s).
01/07/2015 09:01:49:047 [03900] | INFO  | Registering hooks for "C:\Windows\system32\ws2_32.dll" ...
01/07/2015 09:01:49:048 [03900] | INFO  | > Libraries loaded.
01/07/2015 09:01:49:051 [03900] | INFO  | > Found 8 match(es). Installing ...
01/07/2015 09:01:49:092 [03900] | INFO  | > Installed 8 hook(s).
01/07/2015 09:01:49:092 [03900] | INFO  | Initialized.
01/07/2015 09:01:49:108 [03900] | INFO  | Redirecting 'RegisterClassW(0012F928)' ...


I use Default as global settings for IL-2 for my GTS 450

Here my 0.81 Logs that I got working:
Code: [Select]
01/07/2015 04:11:12:890 [00216] | INFO  | Initializing Crosire's ReShade version '0.18.0.832' built on '2015-04-19 20:12:31' loaded from "D:\Spiele\DBW 1.71\IL-2 Sturmovik\Opengl32.dll" to "D:\Spiele\DBW 1.71\IL-2 Sturmovik\il2fb.exe" ...
01/07/2015 04:11:12:902 [00216] | INFO  | Registering hooks for "C:\Windows\system32\d3d8.dll" ...
01/07/2015 04:11:12:903 [00216] | INFO  | > Delayed.
01/07/2015 04:11:12:903 [00216] | INFO  | Registering hooks for "C:\Windows\system32\d3d9.dll" ...
01/07/2015 04:11:12:903 [00216] | INFO  | > Delayed.
01/07/2015 04:11:12:903 [00216] | INFO  | Registering hooks for "C:\Windows\system32\d3d10.dll" ...
01/07/2015 04:11:12:904 [00216] | INFO  | > Delayed.
01/07/2015 04:11:12:904 [00216] | INFO  | Registering hooks for "C:\Windows\system32\d3d10_1.dll" ...
01/07/2015 04:11:12:904 [00216] | INFO  | > Delayed.
01/07/2015 04:11:12:904 [00216] | INFO  | Registering hooks for "C:\Windows\system32\d3d11.dll" ...
01/07/2015 04:11:12:904 [00216] | INFO  | > Delayed.
01/07/2015 04:11:12:904 [00216] | INFO  | Registering hooks for "C:\Windows\system32\dxgi.dll" ...
01/07/2015 04:11:12:905 [00216] | INFO  | > Delayed.
01/07/2015 04:11:12:905 [00216] | INFO  | Registering hooks for "C:\Windows\system32\opengl32.dll" ...
01/07/2015 04:11:12:905 [00216] | INFO  | > Delayed.
01/07/2015 04:11:12:905 [00216] | INFO  | Registering hooks for "C:\Windows\system32\user32.dll" ...
01/07/2015 04:11:12:905 [00216] | INFO  | > Libraries loaded.
01/07/2015 04:11:12:919 [00216] | INFO  | > Found 4 match(es). Installing ...
01/07/2015 04:11:12:939 [00216] | INFO  | > Installed 4 hook(s).
01/07/2015 04:11:12:939 [00216] | INFO  | Registering hooks for "C:\Windows\system32\ws2_32.dll" ...
01/07/2015 04:11:12:939 [00216] | INFO  | > Libraries loaded.
01/07/2015 04:11:12:942 [00216] | INFO  | > Found 8 match(es). Installing ...
01/07/2015 04:11:12:982 [00216] | INFO  | > Installed 8 hook(s).
01/07/2015 04:11:12:982 [00216] | INFO  | Initialized.
01/07/2015 04:11:12:998 [00216] | INFO  | Redirecting 'RegisterClassW(0012F928)' ...
01/07/2015 04:11:13:003 [00216] | INFO  | Installing delayed hooks for "C:\Windows\system32\opengl32.dll" ...
01/07/2015 04:11:13:008 [00216] | INFO  | > Found 360 match(es). Installing ...
01/07/2015 04:11:13:010 [00216] | INFO  | > Installed 360 hook(s).
01/07/2015 04:11:13:021 [00216] | INFO  | Redirecting 'wglChoosePixelFormat(DE01170A, 0012F950)' ...
01/07/2015 04:11:13:201 [00216] | INFO  | Redirecting 'wglSetPixelFormat(DE01170A, 9, 0012F950)' ...
01/07/2015 04:11:13:201 [00216] | WARN  | > Application mistakenly called 'wglSetPixelFormat' directly. Passing on to 'SetPixelFormat':
01/07/2015 04:11:13:201 [00216] | INFO  | Redirecting 'wglSetPixelFormat(DE01170A, 9, 0012F950)' ...
01/07/2015 04:11:13:202 [00216] | INFO  | Redirecting 'wglCreateContext(DE01170A)' ...
01/07/2015 04:11:13:206 [00216] | INFO  | Redirecting 'wglMakeCurrent(DE01170A, 00010000)' ...
01/07/2015 04:11:13:399 [00216] | INFO  | > Switched to new runtime 2F667338.
01/07/2015 04:11:15:375 [00216] | INFO  | Resizing runtime 2F667338 on device context DE01170A to 1920x1080 ...
01/07/2015 04:11:15:867 [00216] | INFO  | Recreated effect environment on runtime 2F667338.
01/07/2015 04:11:16:120 [00216] | INFO  | Loading effect from "D:\Spiele\DBW 1.71\IL-2 Sturmovik\ReShade.fx" ...
01/07/2015 04:11:30:491 [00216] | INFO  | > Successfully compiled effect.
01/07/2015 04:12:55:257 [00216] | INFO  | Redirecting 'wglMakeCurrent(00000000, 00000000)' ...
01/07/2015 04:12:55:257 [00216] | INFO  | > Cleaning up runtime 2F667338 ...
01/07/2015 04:12:55:257 [00216] | INFO  | Destroyed effect environment on runtime 2F667338.
01/07/2015 04:12:55:276 [00216] | INFO  | Redirecting 'wglDeleteContext(00010000)' ...
01/07/2015 04:12:55:445 [00216] | INFO  | Exiting ...
01/07/2015 04:12:55:445 [00216] | INFO  | Uninstalling 406 hook(s) ...
01/07/2015 04:12:55:652 [00216] | INFO  | Exited.

The Logfile:
http://www.mediafire.com/download/2owg7kaaxtfeqo8/log.rar

 :-\
Logged
Wiseman: Did you speak the exact words? Ash: Look, maybe I didn't say every single little tiny syllable, no. But basically I said them, yeah.

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 15232
  • Ask me if I care.
    • Friendly Fire isn't.
Re: I just got Reshade/SweetFX working in OpenGL...
« Reply #23 on: July 01, 2015, 02:08:50 AM »

Remember that Reshade is still beta ;)
You seem not to be alone: http://reshade.me/forum/troubleshooting/822-new-versions-crash-under-game-start

How about switching to stock game mode using the selector first, just to rule out the obvious?
If anything else fails and Reshade 0.18 works for you while 0.19 doesn't, then maybe you should stick with that old version until the Reshade devs found the reason why, and in order to assist them, you might want to report your troubles there.
Who knows, maybe 0.19 isn't that compatible with the lower end of the supported graphics card list anymore?

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - In loving memory of the times when I cared...
Pages: 1 [2] 3 4 5 ... 18   Go Up
 

Page created in 0.032 seconds with 25 queries.