Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: 1 2 3 4 [5] 6 7 8   Go Down

Author Topic: My experience with IL-2 and Stuttering  (Read 12832 times)

0 Members and 1 Guest are viewing this topic.

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 6221
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: My experience with IL-2 and Stuttering
« Reply #48 on: April 23, 2015, 02:35:31 AM »

I know what you mean mate, that part of the Berlin map was always an fps killer.
Too many buildings in a small area. The only fix is to open the map in unlocked FMB and start deleting buildings. You can also replace the buildings with the new city blocks by CanonUK which were made for his English Channel map. That would be a cool modding project. :)

Imho you should try HSFX7. With Il-2 1946 you can have an infinite number of installs at the same time on your hd since it doesnt use registry entries.

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 6221
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: My experience with IL-2 and Stuttering
« Reply #49 on: April 23, 2015, 02:40:14 AM »

Btw I mentioned Imphal fps problems before ( http://www.sas1946.com/main/index.php/topic,45822.msg512685.html#msg512685 ) and I just saw this post:
http://www.sas1946.com/main/index.php/topic,45704.msg512821.html#msg512821
Look at the hardware confing in the posters signature.

PA_Willy

  • member
  • Offline Offline
  • Posts: 751
Re: My experience with IL-2 and Stuttering
« Reply #50 on: April 23, 2015, 02:52:19 AM »

Imho you should try HSFX7.

Right. HSFX 7.03 is a well optimized pack. Ready to play online too. It's my recommendation too.
Logged

marcost

  • Modder
  • member
  • Offline Offline
  • Posts: 869
  • Keep calm and run away
Re: My experience with IL-2 and Stuttering
« Reply #51 on: April 23, 2015, 04:34:00 AM »

I would really like to test the Berlin map in the Standard 4.12.2m game. If i cannot find a playable version of IL-2 it will be retired to the shelf permanently as this is will be my second attempt at playing this game and I am done with tweaking.


hi,

I would echo Mike's point - if the above (decent fps on Berlin) is your sole objective then put it on the shelf now. If not, try one of the many many other great maps and especially ones that have been expertly repainted by Cyberolas etc. You will get good playable fps and fantastic visuals

Regards,

M
Logged

Chupacabras84

  • member
  • Offline Offline
  • Posts: 230
Re: My experience with IL-2 and Stuttering
« Reply #52 on: April 23, 2015, 06:16:52 AM »

I would really like to test the Berlin map in the Standard 4.12.2m game.
Whats keeping you?
Berlin is a standard map, I actually used it as a test map, without planes or vehicles that could affect outcome.
Download the mission.
Unpack it into Missions folder "IL-2 Sturmovik 1946\Missions\fpstest1.mis, fpstest1_en.properties"
Set your IL2 selector to Stock Game.
Open Full Mission Builder, Load fpstest1 and select Play (Every Option is under File tab in FMB)
When the map loads you can skip trough 10 cameras I placed across the map with ctrl+f2 and note fps at every single one.

Here is my fps for comparison, CUP WAW module and Stock Game, (First camera which spawns somewhere in space doesn't count, ctrl+f2 trough first camera).
There is no flying, just skip trough camera and note fps at every single one of them (Just dont move the camera/touch the mouse, fps comparison will be a valid one only if the camera always placed in same place and facing same direction)
Code: [Select]
Berlin:
waw    Stock
29 57
18 33
16 30
12 19
19 37
24 50
52 53
67 83
61 81
44 63

Unfortunately I cant test your trk on stock game because the plane is all pink and grounded, on WAW module its pretty much same thing as you have.
I have no idea why CUP cuts my fps like this but as someone mentioned, you might start looking for another mod because I dont think CUP dev team going to do anything about it, apparently not many people complained about this issue.
Logged

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 17742
  • Failure is not an option.
    • What goes around comes around, you'll see
Re: My experience with IL-2 and Stuttering
« Reply #53 on: April 23, 2015, 06:44:03 AM »

I'm still wondering what this is all about.
There's nothing to fix here, it's all just related to that special map and the special flight path across it.

This is what I get from your NTRK file dsmith71, and I have to stress that his runs the same setting like I use for any other gameplay where I rarely ever drop below 60 FPS:







(Please note that the minimum "0" FPS result from taking the screenshots, however the current FPS (first number) are absolutely real)

As I stated before: Nothing broken, no need to fix anything.
It's all working to specifications.
Attach a 5t trailer to your Ferrari and it won't run 200mph anymore either.

Best regards - Mike
Logged
Learn. Challenge. Improve. In loving memory of the times when I cared...

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 6221
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: My experience with IL-2 and Stuttering
« Reply #54 on: April 23, 2015, 07:50:44 AM »

we got 4 fps on a GTX770 meanwhile I on a GTX550 have 24+...I want to read those specifications :D



Chupacabras84

  • member
  • Offline Offline
  • Posts: 230
Re: My experience with IL-2 and Stuttering
« Reply #55 on: April 23, 2015, 08:07:39 AM »

I'm still wondering what this is all about.
There's nothing to fix here, it's all just related to that special map and the special flight path across it.
I would disagree with you here.
Here are two pictures taken in same place, one in CUP WaW module and the second one in Stock game.
Pic 1-18fps, Pic 2-33fps.
Pic 1-19fps, Pic 2-37fps.
Truth told I dont see anything that would justify such a steep performance drop.

For some reason WAW cuts my fps in half, not DoF or JTA though (At least I haven't noticed).
If I remove large part of air.ini, the fps goes back to norm, I noticed people were claiming that in TFM GournerFX caused similar symptoms (Halved framerate which is impossible to cure by lowering visual settings and that deleting half of air.ini actualy helps).
Logged

SAS~Storebror

  • Editor
  • member
  • Online Online
  • Posts: 17742
  • Failure is not an option.
    • What goes around comes around, you'll see
Re: My experience with IL-2 and Stuttering
« Reply #56 on: April 23, 2015, 08:20:35 AM »

I'll bail out here.
The thread was about conf.ini settings to fix an alleged FPS issue which just isn't there.
Meanwhile everyone's mixing up things in each and every direction, be it different view settings (FOV anyone?), mod limits, mod packs in general etc.

My statement is clear to read for everyone who's capable to understand it: There's nothing wrong with neither dsmith71's PC, his graphics card, nvidia settings, nor conf.ini.

If you believe it helps to start endless sidetrack debates to keep this discussion going, please entertain yourself.
I'll ignore this thread from now on.

Best regards - Mike
Logged
Learn. Challenge. Improve. In loving memory of the times when I cared...

vpmedia

  • Modder
  • member
  • Offline Offline
  • Posts: 6221
  • www.vpmedia.hu/il2
    • VPMEDIA SKINS
Re: My experience with IL-2 and Stuttering
« Reply #57 on: April 23, 2015, 08:45:38 AM »


 
I'm still wondering what this is all about.
There's nothing to fix here, it's all just related to that special map and the special flight path across it.
I would disagree with you here.
Here are two pictures taken in same place, one in CUP WaW module and the second one in Stock game.
Pic 1-18fps, Pic 2-33fps.
Pic 1-19fps, Pic 2-37fps.
Truth told I dont see anything that would justify such a steep performance drop.

For some reason WAW cuts my fps in half, not DoF or JTA though (At least I haven't noticed).
If I remove large part of air.ini, the fps goes back to norm, I noticed people were claiming that in TFM GournerFX caused similar symptoms (Halved framerate which is impossible to cure by lowering visual settings and that deleting half of air.ini actualy helps).

Thanks for the testing results mate. They show the same ~20 fps difference which we mentioned before (4 vs 24 fps over Berlin). Logical conclusion is that theres a mod in CUP which causes this or its not a single mod but a combination of mods. This problem appeared in TFM-412 iirc. TFM-412 is modular so you can turn the modules on and off via jsgme. This, in theory would enable someone - who owns TFM-412 - to narrow the problem down to the module where the fps suddenly drops.

Chupacabras84

  • member
  • Offline Offline
  • Posts: 230
Re: My experience with IL-2 and Stuttering
« Reply #58 on: April 23, 2015, 09:03:21 AM »

I went trough files in GournerFX which were suppose to fix performance drop and MaxVisualDistance, MaxStaticVisualDistance, MaxLongVisualDistance, MaxPlateVisualDistance were all set to 10000.0F because previously they were set too high for many to handle.
I wonder, could those high settings made it somehow into CUP, I think this post and this post could offer us some hints.
Especially those parts.
When enable the gurnerfx, I got only 10 FPS.
If I delete 8A318408BB7C513E in gurnerfx, I can have normal frame rate...
Through test, I'm sure one of the mod in monty-6 is causing the low frame rate.
Since most mods in monty-6 are plane modes, which means as long as I don't load those new planes in a map, there shouldn't have a low frame rate. But I do get frame rate problem on every map.
With all  27 Full monty packs & gurnerfx loaded, the game have only 10 FPS.
( NEW FINDING!!!: It's not only limited to Air.ini. any .ini in #DBW folder can have a effect on the slutter problem) Seems there is a conflict between the total .ini length and the gurnerfx.
I highlighted those parts because Storebor mentioned "object limit" but, if it was actually object limit causing fps drops, I doubt it could have been fixed by disabling GurnerFX.
Also, what is characteristic is user claiming he had fps drop on every map, its the same for me, regardless of what is in the view, where I had 50fps once now I have 25-30, where I had 25 its dropping to 10-13.

This performance drop is really severe at a times, I launched "Battle of Midway" single mission and while on stock game I could play just fine, in CUP I couldn't even start my plane because of 1 fps sideshow, not even exaggerating here.
The weird thing is, it was carrier and some planes, nothing that should have caused 1 fps, even looking in the sky didnt help much.

I think, I'll try to divide air.ini into few eras, for example 1939-1940, German/Russian Front, German\US\UK, JPN\USA and will enable them with JSGME.
Technically it should improve my fps (maybe not in MP)
Logged

Mick

  • Modder
  • member
  • Offline Offline
  • Posts: 4003
Re: My experience with IL-2 and Stuttering
« Reply #59 on: April 23, 2015, 10:40:49 AM »

... may be this is why although I have an old PC (Intel core2 duo 8400 OC@3.45 Ghz, GTX260, 8gigs of RAM, and Velociraptor 10000 rpm) I nealry have no stutter at all ...

I commented out a great part of my air.ini, simply because for instance I never fly in the PTO, nor use VVS planes ...

Please give it a try and report back, if this works, then it could improve a lot of guys' experience ...  :P
Logged
Pages: 1 2 3 4 [5] 6 7 8   Go Up
 

Page created in 0.017 seconds with 28 queries.