Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: CUP modules do not show up in the Selector (SOLVED)  (Read 1521 times)

0 Members and 1 Guest are viewing this topic.

trnsprt

  • member
  • Offline Offline
  • Posts: 4
CUP modules do not show up in the Selector (SOLVED)
« on: April 17, 2015, 12:41:56 PM »

I have a clean install of 4.12.2 and ModAct 5.3. Installed the CUP via the instructions. My issue is that I only have 5 choices on the IL2 Selector. None of the CUP modules show up. Is anyone able to give me some assistance to get the CUP modules to appear in the Selector?

Thanks
Logged

SAS~Gerax

  • SAS Team
  • member
  • Offline Offline
  • Posts: 4692
Re: CUP modules do not show up in the Selector
« Reply #1 on: April 17, 2015, 12:50:44 PM »

here is the content of the root/il2fb.ini file as it comes with CUP.
Within the Modtype settings are added for the CUP modules:

Code: [Select]
; Modtype setting. Set the number of different Mod Types here.
[Modtypes]
Types=6

; Mod Type No.1 (Zero-based Index = 0).
; Set short Name, Help text, Files folder name and Mods folder name.
[Modtype_00]
Name=Stock Game
Help=Unmodded, untouched 'stock' game version.
Files=none
Mods=none

; Mod Type No.2 (Zero-based Index = 1).
[Modtype_01]
Name=HSFX V7.0
Help=Old fashioned modding style with 'FILES' and 'MODS' folders holding the mods.
Files=FILES
Mods=MODS

; Mod Type No.3 (Zero-based Index = 2).
[Modtype_02]
Name=SAS MODACT 5.3
Help=SAS MODACT 5.3, mods reside in '#SAS' folder
Files=none
Mods=#SAS

; Mod Type No.4 (Zero-based Index = 3).
[Modtype_03]
Name=Dawn of Flight 1906-1926
Help=Dawn of Flight 1906-1926, mods reside in '#DOF' folder
Files=none
Mods=#DOF

; Mod Type No.5 (Zero-based Index = 4).
[Modtype_04]
Name=World at War 1936-1946
Help=World at War 1936-1946, mods reside in '#WAW' folder
Files=none
Mods=#WAW

; Mod Type No.6 (Zero-based Index = 5).
[Modtype_05]
Name=The Jet Age 1946-2016
Help=The Jet Age 1946-2016, mods reside in '#JTW' folder
Files=none
Mods=#JTW

; Startup Settings for the SAS / UltraPack IL-2 1946 Game Launcher
[Settings]

; Mod Type Setting:
;
; 0 = No Mods, Stock IL-2 1946 Server
; 1 = "Classic" Mod Style, i.e. modded files reside in "FILES" and "MODS" folder
; 2 = SAS Modact Modded game, i.e. modded files reside in "#SAS" folder
; 3 = UltraPack Modded game, i.e. modded files reside in "#UP#" folder
; 4 = Dark Blue World Modded game, i.e. modded files reside in "#DBW" folder
; 5 = Dark Blue World 1916 Modded game, i.e. modded files reside in "#DBW_1916" folder
;
; default setting: 0
ModType=4

; Ram Size Setting in Megabytes.
; Be careful not to select too big size here.
; Above 512MB is risky.
; Above 1024MB is critical.
; Above 1800MB will most likely cause startup errors.
;
; default setting: 512
RamSize=512

; Expert Mode Setting
; With Expert Mode enabled, the selector offers more setting options than
; than with default setting
;
; default setting: 0 (Expert Mode disabled)
ExpertMode=0

; Memory Strategy setting
; This setting affects the way memory is being allocated for the Java
; virtual Machine. Balanced means that memory will be allocated in a
; blanced manner for heap, stack and objects.
; Heap only is the "old fashioned" way of binary edited il2fb.exe files
; where only the heap memory size is getting increased while all other
; memory areas remain untouched.
; Conservative is a setting right between Balanced and Heap only.
;
; default setting: 0 (Balanced Mode)
MemoryStrategy=0

; Cached File Lists setting
; When this setting is enabled, IL-2 on startup does not scan the modded files
; folder anymore, but uses a filelist cache file for this folder if it exists.
; The filename for this cache file is "~wrapper.cache".
; Every time when you change something inside your modded files folder, you
; have to wipe this file for the game to recreate it with updated contents.
;
; default setting: 0 (Cached File Lists disabled)
UseCachedFileLists=0

; Multiple Instances setting
; Usually you can run only one single IL-2 instance at a time.
; When you enable this setting, you can run IL-2 multiple times in parallel.
; This is particularly useful for developing and debugging tasks.
;
; default setting: 0 (Multiple Instances disabled)
MultipleInstances=0

; Exit With IL-2 setting
; When enabled, IL-2 selector will quit when you exit the game.
; When disabled, you'll get back to the selector when you exit the game, in
; case you started it through the selector.
;
; default setting: 0 (Exit With IL-2 disabled)
ExitWithIL2=0
SplashScreenMode=3

; The following section holds additional parameters for the JVM,
; one parameter per line. Check Java 2 SE documents for applicable parameters.
[JVM]


BUT: when you do not have this file as it should be, what else is wrong?
I fear you did something wrong when installing CUP ...

or have you changed this ini file ?
Logged
i7-4790K 4.00GHz, Asus Z97 Extreme 6, 16GB DDR3; 750GB SSDs, 2TB SSHD, 8TB int.+ext.HDs; Sound Blaster ZxR; Nvidia GTX 980 4GB, Acer 3840x2160 GSync; Win10 prof.; Logitech Extreme 3D Pro, Saitex Throttle Quadrant. Beyerdynamic DT880 Headphones.

trnsprt

  • member
  • Offline Offline
  • Posts: 4
Re: CUP modules do not show up in the Selector
« Reply #2 on: April 17, 2015, 01:51:07 PM »

Thank you. I was using a brand new Zip program. I didn't configure it properly and found that not all of the files (even though "extract all" was my setting) were being extracted to the intended folder. The IL-2 Selector was not being extracted to the root folder so I was stuck with the original.

I have done a lot of research and tries and re-tries with these problems before posting. But it just so happens each time I post I am finding the answer shortly after. However I have pulled out alot of my hair.

Sorry for the mis-fire. I am certain I will have more problems soon.  :P
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 26 queries.