Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1]   Go Down

Author Topic: Black water.  (Read 4044 times)

0 Members and 1 Guest are viewing this topic.

GeneralPsycho

  • member
  • Offline Offline
  • Posts: 92
Black water.
« on: April 09, 2011, 06:16:15 PM »

For some reason in all of my IL2 installations differing from 4.101 and 4.09 have black water. GTX570 here. I have not played this game for about 2 months. My previous card was HD4870 1gb.


Just another request, can some one upload the max settings possible config.ini? (OpenGL part is fine)
Logged

Messcaster

  • member
  • Offline Offline
  • Posts: 147
Re: Black water.
« Reply #1 on: July 14, 2011, 10:42:38 AM »

Hi,
I've got black water when I select Perfect Mod in Landescape Detail... I ve got a NVIDIA GeForce 8800 GT
How to solve this problem???
Logged

Messcaster

  • member
  • Offline Offline
  • Posts: 147
Re: Black water.
« Reply #2 on: July 14, 2011, 10:56:56 AM »

I think I have solved this problem by changing those lines:
TexFlags.TexEnvCombine4NV=1
TexFlags.DepthClampNV=1
TexFlags.TextureShaderNV=1

Water is beautiful again :)
Logged

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 14962
  • Ask me if I care.
    • Friendly Fire isn't.
Re: Black water.
« Reply #3 on: July 14, 2011, 12:03:08 PM »

You're right Messcaster, black water is a texture flag issue of exactly those three flags you've mentioned. They have to be set to "1" for Nvidia cards like GeneralPsycho's GTX570, whereas for ATI cards they have to be set to "0". Swapping from ATI to Nvidia often times gives you black water when these flags aren't altered properly, the other way 'round usually you get completely corrupted viewports.

GeneralPsycho, now that you edit your conf.ini, it's a good opportunity to watch out for water setting too, which is "water=4" for highest level Nvidia setting (might be set to "water=2" currently for you, which is highest ATI setting).

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - Over the Line!

Messcaster

  • member
  • Offline Offline
  • Posts: 147
Re: Black water.
« Reply #4 on: July 14, 2011, 02:35:58 PM »

Thanks one more time Storebror for your answer!
Could you tell me please where can I find a topic about how to find best setting for the config.ini?
Logged

SAS~Storebror

  • Editor
  • member
  • Offline Offline
  • Posts: 14962
  • Ask me if I care.
    • Friendly Fire isn't.
Re: Black water.
« Reply #5 on: July 15, 2011, 01:32:57 AM »

I've collected all "perfect" settings for your refernce here:
http://www.sas1946.com/main/index.php/topic,9756.msg185327.html#msg185327

Best regards - Mike
Logged
Learn. Challenge. Improve. - Storebror on Flickr - Over the Line!

Messcaster

  • member
  • Offline Offline
  • Posts: 147
Re: Black water.
« Reply #6 on: July 15, 2011, 09:42:01 AM »

Excellent! Thanks! :)
Logged

51st_FC

  • member
  • Online Online
  • Posts: 10
Re: Black water.
« Reply #7 on: April 15, 2018, 04:48:57 AM »

Just a Thank You  I know this Post has been around for a long time, I just started flying again after about 12 years  and had the Black water issue so nice to be able to find help.
Logged
Pages: [1]   Go Up
 

Page created in 2.302 seconds with 25 queries.