Special Aircraft Service

Please login or register.

Login with username, password and session length
Advanced search  
Pages: [1] 2 3 4 ... 13   Go Down

Author Topic: DBW AI Mod Discussion & Bugs  (Read 22916 times)

0 Members and 2 Guests are viewing this topic.

soldaten

  • member
  • Offline Offline
  • Posts: 23
DBW AI Mod Discussion & Bugs
« on: June 29, 2011, 09:05:24 AM »

Saw the same inability of the AI to make my plane take off from an airfield. It was a A6m22 zero
on the New Guinea map.

Also. when attacking fighter planes while they are midway in transit to their targets (or back to home base)
they do not react at all to any human attacks. Ordinarily in DBW 1.0 they would start maneuvering to avoid being shot down as soon as a player got with .49 of their tails.  Now in DBW 1.1, they take no evasive action at all, allowing a human to close to point blank range and shoot them down with ease.

The Zero A6m2 21 is a lot more stable as a gunnery platform in 1.1.
Previously , it would shake and jutter quite a bit when firing,
making it difficult to keep the crosshairs on target. Now, it
is a lot smoother. Not sure if that is intended or not.

Anyway, thanks for making DBW available and improving it.  Having lots of fun with it :)
Logged

vampire_pilot

  • Modder
  • member
  • Offline Offline
  • Posts: 713
Re: DBW AI Mod Discussion & Bugs
« Reply #1 on: June 29, 2011, 09:15:46 AM »

it is part of the beta AI Mods AFAIK
it was the same when you used the 4.09 CERT AI on DBWv1.0. actually also the autopilot could not move throttle at all, also not in flight then. It stuck where you left it for the AI to take over.

also the fact, that once a AI plane is on it's last leg prior to touch down (I.e. passed the last waypoint) and will not react anymore neither to your radio call or attacks is long experineced AI problem.

Some mission builders forget that and don't put one last waypoint close to home base. such flights home are easy prey once you let them spend their amo on you, doing circles and them allways shooting short with minute long bursts;)
Logged

Chewaca

  • member
  • Offline Offline
  • Posts: 94
Re: DBW AI Mod Discussion & Bugs
« Reply #2 on: June 29, 2011, 12:50:35 PM »

The planes don´t open her wings, neither AI or human controlled. And yes i have the toggle wing folds key mapped in the keyboard and in the joystick


Some dead crew men turning invisible


And dead gunners firing after dead like El Cid Campeador


I just installed the v.2 hotfix and the planes take off but the wing folds bug continue.
Sorry Cirx for put in the bug in the other thread

This problem only appears in the F-4f-3. I tried the same mission changing the plane for F-4f-4 and Corsair and the wings deploys in Autopilot or Manual mode
Logged

Ribs

  • member
  • Offline Offline
  • Posts: 195
Re: DBW AI Mod Discussion & Bugs
« Reply #3 on: June 29, 2011, 10:17:35 PM »

Just noticed that the Cat MOD is not working on the CVL's , Belleau Wood and Princeton.

Ribs
Logged
I've spent most of my money on Whiskey and Women. The rest I just wasted.

SAS~CirX

  • Editor
  • member
  • Offline Offline
  • Posts: 4335
  • No Zips, Only Buttons
Re: DBW AI Mod Discussion & Bugs
« Reply #4 on: June 30, 2011, 12:54:44 AM »

Hi guys

The AI mod seems to still have quite a few issues. Clever guys are working on it, but in the meantime I dont want to frustrate you all with it. Hotfix 3 is out. It seperates the AI mod from the DBW base classes, and thus you will be able to disable it completely if you want or need to.

To install it, it is very important that you first delete your entire XTD folder, and also the 0_DBW1.1_HOTFIXES foled if you had downloaded that.

It also includes a new buttons that fixes the F4F3 wingfold issue. Instructions and details in the hotfixes thread.
Logged

Boelcke

  • Modder
  • member
  • Offline Offline
  • Posts: 1321
Re: DBW AI Mod Discussion & Bugs
« Reply #5 on: June 30, 2011, 01:29:08 PM »

I can´t load the Palau map, i´ve always got an load.ini error message.

The japanese zeros can´t start from a carrier, they all are splashing into the sea. The US planes can start from carriers. When i tried it with autopilot, i discovered that the autopilot now doesn´t start at all with your own plane, on carriers and on airfields. For all planes and nations.

I have tested zeros now from carriers in single msions , careers, qmb, never had a problem yet. So , let us know when you figure that one out, or give more details.

Th autopilot bug is a bummer. I am posting a very brutal hotfix for it in a few minutes.
Hope there will be time to do a more propet update for it later the week.

Palau map fix will also be in the hotfix.


i have tested a little bit more about the zeros, it appears when choosing the stock dgen "Imperial japanese Navy Fighter" and only with the A6M5-52 on the Marianas subcampaign/map (clean DBW). Every single plane of my flight crashes into the sea when starting.

I tested the same with UP 3 (clean) and they all started well.

EDIT: I didn´t test the new hotfix, sorry, but had a car accident today and i´m not yet in the condition to do more today.
Logged

SAS~CirX

  • Editor
  • member
  • Offline Offline
  • Posts: 4335
  • No Zips, Only Buttons
Re: DBW AI Mod Discussion & Bugs
« Reply #6 on: June 30, 2011, 02:06:32 PM »

I hope your OK man! Is there much damage to the car? Good luck with whatever follows mate.

About the zero's, I am pretty sure it would be caused by the AI mod. In the hotfiix, it is seperated, and can be disabled.
Logged

Chewaca

  • member
  • Offline Offline
  • Posts: 94
Re: DBW AI Mod Discussion & Bugs
« Reply #7 on: July 02, 2011, 08:40:59 AM »

Hotfix 3.1 installed. The F4f3 wing issue resolved, but the dauntless that i must to protect, crashed one after one at take off from the carrier. Sorry Cirx  for give you another headache.
Logged

Riptide_One

  • member
  • Offline Offline
  • Posts: 476
Re: DBW AI Mod Discussion & Bugs
« Reply #8 on: July 04, 2011, 07:04:51 AM »

I've encountered a problem with Spitfires. After takeoff, they climb up to angels 20 and very shortly after that, their engines start to sound sick. Then one-by-one, each pilot reports he has been hit. Actually, his engine just stops. However, the Spitfire I am flying has no such engine problem. So far, I've seen this happen with the Spitfire models Mk. Ia, 1939 and Mk. Ib, 1940. Has anyone else had this problem?

Cheers,

Riptide
Logged

Zappatime

  • member
  • Offline Offline
  • Posts: 20
Re: DBW AI Mod Discussion & Bugs
« Reply #9 on: July 04, 2011, 10:26:30 AM »

I have noticed when using QMBpro that if I switch autopilot on at the start of a scramble mission (on Channel_battles map) it will start the engine but is unable to take off, it appears the wheel brakes are set on and the AUtopilot will not take them off so it just sits there with the engine ticking over. AI planes behind are not affected - if I knock autopilot off, and take off, they will do take off ok.
Logged

Riptide_One

  • member
  • Offline Offline
  • Posts: 476
Re: DBW AI Mod Discussion & Bugs
« Reply #10 on: July 04, 2011, 07:38:40 PM »

Redfox,

I wish it were that simple. However, I am using SAS Buttons Version 8.9 and I have placed that file in  ...\#DBW\STD\gui\game. So, my problem lies elsewhere. Set me know if there is something else I can try.

Cheers,

Riptide
Logged

Riptide_One

  • member
  • Offline Offline
  • Posts: 476
Re: DBW AI Mod Discussion & Bugs
« Reply #11 on: July 05, 2011, 12:22:36 AM »

I thought the Spitfire engine failures was due to AI mismanaging engine temperature. So, I tried a stepwise ascent to cruise altitude. Climb to angels 10 and maintain for five minutes. Then climb to angels 20. Once again, shortly after reaching angels 20, the planes in my flight began losing power, one-by-one, until I was alone. I flew to the patrol area and back to base without any engine problems.

In this mission, I included a replacement flight that took off from my airbase 20 minutes after my flight's departure. They also used a stepwise ascent. They all made it to the patrol area. On the way back, near the airbase, all planes in the second flight suffered engine failure during their descent. Some planes ended up littering the streets of London.

So, whatever is killing the Spitfire engines does not affect the player's plane and affects AI planes in an inconsistent manner.

I've only tried the early model Spitfires. I assume later models will be affected by this bug the same way.

Cheers,

Riptide
Logged
Pages: [1] 2 3 4 ... 13   Go Up
 

Page created in 0.09 seconds with 22 queries.